A new Filestore issue since

Continuing the discussion from Backup and Restore Module reporting file store error:

I just noticed since the update to Filestore that my old backups were not being cleaned up. I tried manually deleting and got an error. I rolled Filestore back to and I was able to delete my old backups again.

Hi @SonicJoe Raised [bug]: Filestore - old backups were not being cleaned up · Issue #261 · FreePBX/issue-tracker · GitHub to keep track of your issue. Could you please update this jira to add more details which will help us to reproduce the issue in-house. thanks

Not sure how to provide an update there. Clicking the link takes me to a the bug but it says it is closed. I am using SSH for backup. As you know I had experienced some issues with the GUI and the Filestore module. I upgraded to as you requested and that fixed those issues. However, I have my backup set to clean up old backups after 2 weeks and I happened to notice that I had about a month’s worth of backups still. I tried deleting the older backups via the GUI and I got an error saying that it failed and I may have to delete the backups manually. I then rolled Filestore back to, which was the last known working version I had used before updating to After downgrading to I was able to delete the old backups via the GUI, and ever since the automatic cleanup is working again as well.

I am happy to upgrade again and provide some logs if you tell me which logs you want or what you want me to do to test. Otherwise to reproduce all you need to do is runa backup via SSH using the latest Backup and Restore and Filestore modules, then try deleting the backup via the GUI.

Please try with the latest filestore and backup module.

fwconsole ma downloadinstall filestore --tag=
fwconsole ma downloadinstall backup --tag=
fwconsole chown
fwconsole r

Ok, will try that specific combo and additional commands shortly. I did try updating to the latest release of both but I still get the error.

I ran the commands exactly as directed but I still see the error when deleting an old backup.

Actually, interestingly enough, even though I got the error message it deleted the file any way with that combination. I’ll leave it for now and see if the auto clean-up works.

So, the final verdict is it is now working, but if you try to delete a file from the restore tab it gives the error message even though it successfully deletes the old backup. The cleanup process on the backup job is properly removing the old backups.

Please give a try with filestore v17.0.2.21. Thanks

Yes, seems to be working perfectly now. No errors when backing up, restoring, or delting old backups.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.