Auto answer incoming calls


I am new to to FreePBX and i am trying to figure out how to automatically accept incoming calls and record them. I have connected my SIP trunk succesfully.

I am only concerned about accepting the incoming call and record it, I don’t want someone speaking back to the incoming caller.

Like I said I am a complete newbie to FreePBX and voip, I hope you guys could help me with configuring.

Thanks a lot!

Recording can be enabled on the inbound route. What do you mean by ‘accept’, what happens to the inbound call?

By accept I mean that when someone is calling my voip number the system will answer the call (not an agent for example.)

That doesn’t answer my question, what happens to the call once the PBX answers?

I think nothing?, i have not connected it to a device or something if thats what your meaning?

Well I genuinely can’t figure out what you’re asking, but if the goal is to test inbound calls before you have anything configured, I will usually send the call to Feature Codes -> Echo Test.

Is this really that hard to setup? I only need the system to pickup the incoming calls automatically and record them. Thats it.

Sounds like voicemail to me.

1 Like

Yes it is, but i also need to record the conversation longer then 2 hours, is this possible?

Yes. The default is 300 seconds but you can change that in voicemail- > settings

Thank you for your response, I have set up voicemail now. I have set the destination in inbound route to voicemail (unavailable message), but I want to get rid of the message. Is this possible?

I want no greeting message in the voicemail and still want to record the call.

Record your own “personal” “empty” greeting message.
Or just disable voicemail greeting altogether.
There is also a way to direct the call to a voicemail without playing the greeting message, I did it a long time ago so I don’t remember exactly which destination needs to be selected, but I do remember that it exists.

One of the voicemail destination options is (No Message), that’s the one you want.

1 Like

Thank you for your response, where exactly can i set my own greeting message (sorry I can’t find it)

Thanks for your response, i selected that one earlier today, but then I don’t receive an audio file in my mail anymore.

Set transmit_silence = yes , if it isn’t already on. See

P.s. when i set the voicemail to: no message. It does exactly what i want, but like I said I do not receive the audio file in my email, but it does come up in my CDR reports. But when I try to download it or play the file, it doesn’t do anything.

When you call that VM box, can you play that message?

Which email service are you using?

Where did you add your email address to receive the voicemails.

Finally, I’m afraid we’re missing something here.

What are you trying to accomplish?

Sorry I am a complete newbie to voip, freepbx. I don’t now what you mean by VM box.

Email service: Gmail
Where did you add your email address to receive the voicemails: at the extension voicemail, there is an option to add a email address.

What are you trying to accomplish? I want to build an iPhone call recorder, for more details please watch this video:

VM = Voicemail.
Can you playback that message?

Did you configure a gmail account on the PBX to send the emails from?

Also, have you checked your spam folder?