AudioCode MP112 - Call Can't Be Completed As Dialed

Is anyone familiar with setting up an AudioCode MP112 device? I have it set up in the sense that I can call the analog phone that’s connected to it from another extension. However I am unable to use the analog phone to call out (“your call can’t be completed as dialed” message after what feels like an eternity of silence), whether it’s to another extension or an external number (in the format 91[AreaCode][Number]).

Hope I’m doing this paste bin thing right, but here’s what I saw when I tried the call with asterisk -rvvv (extension I set for the AudioCode is 7449).

https://pastebin.freepbx.org/view/a8e41adf

In the output there it seems almost like it’s thinking the analog phone is just dialing 99 (that is also how it shows up in the CEL Reports.

Here’s the paste bin for the AudioCode .ini file.

https://pastebin.freepbx.org/view/b0ce5818

Is there something obvious I am missing? I saw the template had a default dial pattern of x+#|xx+* but I removed that, thinking it would make a difference. Alas no difference was made. I had followed a tutorial on YouTube (Audiocodes MP112 Gateway Setup | VoIP Supply - YouTube) and entered my FreePBX information.

Thanks!

-- Executing [[email protected]:7] GotoIf("PJSIP/7449-00000088", "1?restrictedroute-825989f0a48ada175aa43c68e29d84ee,99,2:outbound-allroutes,99,2") in new stack
-- Goto (restrictedroute-825989f0a48ada175aa43c68e29d84ee,99,2)
-- Channel 'PJSIP/7449-00000088' sent to invalid extension: context,exten,priority=restrictedroute-825989f0a48ada175aa43c68e29d84ee,99,2

Did you intend to call 99? Your system seems to have 99 listed as indicating a restricted route, a number pattern that you never let people call.

https://wiki.freepbx.org/display/FPG/Outbound+Routes+Module

Yeah not intending to call it. I tried calling 2000 (one of the extensions I have) as well as my cell phone. Right now I’m running into something else, probably related. I have to see if I have a credential mismatch somewhere along the line. Though I’m not sure why it says “<sip:[email protected]…” I don’t have an extension 1001 and within the web configuration for the AudioCode I don’t see anything for that number.

Sorry by the way, I’m still familiarizing myself with FreePBX and Asterisk. I’ve come a long way since Marc when I started looking at it more, but still some what I’d imagine basic stuff still trips me up.

[2022-05-11 13:39:08] NOTICE[21875] res_pjsip/pjsip_distributor.c: Request 'REGISTER' from '<sip:[email protected];user=phone>' failed for '10.60.190.6:5060' (callid: [email protected]) - No matching endpoint found
[2022-05-11 13:39:08] NOTICE[21875] res_pjsip/pjsip_distributor.c: Request 'REGISTER' from '<sip:[email protected];user=phone>' failed for '10.60.190.6:5060' (callid: [email protected]) - Failed to authenticate

I changed a couple things in the configuration settings of the AudioCode and I can now make a call to another extension. Still can’t do external. I’ll poke around some more.

It’s seeming to grab just the first five digits. Probably something in a prefix in the settings? I was trying to dial my cell, which starts with 5096*… so 95096… as I have 9 set for outbound calls.

[2022-05-11 14:11:22] VERBOSE[33316][C-00000008] pbx.c: Executing [[email protected]:7] GotoIf("PJSIP/7449-00000008", "1?restrictedroute-825989f0a48ada175aa43c68e29d84ee,95096,2:outbound-allroutes,95096,2") in new stack

I know very little about AudioCodes but have one system that uses it.

On line 114 of your .ini file, there is a definition for TrunkGroup 1 with an empty phone number. I am guessing that this defaulted to 1001.

The authentication failure may be a mismatch between the SIP password set in the device and the value of Secret for the extension in FreePBX. Possibly, there is a limitation on length or character set – try a Secret consisting of no more than 12 letters and digits.

My system has an entry under [MEGACO Params] with something like:
DIGITMAPPING = '911|9911|[2-7]xxx|91[2-9]xx[2-9]xxxxxx|9[2-9]xx[2-9]xxxxxx|*x.T'
which would allow dialing 4-digit extension numbers starting with 2 thru 7, as well as 10-digit external numbers prefixed by 9 or 91.

1 Like

I think it is a secondary error. It can’t authenticate because it has no endpoint against which to do so!

I’m making some progress. I removed the definition for TrunkGroup 1 (I think it was partly a copy-paste error on my part from an existing .ini file for an AudioCode in our Alcatel OXE). Now it definitely seems to be pre-pending a 9 to whatever I call out. It shows I’m trying to call 92000 and understandably fails since that extension doesn’t exist.

- Executing [[email protected]:7] GotoIf("PJSIP/7449-0000001b", "1?restrictedroute-825989f0a48ada175aa43c68e29d84ee,92000,2:outbound-allroutes,92000,2") in new stack

I don’t know if it makes a difference, but I put the dial plan you had both in the .ini file under [MEGACO Params] as well as in the Endpoint Manager for the AudioCode template. I’ll dig around some more in the configuration web interface for the AudioCode and see if I can find it adding the 9.

Try deleting the line
NumberMapTel2Ip 1 = *, *, *, 255, 255, 0, 0, 255, 9, , 255, -1, -1;

Ah perfect! Deleting that line works! I can dial extensions fine, can dial out to my desk phone, and can call into the analog phone itself. Thanks very much!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.