ATA Grandstream Connected in Intelbras does not work properly

Hi, I have one ATA Grrandstram with the FXO conected to an Extension from an Intelbras CP112.
The FXO is registered in the Freepbx correctely. The problem is, when ose an SIP phone to cal the dialplab to dial to the extensions 15, 16, 302, 602 603 and so on(from the intelbras) it works fine.
My problem is, when I dial some extensions like, 301,201,1201 (final 1 expecialy) the call fails. I could not identify the reason. In very rare times, the calls works fine.

In the asterisk dial plan, I am using:

exten => 301,1,Answer()
same = n,Set(CHANNEL(language)=pt)
same = n,Dial(PJSIP/[email protected],65,gM(macrodial))
same = n,Playback(Soar-fim-da-ligacao)
same = n,Hangup()

In the ATA FXO I am using:

Could someone help me ? Please ?

Your setup is very unusual. Normally, the FXO would be set up as a trunk in FreePBX, with an Outbound Route that sends the range of extension numbers used by the remote system to the Intelbras trunk. There would be no need for any custom dial plan.

However, given that dialing 302 works but 301 doesn’t, it seems like DTMF is not being transmitted reliably, even though you set the tone duration and spacing to maximum. You may be able to confirm this by pressing the 1 key on the IP phone, just after the call to 301 was dialed by the HT.

Possibly, increasing or decreasing the level will help. Try setting TX Gain for the FXO port to 6. Also try -6.

There may be a loop voltage or current incompatibility between the HT and the Intelbras, but in that case I’d expect that voice would also be noisy and/or distorted. When the call to 302 does work, is the voice quality ok?

Thanks by the directions. I will test. The voice qualidy is perfect. No noise.
But looking your coments, could be the dtmf.
Do you have any example of the configuration/connection of the FXO as a trunk in the intelbras ?
Can I send the HT confirmation in the end of the fxo diaplan belo ?

FXO Dial Plan:{x+}

Thanks.

After I had set -6, the dial to 302 do not works either.
And +6 no make diference. Aparentelly.
Thanks.

Do you have a butt set or other means of listening on the analog line to hear what the HT is doing?

If not, you might try temporarily replacing Dial(PJSIP/[email protected] …) with Dial(PJSIP/[email protected] …)
If the 1 isn’t ‘heard’ by the Intelbras, you should hear its dial tone and could then try dialing 301 manually on the the IP phone. If that works ok, I would guess that the HT is sending DTMF incorrectly.

What is the Grandstream model (HT503, HT813, etc.)? Is it running the latest firmware? Do you have another analog line you could connect to for test (POTS, ISP VoIP, etc.)?

A cheaper ’ butt set ’

Nope. It can’t monitor the line without taking it off hook.

My memories of Brasil is everything is taxed at 200% or more, an even cheaper butt set is a 3.5mm stereo ear bud , use the tip (left channel) and body/sleeve ( ground) not any of the rings (right and microphone) . They are usually a couple hundred ohms so not too disruptive.

Sure. Put a ~1 uF capacitor in series.

That makes it a stealth listener (high impedance switch on the butt set) . To answer you need a DC current of more than a few tens of milliamps. As ever , physics rules until . . .

Good idea. I will put an aldio phone in the line.
I already tested with other lines and had the same result.

I will check the version of the grandstream. But I did not updated the firmware yet.

Thanks.

I have an circuito that I can use to monitore the audio from a line. I will try it.

By the way. The CP112 has 2 available trunks. It is possible to conect the FXO in one of these trunkcs ?

I will do that too. Thanks.

I will check today at nigt.

I magically solved my problem. When I put a capacitor in seri with an audio transformer to try to listen to dtmf, everything started to work. Probably some impedance or resistance problem. Now all calls work perfectly. If I take the transformer, the problem comes back. I would add that it was just impedance differences. Thank you very much for the tips.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.