Asterisk 1.8 FreePBX 2.9 ISDN HFC clueless

I installed fresh AsteriskNow and then updated FreePBX + Asterisk to latest versions. I also installed latest LibPri and I can see Asterisk see my hardware:

[[email protected] src]# dahdi_hardware
pci:0000:03:01.0 wctdm24xxp+ d161:0800 Wildcard TDM800P
pci:0000:03:02.0 zaphfc- 1397:2bd0 HFC-S ISDN BRI card

But how do I add then as a Dahdi group or channel(s) to use in trunks?

Thanks

Ekkas

No, unfortunately it doesn’t.
I had Elastix 2.0 installed before, which after install, it didn’t show up, but clicking on ‘Detect hardware’ in Elastix made it appear.

Hopefully someone here will be able to help. I’ll maybe try to compile Asterisk tonight now that LibPri is installed and hope that fix something, or do you think asterisk18 and asterisk18-core packages of the AsteriskNow-configured repositories should be working?

Thanks

Ekkas

I meant that the digital cards should show up under the heading “Digital Hardware” on the DAHDI page. If they don’t somebody else will have to step in. The cards I have installed so far just showed up there automagically…

Best regards,

Mikkel C. Simonsen

Do you have the DAHDI Config module installed?

Best regards,

Mikkel C. Simonsen

The DAHDI module in FreePBX is there, but it only sees my 8 FXO ports.
Do I need to do something there, or do you mean?

dahdi_genconf

and

[[email protected] ~]# dahdi_cfg -vvv
DAHDI Tools Version - 2.4.1

DAHDI Version: 2.4.1.1
Echo Canceller(s): MG2
Configuration

Channel map:

Channel 01: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 04)
Channel 05: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 05)
Channel 06: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 06)
Channel 07: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 07)
Channel 08: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 08)

8 channels to configure.

Setting echocan for channel 1 to mg2
Setting echocan for channel 2 to mg2
Setting echocan for channel 3 to mg2
Setting echocan for channel 4 to mg2
Setting echocan for channel 5 to mg2
Setting echocan for channel 6 to mg2
Setting echocan for channel 7 to mg2
Setting echocan for channel 8 to mg2