FreePBX | Register | Issues | Wiki | Portal | Support

Analog phone systems not able to call in

freepbx
Tags: #<Tag:0x00007fcd22531a28>

(Njohnson) #1

We have a deployment that works fine however, we are unable to accept any analog calls on our incoming SIP trunks. Currently we have trunks with AT&T and I will post their config at the bottom of this post. No analog phone systems can call us, they can hear us but we cannot hear them. Not sure if this is a carrier issue or if it is a codec issue. I need the help.

PEER Details

videosupport=no
type=peer
srvlookup=no
sendrpid=no
realm=asterisk
qualify=2000
insecure=invite,port
host=12.194.44.181
dtmfmode=rfc2833
disallow=all
directrtpsetup=yes
context=from-pstn
canreinvite=yes
bindport=5160
allowoverlap=yes
allow=ulaw
nat=yes

No incoming settings.


(Dave Burgess) #2

it’s weird for sure.

A few suggestions:

videosupport=no
type=friend
sendrpid=yes
insecure=invite,port
host=12.194.44.181
dtmfmode=rfc2833
disallow=all
context=from-pstn
canreinvite=yes
bindport=5160
allow=ulaw
nat=yes

These settings might help. I assume your SIP settings (in the Advanced SIP Settings) are all correct and that they reflect this configuration.

For incoming calls, you may be losing RTP, so make sure you have your firewall redirect UDP ports 10000-20000 so they go to the PBX. There shouldn’t be any difference between POTS calls and SIP calls through your provider - they should all be coming in through a SIP connection.


(Tom Ray) #3

You would not have “analog calls” on your SIP trunk. All your calls are SIP because that’s is how they are being delivered to you by ATT. What is on the other side of that call over the PSTN has no bearing on you not hearing their audio.

You know what does impact you hearing incoming audio over your SIP, your NAT and network settings.

Also this is a type=peer not a type=friend as @cynjut suggested since there is no user for this. However I would seriously just consider using PJSIP for this as your trunk. ATT is not asking for any specific settings, it’s a pure IP auth peering so this is literally the PJSIP setup:

BOOM, done. Tell it no Auth since it’s IP based and tell it the server and their port. It’s easier than dealing with a trunk that registers which really isn’t that hard either.


(Njohnson) #4

I will give this a shot later tonight I have to rebuild our firewall and settings. Hopefully that will help the issues. In the beginning I tried pjsip trunks but they just didn’t work so we switched to chan_sip and they worked fine. I assume it’s our firewall so I will do that tonight.