Amportal.conf not writeable

I get this warning after upgrading via the typical web interface:

Your amportal.conf file is not writeable. FreePBX is running in a crippled mode until changed. You can run ‘amportal chown’ from the Linux command line to rectify this.
Added 4 days, 2 hours, 56 minutes ago
(framework.AMPORTAL_NO_WRITE)

I have run the command but it still is there.

This showed up after upgrading to FreePBX 2.9.0beta2.1
CentOS release 5.2 (Final)

any help is appreciated.

PS: I do not know Linux so a step by step would be helpful

@Almoprocess

Have you checked the Amportal Settings screen before the upgrade? Did it work for you?

The reason I am asking I have a similar problem. In my case amportal.conf was not writable even before the upgrade. Amportal Settings also failed to read from it. I discovered that while working on Ticket #4839.

And yes Apache and Asterisk both run as user asterisk, and the ownership and permissions are right on amportal.conf.

[[email protected] etc]# ls -l amportal.conf
-rw-rw---- 1 asterisk asterisk 10470 Oct 23 01:39 amportal.conf

I ran into a more serious problem, my system crashed after the update to 2.9. See Ticket 4954.

-Vladimir

The manual method of making the file permissions worked for me. Thanks. BTW, i am using PBXINAFLASH. There are a few other issues now also such as the A2BILLING does not work at all now. Also the MOH does not work, or I should say, all my recordings are gone.

Look here for this one

http://www.freepbx.org/forum/freepbx/installation/music-on-hold-after-upgrade-missing-and-cant-upload#comment-35461

-Vladimir

@Almoprocess.

Thank you for the update. It helps. I am using AsteriskNOW.

There is no A2Billing. Cannot help with this one. Sorry.

-Vladimir

Yes, and I even rebooted and shut down, restarted, etc.

hmm - well I’ve been testing this and in most situations it should work though strange directory structures do have the ability to break this.

You can go to the linux command line and type:

chown asterisk:asterisk /etc/amportal.conf
chmod 660 /etc/amportal.conf

that should set it up and the assumption is that the web server and asterisk are running as user asterisk, if not, then it’s a much more complicated process and is non-standard for most FreePBX/Asterisk installations.

you need to press the Apply Configuration Settings bar after making the change, that is the only time it checks and updates that notification.

Have you done that?

Second part of that worked for me -

chown asterisk:asterisk /etc/amportal.conf
chmod 660 /etc/amportal.conf

My permissions were off on a fresh install, readable, not writeable.

Everyone is VERY helpful in the forums, but I have noticed that the hints given in the web interface are typically vague, and incomplete. The offered suggestion in this error was

You can run ‘amportal chown’ from the Linux command line to rectify this.

Which is incorrect in my case, as it sets mine to read-only, and for new users, leads them down a path of trying to figure out why the suggested command is…

It seems that a lot of repeat questions could be avoided if someone was making sure the tooltips, etc. were helpful… Same thing goes for the MANY password changes. They really do seem like a recipe for security disaster. There are too many vague, incomplete, and incorrect directions for fixing on many forums, but no real solution in actual documentation that is EASY to find - a priority for basic security setting, IMHO.

Not a rant, or even a bitch, just seems like many people are trying to help in forums, rather than getting this at the source. Helpfullness after the fact I guess?

chown asterisk:asterisk /etc/amportal.conf
chmod 660 /etc/amportal.conf

However, I did not have the amportal.conf error BEFORE the upgrade, only after!

Hi,

I am getting this issue too - the reminder pops up in the notification area.

I wonder whether this is related to the problems I am having here:

http://www.freepbx.org/forum/freepbx/general-help/errors-with-ari-after-update-asterisk-failure-and-interface-wont-load

I have run the

chown asterisk:asterisk /etc/amportal.conf
chmod 660 /etc/amportal.conf

commands in SSH putty but the issue persists.

My problems after the upgrade are much larger (as per the link) though - unless this is the root cause of all the issues.