Allowing remote registerations from a router using an ipv6 public address

Freepbx 5.211.65-21
Asterisk 11

A remote office had their internet router replaced. Prior to the swap the public address for the remote office was ipv4, which was allowed through the firewall and added to the permit ACL for each of the extensions. Since the swap the ipv4 address is being converted into an ipv6 address by the ISP. Phones can no longer connect to the server. I tried changing permit ACL to with no luck. How to add I the ipv6 address to the permit ACL?


You probably don’t have a valid IPv6 address on the Asterisk device. I’m surprised that this has been randomly changed like that. You’ll need to get in touch with whoever configured your router and get it sorted out.

Saying that - IPv6 works fine with Asterisk 11 and upwards, and FreePBX 12 and upwards, as far as I know. It’s not ‘officially’ supported yet, as we haven’t had enough bug reports against it, but I run several pure IPv6 machines and they work fine.

Thank you for the info. We are working with the ISP to get an ipv4 IP.

By enabling ipv6 on the server I will be able to add ipv6 addresses to the ACL?

I’m not sure which ACL you’re talking about, but IPv6 uses ‘ip6tables’ and IPv4 uses ‘iptables’. They’re a completely different IP stack. Stuff written for IPv4 will not automatically work with IPv6.

Note that the new FreePBX Firewall that I’m writing will have complete IPv6 support, but that will be FreePBX 13 only.

I mean the permit field in the device settings for the extension:

I don’t know! If it doesn’t, that’ll be a FreePBX 13 change, because it’ll need to change the IP address validation code.