‘all circuits are busy…’ On External Calls Using Google Voice Via OBiHAI200


(United States) #1

Hello,

I get the message ‘all circuits are busy…’, when i try to make external calls using an OBiHAI 200 setup to use Google Voice.
Calls within the organization can be done without any problem, but when we try to call outside, its when we get that message.

Can you please assist on this.

thank you


#2

No idea what’s wrong, but try:

  1. Confirm that GV calls from an analog phone connected to the OBi work properly.
  2. Make a failing call from PBX, check OBi Call History. If present, it should give a clue as to what’s wrong.
  3. Use sip set debug on or pjsip set logger on at the Asterisk console, to see the SIP sent to the OBi. With luck, you will see an incorrect IP address, port, number format or codec.
  4. If you see nothing, look at Asterisk log to see why call wasn’t routed to GV trunk.

(United States) #3

Thank you for your prompt reply. After following your suggestions, I have still had no luck. As such I followed your forth suggestion and looked at the log file. I have attached a link to the relevant portion of this file as I am having trouble understanding it and though that you might be able to help decode it and suggest the next steps in the troubleshooting process. Thank you in advance for any and all help you can provide me in resolving this issue.

The log file output is accessible at:
http://oherproductions.tk/log-file/


#4

I’m getting a 404 error at
http://oherproductions.tk/logfile
after your server redirects
http://www.otherproductions.tk/logfile
to that address.


(United States) #5

That’s my bad the link is located at oherproductions.tk/log-file/


#6
[2019-09-20 18:53:02] VERBOSE[56227][C-0000002d] app_dial.c: Called sip/6319837865@192.168.1.11:5083
[2019-09-20 18:53:34] WARNING[2082] chan_sip.c: Retransmission timeout reached on transmission

Unfortunately, all that tells us is that Asterisk sent the initial INVITE to the OBi but got no reply.

Assuming that the OBi is really at 192.168.1.11 (can you ping it from the PBX)?, X_UserAgentPort for the SPx in question is really set to 5083 (log into the OBi’s local web page to check), and you don’t have any firewall in between, you’ll have to use debugging tools at one end or the other to see what is going wrong.

In the PBX, at the Asterisk console, type
sip set debug on
and make a failing call attempt. The SIP trace will appear in the Asterisk log (interspersed with the normal entries), so you can see if there is anything wrong with the INVITE.

If you have set any security features in the OBi such as X_AccessList, confirm that they are properly configured.

If after checking the above you still see nothing in OBi’s Call History, use its Syslog and/or X_SipDebugOption to see why it is ignoring or rejecting the INVITEs.


(Lorne Gaetz) #7

The forum software flagged you as a spammer due the account age and unknown link. I recommend you use pastebin, which has native support if you’re using the Distro:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(United States) #8

Thank you for that information. I shall do that going forward. In the meanwhile, how would I resolve the issue of the forum thinking I am a spammer.


(United States) #9

I am able to ping the OBi at 192.168.11. X_UserAgentPort was set to 5062. However even after correcting it the issue still persists. The only firewall in place is Sangoma’s own firewall running on the PBX itself. As you suggested at this point I began the debugging proccess. The relevant portion of this file is available at the same link as last time as I am having trouble understanding it and though that you might be able to help decode it and suggest the next steps in the troubleshooting process. The link was www.oherproductions.tk/log-file/

Additionally, I have not set up any security features as far as I am aware.


#10

Did you change any trunk settings? The new log shows that the call wasn’t even attempted:
[2019-09-22 18:47:52] DEBUG[80997][C-0000001c] chan_sip.c: Cant create SIP call – target device not registered
This seems strange because there should not be any registration involved. The OBi is not a SIP server so it’s not possible to register to it. It is possible for the OBi to register to Asterisk; did you set it up that way? If so, I presume the OBi’s System Status page shows it’s not registered and you can track down why that was once working but isn’t anymore.

Or, you can use a static configuration in both Asterisk and OBi, without registration, which is simpler when both devices are on the same LAN.

Which are you trying to do? Post your trunk settings (except for secret/password).


(United States) #11

Strangly enough, the OBi’s System Status page shows it is succesfully registered. It reregisters every minute or so. The odd part is that incoming call have always worked and continue to work at this time. Regarding the trunk the Outgoing peer details are as follows:

type=friend
defaultuser=OBi200
secret=*************
qualify=yes
port=5160
nat=yes
host=dynamic
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=no
allow=ulaw
insecure=port,invite

Additionally, I have not changed any trunk settings since the last time that I had discussed the matter with you.


#13

I don’t know what’s wrong, though my own system has a much simpler configuration; the equivalent would be:

type=friend
username=OBi200
secret=*************
qualify=yes
host=dynamic
context=from-trunk
canreinvite=no

Also, my system uses OBi200 for the trunk name as well (in both General and SIP Settings tabs), but I don’t remember what went wrong when the trunk name and username were different.

I don’t know whether
[2019-09-22 18:47:52] DEBUG[80997][C-0000001c] chan_sip.c: Asked to create a SIP channel with formats: (g722)
is relevant – I would assume that Asterisk would transcode g722<->ulaw as needed, but you might try temporarily forcing the extension to use ulaw.

If you still have trouble, post a new log and also report whether Reports->Asterisk Info shows the status as OK.


(United States) #15

How would I go about forcing the extension to use ulaw?


#16

If the other changes don’t help, try setting Disallowed Codecs for the extension to g722 and also turn off g722 in the device settings.


(United States) #18

After temporarily forcing the extension to use ulaw, the issue persists. The new log is available at the link from before.


(United States) #19

Hi, did you have any update regarding the issue?


#20

Well, your most recent log still shows Asked to create a SIP channel with formats: (g722), so I figured that your temporary disable of g722 didn’t work right and you would be able to resolve that.

Also, the log still shows OBi200 Trunk as the trunk name, so there must be vestiges of that as it should have been changed to OBi200.

In post 6 of this thread, Asterisk was sending INVITEs to the OBi, which it isn’t anymore. Perhaps you can find what was the step backwards and reverse it.

If you clean up the above but still have trouble, please report whether outbound calls on ‘normal’ SIP trunks (from a VoIP provider) work properly, in addition to posting a new log.


#21

I had the same problem. This is what I did to get around it:

FreePBX Trunk configuration:

defaultuser=************
secret=************
host=dynamic
port=5060
type=friend
context=from-trunk
qualify=yes
directmedia=no
nat=no
dtmfmode=rfc2833
canreinvite=no
disallow=all
allow=ulaw
insecure=invite, port


(United States) #22

Hi Stewart, In a last ditch effort to try to fix the Obi Invite issue, I rolled the VM that the PBX resides on back to the last snapshot of it that I have available. Now that I’ve done so I’m encountering a different issue. Inbound calls still work fine but now outbound calls give me a recording that say, “The number you have dialed is not in service please check the number and try again.” I’ve uploaded the new log file. I’m almost ready to pull out my hair relating to this matter.


(United States) #23

A side note: After rolling back the VM, the only changes that I made to the VM after rolling it back where to change the trunk name to OBi200.