After (wrong?) uninstalling --> dahdiconfig config error showing up

Hi there

After upgrading (with upgrade script) to 5.211.65-21 and uninstalling the DAHDi Config Module I get the following config error:

Error File is not owned by asterisk
Delete thisIgnore this
Please run 'amportal chown’
Added 52 minutes ago
(dahdiconfig.)

It seems to be similar to the error described here:

However, nothing has worked to fix this issue. I tried several times to uninstall, install & reboot the module (incl. ‘amportal chown’). Any hints? What’s about changing the permission of the file dahdi.conf? Currently it looks like:

-rw-r–r-- 1 asterisk asterisk 114 Sep 23 15:52 dahdi.conf

Well, because I am a Linux newbie, I don’t know if a change of the permission will destroy even more…

Ok, changing the permission of dahdi.conf to -rw-rw-rw- doesn’t help anything, - message is still present.

Whatever, user SVLD wrote in the related thread that he fixed this annoying notification with the following steps:

  1. U have to install (again) DAHDi config module –> ok
  2. Run ‘amportal chown’ –> ok
  3. Delete notification (‘Please run …’) –> uclear, how delete notification, with a command?
  4. Wait until module checks permissions and remove notification record from DB –> ok
  5. Uninstall DAHDi module –> ok

For advanced users - just remove notification from DB (DELETE FROM notifications;)
–> PLEASE, could someone explain this somewhat clearer? --> Command? --> Syntax?

I want to note here that I found meanwhile a solution, - thanks to user w5waf!

After installing phpMyAdmin 4.0.10.8 I was able to remove easily the ugly (dahdiconfig.) “Error File is not owned by asterisk” notification. (I know I know, installing phpMyAdmin is regarding security reasons always a bad idea. Well, in my situation, I had no desire and no time to learn the corresponding MySQL commands. :wink:)

Note, it is recommended to check fist yours dependencies, for example, FreePBX 5.211.65-x is due to old MySQL 5.1.73 not compatible with any newer phpMyAdmin version! Furthermore, it may be possible that you cannot install it simply trough a repository like EPEL. In such situations you have to install phpMyAdmin using the source files.

Finally, if you don’t know yours Asterisk MySQL DB user & password, - check your /etc/freepbx.conf!
–> A very big thanks to user p_lindheimer for that hint!

You error is ^. You uninstalled the module. Therefore the module could have never been able to remove the message because… it was uninstalled.

Hi Andrew, yes, this error occurred the first time when I have uninstalled (somehow wrong?) the DAHDi Config Module.

I tried to fix the error by installing and activating the module again. But that did not work, - nothing helped. (I installed / uninstalled the DAHDi Config Module really umpteen times, at the Web UI and from CLI.)

Anyway, finally it worked, that’s the most important… I should worry about now only how do I make a clean uninstall of phpMyAdmin. :smile:

Installing it wouldn’t have done it. The alert is activated and removed once you look at the module’s pages. Through dahdiconfig. You got the error originally because you installed it and went into it, Then you uninstalled it and couldn’t get rid of the error. Then you went back and installed it but didn’t go look at it.

I don’t know what “activating” means.

Yes, that must have happened on that way… So far I remember me correctly after the uninstall of dahdiconfig, I logged out from Web UI before I pushed the “Apply Config” button. After new login into Web UI the dahdiconfig error “File is not owned by asterisk” notification remained permanent.

“Activating” means enabling (the dahdiconfig module)… :wink:

Little addition, I went (every time) after a new dahdiconfig module installation numerous times back and “look at it” (–> go into the dahdiconfig module). But as mentioned, no matter what I adjust in dahdiconfig, that all doesn’t help anything regarding the “File is not owned by asterisk” notification.

Sorry totally confused by this statement. I’m pretty sure this is a non-issue moving forward (as in it’s been solved)

Don’t worry, - sorry for my bad English. :pensive:

Whatever was the original reason, - the issue is now solved. Thanks to phpMyAdmin:smile: