Advanced recovery: Error cURL 60 and 51

Hello FreePBX community,

I bought the Commercial Module Advanced Recovery on my both servers to have a high availability scheme. I’ve created the keys so both servers can be accessed via ssh without password.

However, my issue starts when I try to configure the Advanced Recovery module by clicking on the Quick Configuration button. I fill the information of my secondary server (the IP and the rest fills by default), set the dates for backups and finally when I finish, it appears an error:

cURL error 60: Peer's Certificate issuer is not recognized. (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)

We’ve installed trusted certificates on both servers, but I am still getting the error.

image

I’ve tried to look for an answer here in the community for days but I don’t see any answer which can help me. Hope you can help me on this.

Instead of the IP have you tried putting the fqdn that corresponds to the name on the certificate?

Hello dobrosavljevic, yes I did it and it solved the problem.

Thank you for your answer!

No problem. Although I would be really careful with using HTTPs inside of the Advanced Recovery module. The servers us https for all the heart beat functionality between them and the moment SSL breaks down for whatever reason they will consider themselves in an outage situation and act accordingly. That can be really tricky with the SSL renewal issues that FreePBX has in general. See this thread for example:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.