*80 Intercom - No Audio from user who dialed


(Dpbx71) #1

FreePBX 14
Asterisk 13.29.2
Feature Code: *80 enabled

Extensions (premises) have direct media NO. Connected to a cloud server.

When extension 1 dials extension 2, extension 2 hears nothing. Extension 1 hears everything.


One way audio between extensions
One way audio between extensions
#2

Affected phone(s) make/model? All phones on system affected? If receiver is lifted after intercom call is auto-answered, is there two-way audio? Speakerphone otherwise operate normally?


(Dave Burgess) #3

Do you have NAT enabled on everything? Because of the “cloud” part, these aren’t local calls - they are just like any other Internet call coming through the firewalls, so double check all of your intervening firewall settings.

In a ‘typical’ setup, these calls are transversing four firewall interactions, two at the local network end and two at the Cloud end.


#4

Possibly, this thread:


is relevant to your situation, if the problem occurs only when the called extension has multiple registered devices.


(Dpbx71) #5

CONFBRIDGE(user,muted)=yes

Dialing *1 unmuted mid-intercom

Looks like confbridge is muting me… just need to find out why and how to fix


(Dave Burgess) #6

There are options in the conferencing app that turn on “mute on connect” by default. I’d check that first.


(Tk 351) #7

So, the issue I was running into seems to be resolved by dialing *1 while on the intercom call.

My original post (One way audio between extensions)

I double-checked the setting in conferences and it’s set to not mute. I guess the question is why is it happening.


(Dpbx71) #8

Sure. I have some ideas, but I’ll wait to post until I have something conclusive.


(Itzik) #9

Where do you see that?


(Dpbx71) #10

The log file


(Itzik) #11

Can you post a full call trace? Post a pastebin link. See instructions: https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Tk 351) #12

I can post one shortly.

Found a work around for now in my situation. Check in usermanager, ucp and then the phone tab to see if it’s enabled either on users directly or on a group(s). It was in my case. Turning it off seemed to do it.