30 minute dropped calls! Not sure how to fix

I have a problem on freepbx where calls drop at exactly 30 minutes. We have exhausted options with the carrier.

First off we have a PBX behind a Cisco ASA firewall. I believe we are using Sip Inspection. At 30 minutes we are seeing an invite request which seems to be coming from our PBX to the carrier- and the carrier is saying it is a malformed packet, and they get a parse failure due to extra characters. That is what the wireshark tells us.

I tried to turn off session timers on the trunk itself in in pjsip_custom_post.conf and set timers=no and tried to turn it off on the extension itself.

I am getting mixed results with most calls still dropping at 30 minutes. It seems the OLD pbx does not have this issue. I am using Asterisk 13.29.2

Any ideas? it’s really annoying and looking for solutions.

While this may not be the exact answer to your question, it’s where I’d start for pointers.

Thanks- yah mine seems similar to this issue- so trying this also


1 Like

This didn’t seem to work either - I added


Still hangs up after 30 minutes- wondering if this is fixed in version 15? also it seems to happen in pjsip but not sip…

This one talks specifically about PJ-SIP

Yah - nothing I have tried has worked up to this point.

I could be wrong here, but I’ve heard about networking timeouts in the router causing weird behavior like this. I don’t know if there are tools now to resolve this or not, but it’s worth checking into.

Here is an article talking about something similar:

I believe this fixed it

SIP canrenivite (directmedia) - I set this to UPDATE and I haven’t had the problem again.

This is in FREEPBX advanced settings.

1 Like

interesting… this makes a lot of sense.

I’ve been using the timers=no trick for ages as a workaround on my servers but will give this a whirl.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.