2 Nic no audio both ways

Hi there,
Still a little new settings up freepbx, new install, this one is on a hyper v machine, installed ok and added a second nic to connect directly to the ISP deice to authenticate the trunk.
So setup is eth0 phone connections, and eth1 is for the ISP SIP connection. I can get the phones to connect no problem, and my trunk connects no problem, but if I call in there is no audio. and same with out bound. also getting a disconnect after about 30 seconds which may be a nat issue, but looking for assistance getting the audio working first. Please and thank you!

30 seconds disconnection means a NAT issue almost everytime.
Verify that NAT settings are configured correctly for your particular network environment and ports have been correctly forwarded on whatever NAT device you are using

Did you specify both local networks under Settings > Asterisk SIP Settings?

Also, did you set one NIC as the default?

I agree with all of the above. If you are using a gateway provider, and are using SIP/RTP make sure that your firewall is allowing All the required RTP and SIP ports to the gateway IP address(s). Also if using fortigate, make sure VOIP-ALG traffic is NOT being managed by the fortigate, it DOES NOT manage traffic well. Let the traffic flow and let FreePBX handle flow and signalling for these protocols.

Disable SIP ALG on any and all routers, not just fortigate.

More specifically, it means that your router is dropping your NAT connections because there’s no traffic going back to the right place. If your extensions are not set up for NAT, the system will send your “local” address into the “wild, wild Internet” and the path back will be invalid.

Be sure to check everything else on this thread. There are dozens of ways for RTP to get mid-directed, so it’s going to take you a few minutes to figure out which problem is causing your specific issue.

I would agree, I have had that issue in the past before, but this setup is a little different, the trunk connection is direct to the ISP’s device that is a specified port for the SIP traffic, so no router in between the one nic and the trunk connection. So I am assuming that there is RTP traffic possibly going out over the other nic…?

Yes done, it is a Ubiquiti router, but I have turned the SIP off there

Depending on your network configuration, I would all but guarantee it.

That may be part, as mentioned I have not done a dual nic local freepbx setup yet so this one is new to me. I do not believe I have set a default NIC, I guess which nic the trunk facing or the lan facing? For the asterisk SIP settings, I don’t think I added the network, I will try that as well. I am also seeing the external Address listed there as the eth0 sides external, which really may not be the right one, that is just what the phones to connect back to the server with?

You probably need to define a static route to your ISP out the specific nic

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.