2.10 RC coming up, Other Updates

We hope everyone out there had a great Holiday Season and Happy New Year! In addition to enjoying "the season" ourselves we've been quite busy so we're back to give you a quick update on all the threads of activities that have been keeping us going! Those include 2.10 Release Candidate coming up, new site and repository servers and the fast approaching Open Telephony Training Class.

FreePBX 2.10 Beta/RC

On the FreePBX 2.10 front we finally got the Version Upgrade module out and into the 2.9 online repository so that we could facilitate more of you participating in the beta program. There was a slight delay in doing such as we wanted to make sure that the new Backup and Restore module in 2.10 could restore a 2.9 system “at least as good as has always been the case.” What that means is that we don’t support restoring backups between major releases although it has always “mostly/somewhat worked.” We did not want to put a Version Upgrade module into the 2.9 repository without having at least that level of functionality that many of you have grown to expect from us.

We released the upgrade module in conjunction with pushing 2.10 into a beta3 stage. Calling it beta3 vs. Release Candidate 1 (RC1) was more of a formality. We wanted to do a sanity check with the first wave of migrations before putting our RC stamp of confidence on it even though we are all feeling quite comfortable with this new release and have it up in dozens of production settings already. Since all has been quiet since that time and plenty of upgrades have been occurring, we plan on moving 2.10 to a release candidate at the end of this week at this point!

New Site Servers

We are excited to inform you that most of the first phase of our FreePBX.org and Online Repository migration has been accomplished without a hitch! Our single site server is now made up of two pairs of servers that comprise the site and repository and their respective live replicated backups! Currently the replicated servers are at the same data center but have plans to move to a separate facility soon. We also have full backups occurring on the replicated servers so those of you in parts of the world who used to feel a bit of a slowdown when we were “selfishly” doing our backups in the middle of the US night should no longer have that issue! The replication is done using a combination of MySQL realtime replication and hourly rsync’s as well as instantaneous rsyncs when we publish on the repository. We couldn’t have done all of this and so smoothly without the generous assistance provided by Schmooze Com, Inc so as always, a big THANKS to them!

We noticed that up until we shutdown the old server, about 2 weeks after changing the DNS records, it was still getting a fair amount of traffic. For the FreePBX.org site it was mostly spider bots so no concern there. For the repository site it appeared there were still lots of FreePBX systems trying to hit the old server. This would occur if you were to have manually entered the old IP address on your server in /etc/hosts or otherwise have a really mis-behaved DNS cache. If you are not getting updates, you may want to check /etc/hosts. Over the years there have been many cases where people ran into various DNS problems and fixed them by hard coding the FreePBX mirror site address. If you were in this category you will have to undo that change to get the updates flowing again.

Open Telephony Training Seminar - Naples, FL - Jan 24-26

We are really excited with the upcoming OTTS class just under three weeks away! Given the weather recently here in the Pacific Northwest, I’m personally really stoked!. We’ve got an almost completely full class so if you are still on the fence, don’t get caught like some of the procrastinators the last time we gave this class without a spot. I think there is one more spot right now though we are reviewing logistics to see if we can’t accommodate a few more. But no guarantee! We also negotiated a good rate at the local Courtyard Marriott which was suppose to expire today though we just got them to keep a few rooms until the end of the week for any late stragglers.

For now, go upgrade to 2.10 and help us get that much more exposure and for those of you on your way to Florida, see you very soon!

Philippe On behalf of the FreePBX and Schmooze Teams!


I am not finding the upgrade module when I Check on Line with Module Administration.

I forgot to put a repo tag for the standard repo in it so it may not have showed up depending on which repos you had enabled, I forget which repo it defaults to if this is left off…

In any event I re-published it under the standard repo so you should see it now…


I just looked for updates in all repositories and found one module Framework and have installed that. Still don’t see 2.9 to 2.10 upgrade module.

hmm … don’t know what to say … it should be there in the standard repo now, I checked on a 2.9 system right after correcting that?

I can’t find it either on multiple systems, no matter the repo selection

Just checked again

Only had ‘basic’ checked for the repo, on a 2.9 system.

Under the Admin category once checking online it comes up with “2.10 Upgrade Tool” …

Checking the http logs on the server, there have been plenty of downloads.

So not sure what to say???


Thank you for 2.10!!!

Just tried again and the module has appeared. Thanks.

Two days ago I installed stable and last night I ran the script to upgrade.

I notice in System Admin -> Network Settings , the Gateway field is empty … even if netstat -rn does show my gateway is properly configured.

Besides that, all seem fine so far.


Good day,

Thank you for the update.

I have two asterisk servers both running and successfully upgraded to 2.10 on one server, however on the other an authentication issue occurred.

after I upgraded the framework, I would be redirected to the login page with each click on a link. It also appears that the framework is and didn’t upgrade to 2.10.

How can I get it back to working condition?

Hi benzo,

Did you manage to solve this issue?

I am experiencing the same issue and the core module needs to be updated… But I can’t since the webpage auth session is being destroyed on every click.


I am anxious for a distro with all the latest on 64-bit. I have a brand new machine waiting to install FreePBX 2.10 but I need the TRIM support for SSD that is non-existent in Centos5.

I tried installing the 32-bit distro, but anaconda crashed during the install. I tried doing a manual install of FreePBX on a clean Centos 6.2 install, but the only instructions I can find are so outdated as to be useless.

Did you follow the instructions at www.powerpbx.org? The 2.9 CentOs install will work fine. The only major process change is to not edit amportal.conf and to set the db credentials in freepbx.conf

I’m having the exact same issue. Any luck?

Good day,

Since upgrading to 2.10, I have issues with freepbx. I cannot navigate the menus’ properly or apply configs’ as I am requested to login at each click.

Any other person with this issue?

When I got update module to 2.10 and read description where it said about safe install - I tryed to upgrade.
Now I fall into some problems.

PHP Fatal error: Incompatible file format: The encoded file has format major ID 3, whereas the Loader expects 4 in /var/www/html/admin/modules/sysadmin/functions.inc/general.php on line 0

So - no Web-interface is available. Cannot press “Apply Button” to finish process and dont know what to do.

Please suggest.

(Using Trixbox system.)

Then tryed to downgrade to php v.5.2.17 and got:

DB Error: extension not found

Trace Back

/var/www/html/admin/libraries/db_connect.php:63 die_freepbx()
[0]: DB Error: extension not found

/var/www/html/admin/bootstrap.php:98 require_once()
[0]: /var/www/html/admin/libraries/db_connect.php

/etc/freepbx.conf:9 require_once()
[0]: /var/www/html/admin/bootstrap.php

/var/www/html/admin/config.php:97 include_once()
[0]: /etc/freepbx.conf

Currently php -v is:
PHP 5.2.17 (cli) (built: Aug 9 2011 20:12:01)
Copyright © 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright © 1998-2010 Zend Technologies
with eAccelerator v0.9.6.1, Copyright © 2004-2010 eAccelerator, by eAccelerator
with Zend Extension Manager v1.2.2, Copyright © 2003-2007, by Zend Technologies
with Zend Optimizer v3.3.3, Copyright © 1998-2007, by Zend Technologies

I think you need to manually update your system. See this link: http://www.freepbx.org/forum/freepbx-distro/distro-discussion-help/release-versions#comment-45417

As the post states, do a cat /etc/asterisk/freepbxdistro-version to get your version. Then, from the list at the post, do a right click on the link that is next in line from the version you have. Choose Copy Link Location. Go to your prompt and from any directory, type this:
wget “and then the link location” – a right click should paste it into the line

you will have something that looks like this:
wget http://upgrades.freepbxdistro.org/stable/

Hit enter.

Then chmod +x"file name you just got" this changes the file to an executable.

then do this “./filename you just got” This will install the file. Had to edit this and put in the quotes because the filename did not come through in original post becuase i was using illegal brackets!

Depending on what version you have this may take 30-45 minutes to go through all the updates. Good luck. Once done you should have a fully updated FreePBX 2.10 Go to your GUI and search for updates. Shouldn’t be any, and the nasty errors should be gone.

Callback still doesn’t work :frowning:


The rest seems to be OK. Thanks!


I went from 2.10beta to 2.10RC1.0 and had the navigation issue today.

Temp fix is

chmod 777 /var/lib/php/session

I posted more info on it here

Have been using 2 systems for just on a year, great work :slight_smile: