FreePBX | Register | Issues | Wiki | Portal | Support

Zulu's Link to URL functionality doesn't work?


(Fetus) #1

Hi again,

I’m trying to prepare a demo for a customer, He is interested on using zulu on 100 PCs aproximately, so I have to be sure the software wil work.

Anyway, I have tried it in my desktop computer (windows 10) and calls are received an originated correctly, but Link to URL functionality do nothing. I have configured it on teh extensión options, on Zulu tab, even on inbound rutes, but it do nothing. The phone and zulu rings together, but browsers do nothing.

Any idea what to do?

Regards.


(Tony Lewis) #2

You have to install the browser plugin for chrome for Zulu.


(Fetus) #3

It’s allready installed, but it doesn’t work. Do I need to make any configuration on the chrome’s plugin?

Regards


(Andrew Nagy) #4

Are you talking about clicking links in the browser or something else?


(Fetus) #5

Hi!

I’m talking about Link to URL functionality of Zulu. In the FreePBX configuration pannel, in the extensión, I have configure de URL to open on incoming calls.This is what I have configured:

Ehat is suppose to happen? On incloming calls it do nothing. Plugin for chrome is installed and working (clic to dial works fine). Any idea?

Regards.


(Fetus) #6

Hi, i’m still having issue with this. Does it really work?

Regards


(Andrew Nagy) #7

Yes it works. It has nothing to do with Chrome/


(Fetus) #8

Well, I’ll try in another PC, just to know if it’s my PCs issue or not.

Anyway, I’m facing more issues with the inbound calls. On inbounf calls, the phone rings, and Zulu shows the following message: “Connection droped by remote peer”, but sometimes softphone doesn’t work, and doesn’t show any information about the inbound call. It doesn’t happens allways, but it’s very annoying. Is it usable as a softphone? I know it’s a beta version, but I can’t use it in a production scenario.

Regards


(Fetus) #9

Hi again,

I have just installed and configured it on a MAC pc. It does the same… :frowning:


(Fetus) #10

Well, I wonder if asterisk version would be the reason of the issues. I use asteris 11. Is there any compatibility issue with this?

Regards


(Fetus) #11

Does anyone tried Zulu recently? Does it really works with last versions?

I have allready tried in three different systems, and not allways working.

Is it buggy?

Regards


(Tony Nichols) #12

I just moved to version 14 - working great for me!

We use the launch url option to open our Hubspot CRM and display the cont information.

https://app.hubspot.com/sales/“your-hubspot-number”/contacts/list/view/all?query=${CALLERID(name)}

I did have a hiccup when my callerid (name) broke… but other than that - it works like magic!


(Fetus) #13

Whow! Did you tried it on Freepbx 13?

I have a Freepbx 13 working, with about 100 extensions, with chan_sip. Do I have to migrate it to 14? Any suggestion to migrate it?

Regards


(Tony Nichols) #14

It worked on my version 13 until I moved the deployment id to the new server - so I’m sure migrating wont be required.

I think I see the issue… you are changing the extension Zulu tab - where as I change the inbound route Zulu tab.


(Fetus) #15

I have allready tried both. Wich one is the more restrictive?

Regards


(Tony Nichols) #16

-it is my belief - it is one or the other… If you want an inbound call to popup information about the caller,

  1. the extension ZULU tab setting will need to be “Inherit” and the Link url --blank
  2. the usermanager Zulu tab needs to be enabled yes

(Fetus) #17

Ok, will try it tomorrow. Is there any log to see if it’s working or not?

Regards


(Tony Nichols) #18

Yes - look int the /var/log/asterisk/full and search for ZULU_URL= "your url link will appear here"
Good Luck!


(Lynden Waldner) #19

I realize this has been a couple years ago BUT I need your help…how does the URL lookup work? I am also using hubspot and would like to get this working…thanks