ZULU windows client not connecting

I have two windows clients in different locations. Neither will connect to the ZULU server. They have been working without issue. The problem was noticed approximately a week ago, but I cannot correlate any obvious system changes that would have caused this.

The Windows log file show: (note the actual password has been replaced with “Password” but is verified to be correct for use 1000.)

2018-03-15 08:50:58,087 [1468] DEBUG WebSocketServer-21210914 - IntServer: message received: {“command”:“CONFIG”,“number”:null,“recipientname”:null,“text”:null}
2018-03-15 08:50:58,087 [1468] DEBUG WebSocketServer-21210914 - Handler found for command: CONFIG
2018-03-15 08:50:58,212 [10028] DEBUG PBXCommunicator.PBXSocketClient - SEND: {“type”:“ping”,“id”:“1181657693”,“command”:“pull”}
2018-03-15 08:50:58,212 [9084] INFO PBXCommunicator.PBXSocketClient - PBX socket disconnected
2018-03-15 08:50:59,087 [1468] DEBUG WebSocketServer-21210914 - IntServer: message received: {“command”:“CONFIG”,“number”:null,“recipientname”:null,“text”:null}
2018-03-15 08:50:59,087 [1468] DEBUG WebSocketServer-21210914 - Handler found for command: CONFIG

This section is repeated ad-infinitum.

I have tried connecting both over the VPN and via the Internet, with no difference in behaviour.

Steps taken to resolve the issue so far without success:

  1. Checked ZULU (Free) activation is valid until 2018-07-08 with 2 users
  2. Changed User 1000 password
  3. Check PBX Firewall open ports 8002, 8009 - ok
  4. Check Settings > Advanced Settings>

ZULU Server:
Enable the Zulu Server Yes
Zulu Bind Address
Zulu Bind Port 8002
Zulu Command Bind Port 7999
Zulu TLS Certificate Location (reset to default - entry is blank)

Certificates are provided automatically under Admin > Certificate Management by Let’s Encrypt - all up to date.

  1. Ran Admin System > Updates to PBX latest version 10.13.66-22

  2. Upgraded Asterisk from v.11 to v.13

  3. Upgraded all Admin Modules.

  4. fwconsole CHOWN

  5. fwconsole restart

  6. fwconsole reload

Still neither of the ZULU clients are connecting.

I would appreciate any help or guidance to debug this issue further.



When you reset this you removed the certificate. This is bad.

Thanks Andrew,

I reset this back to what it was. Still no connection.

However after a little more digging, I discovered that under Admin > Zulu menu, the user 1000 that was registered to these two clients was missing from the list of ZULU users. (I had only looked under the Admin > User menu previously to check the password was correct).

It seems that what happened was that when I added a new extension 401 (and user) to the system a week or so ago, the default behaviour was to add the new user to ZULU. As I am only using the free ZULU module, there is a maximum limit of 2 users, and two users were already registered, 1000 and 400. It looks like the new user 401 had overwritten User 1000, so the two users became 400 and 401 instead of 400 and 1000.

When I deleted the new user and re-added User 1000 on the Admin > User menu to the Zulu tab, the client reconnected and is now working normally.

Is this possibly a bug, or did I miss something when adding the new extension?

Thanks again for your feedback.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.