Zulu mobile require a trusted SSL certificate HELP!


(Wifx) #1

Hello !

I installed the company certificate (wildcard Let’s encrypt certificate) on the FreePBX server.

When I connect to administration in HTTPS with Chrome on my PC, everything works, Zulu Desktop works with my PC as well.

The PBX is on a public IP, no NAT, the FreePBX Firewall is not enabled, everything is open also on the Hardware Firewall before the PBX. Ping is working as well from Internet.

When I try to do the same thing with my Android mobile (version 10), on Zulu, I get this error :
Zulu mobile require a trusted SSL certificate ,

I tested the SSL certificate with this site: https://www.sslshopper.com/ssl-checker.html on port 8002 and everything is OK.

Another problem that I don’t understand at all, from the internal network, I can access the admin of my FreePBX on port 443, but not from the Internet, I get the error ERR_CONNECTION_REFUSED

I don’t see anything particular that could help me in the Apache logs.

I have been searching for several hours and I am completely lost. :disappointed_relieved:

Best regards,
Marc


(Lorne Gaetz) #2

At this point you want to be using Sangoma Connect for a mobile client, not Zulu.


(Wifx) #3

I tried, but Sangoma Connect remains blocked at registration. :frowning:

This certificate problem again?


(Lorne Gaetz) #4

Not a cert no. Prob firewall misconfig.


(Wifx) #5

This PBX has a public IP, no NAT.

Port TCP 8002 and UDP 10000-20000 is open.
Is this correct ?


(Wifx) #6

I just tried to open everything ! No restriction of any kind.
Does not help …


(Wifx) #7

After re-controlling everything with a network engineer, nothing was found on the Firewall.
I will open a paid support ticket and give the results here for the community.