Zulu Issues - Remote Connections

I have just updated to PBXact .20 so I am on the lastest. An issue I have been working on for a couple weeks:

  1. When I am remote to the network I have no voice communication. If I place the called person on hold using the Softphone they can hear Hold Music, I can even pick them back up. However no voice either way. Keep in mind we do have remote phones working with no issues and no VPN’s. We use the Responsive Firewall. We do have Zulu working with 2 way voice internally.

  2. Also in regards to this, if eth0 Interface is set to “Internet (Default Firewall)” - as it should be, the PBXact rejects my ZULU connection. I have to set it to Local (Local Trusted Traffic) in order for it to connect.

Hold music is generated by the pbx. So it really doesn’t matter if you have one way audio but hold works.

well thats just the thing though, doesn’t that mean the RTP stream is at least working? Because with no audio after 30 seconds the call gets dropped. If I place the person on hold they can sit on hold forever. I pick them back up and after 30 seconds the call will drop.

In Chan-SCCP-B we used to see this with Codec Changes - the call would go from the one codec (say uLaw) to WAV (for the music on hold) and then wouldn’t change back when the call came off hold.

It’s probably not the problem; I’m just saying that there might be other forces at play that look like this.

Does anyone have any suggestions for this? Or is this a known issue for remote connectivity not working. Like I said everything internally works for the most part.

Like with my example, it’s usually very implementation specific. Something in your specific deployment might be causing the problem. Since it’s intermittent, it’s going to be hard to find, though, so it’s going to take patience and determination to find it.

Your best bet is to figure out a way to reliably reproduce the problem and just hammer away on it until you can figure out what it actually screwing you up.

@cynjut I am a bit confused by your response. lol.

Its not intermittent its all the time. Local to network of the phone system-Everything works and 2 way voice. Remote from the network - No Voice either way. The Software connects and will make a call but just no voice. Its actually a very simple issue.

I have all the ports forwarded and my firewall is no blocking anything from the outside world on those ports they have listed. I guess since Zulu does not use SIP/RTP how does it communicate?

OK then - I’m out. Good luck.


Have you opened the remote port as defined in the Zulu wiki.

Zulu Communication Port SSL TCP 8002
Zulu Soft Phone SSL TCP 8089
I also has open 5000 for the chat system.

We’re having even stranger issues. The Zulu client (Windows 10) connects fine and can make calls fine, audio etc perfect. Incoming calls from external will sometimes ring on the softphone and sometimes not. If however an incoming call from external is answered there is always no audio. Very strangely, incoming calls from an internal extension, work perfectly both ways.

We run our FreePBX on a remote server so have no NAT on the server. Extensions are configured with “NAT mode”: “Yes/force” under advanced. We also only use alaw and g722 for both our main trunk (SIP) and all endpoints. Other than that our server is close to default. I have tried disabling the firewall to test as well.

Just another update here, Zoiper works perfectly but I’d really rather not purchase an external piece of software when there is a solution within the Sangoma stack. Would it be worth logging a support query for? I see Zulu is still in beta but to me it looks very promising. The problem is I need to have a fully functioning call centre up and running in the next few weeks.

Any thoughts/advice would be greatly appreciated.

Problem solved!

I ended up opening a support ticket for this and was advised by the agent to add a STUN server under Asterix SIP settings. I used stun.l.google.com:19302. They also said to try toggling the NAT setting in Zulu itself. Only after also setting it to NAT “no” did calls work correctly both ways.

Now I just need to figure out how to enforce this from the server side so I don’t have to set this on every work station.

1 Like

Ok still having the issue where incoming calls will not “ring” on the Zulu client ie the “Answer” and “Hangup” buttons don’t appear. Oddly, the Windows notification indicating an incoming call does appear.

Only if I toggle the NAT setting in Zulu to “Yes” and back to “No” does it work again. I have to do this every time I restart Zulu.

I have updated my support ticket and will report back here if anything develops.

Hey man,

I am having the exact same issue where we can see the extension ringing in the queue but the zulu softphone is not ringing itself. Have you found an answer as yet?

There is another active thread that talks about the Zulu phone losing it’s registration after an indeterminate period of time. Restarting the client is the work-around, and there is some work being done in Zulu version 3.0 to address this issue.