Zulu 3.1.1 only "deskphone"


(Vasman) #1

We’ve recently created a new server running the latest distro 15/Freepbx A/16, we have added the two free liences from the portal for Zulu and lienced it.and that’s up and running fine. However, when running the Zulu desktop software (macOS), we are no longer able to use the softphone (which is pretty critcall) it only portd Desk (ip phone)

There seems to be some comments but nothing is really defined?

Is there an issue or has something changed?

Any comment or help would be very useful


(David M. Lee) #2

@vasmanrossano,

This sounds like the behavior you would get if WS and WSS were disabled in PJSIP. Check your dashboard to see if there are any warnings about enabling it. More details about the server install are on the wiki at https://wiki.freepbx.org/display/ZU/Zulu+3+Server+Installation.

You might also need to toggle Zulu off and on again for those extension in order to get Zulu to create its PJSIP devices.


(Vasman) #3

Yep, done all of that, not worked at all

Zulu setting above, the default cert is working else where using the lets-encrypt

X-lite soft-phone working with any problems

Running FreePBX shutdown…

Running Asterisk pre from Core module
Stopping Core FastAGI Server
Stopped FastAGI Server
Running Asterisk pre from Ucp module
Stopping UCP Node Server
[>---------------------------] < 1 sec
Stopped UCP Node Server
Running Asterisk pre from Xmpp module
Stopping Chat Server
Stopped Chat Server
Running Asterisk pre from Zulu module
Stopping Zulu Server
Stopped Zulu Server
Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] < 1 sec
Wanrouter: No valid Sangoma Hardware found, if you have no Sangoma cards this is OK
Stopping DAHDi for Digium Cards
DAHDi Stopped
Running FreePBX startup…
Running Asterisk pre from Dahdiconfig module
Wanrouter: No valid Sangoma Hardware found, if you have no Sangoma cards this is OK
Starting DAHDi for Digium Cards
DAHDi Started
Running Asterisk pre from Firewall module
Running Asterisk pre from Sysadmin module
Running Sysadmin Hooks
Restarting fail2ban
fail2ban Restarted
Updating License Information for 52270852
Checking Vpn server
Starting Asterisk…
[============================] 1 sec
Asterisk Started
Running Asterisk post from Core module
Starting Core FastAGI Server…
[>---------------------------] < 1 sec
Started Core FastAGI Server. PID is 17637
Running Asterisk post from Dahdiconfig module
Running Asterisk post from Endpoint module
Running Asterisk post from Pagingpro module
Running Asterisk post from Ucp module

Broadcast message from root@s119 (Tue Jan 21 18:30:20 2020):

Firewall service now starting.

Starting UCP Node Server…
[>---------------------------] < 1 sec
Started UCP Node Server. PID is 17964
Running Asterisk post from Xmpp module
Starting Chat Server…
[>---------------------------] < 1 sec
Started Chat Server. PID is 18390
Running Asterisk post from Zulu module
Starting Zulu Server…
[>---------------------------] < 1 sec
Started Zulu Server. PID is 18780
[root@s119 ~]# asterisk -x "pjsip show transports

^C
[root@s119 ~]# asterisk -x “pjsip show transports”

Transport: <TransportId…> <BindAddress…>

Transport: 0.0.0.0-tcp tcp 3 96 0.0.0.0:5060
Transport: 0.0.0.0-tls tls 3 96 0.0.0.0:5061
Transport: 0.0.0.0-udp udp 3 96 0.0.0.0:5060
Transport: 0.0.0.0-ws ws 3 96 0.0.0.0:5060
Transport: 0.0.0.0-wss wss 3 96 0.0.0.0:5060

Objects found: 5

[root@s119 ~]#
[root@s119 ~]# fwconsole ma upgradeall
No repos specified, using: [extended,commercial,standard] from last GUI settings

Up to date.
Updating Hooks…Done
[root@s119 ~]# fwconsole ma downloadinstall zulu
No repos specified, using: [extended,commercial,standard] from last GUI settings

Downloading module ‘zulu’
Processing zulu
Verifying local module download…Verified
Extracting…Done
Download completed in 1 seconds
Updating tables zulu_interactions_interaction_states, zulu_softphones, zulu_tokens, zulu_interactions_contacts, zulu_interactions_interactions, zulu_interactions_owners, zulu_interactions_members, zulu_interactions_streams, zulu_interactions_stream_bodies, zulu_interactions_stream_links, zulu_interactions_stream_actions, zulu_login_tokens, zulu_mobile_tokens…Done
Installing/Updating Required Libraries. This may take a while…The following messages are ONLY FOR DEBUGGING. Ignore anything that says ‘WARN’ or is just a warning
npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
Installed npm-cache v0.7.0
Running installation…
[npm-cache] [INFO] using /home/asterisk/.package_cache as cache directory
[npm-cache] [INFO] [composer] Dependency config file /var/www/html/admin/modules/zulu/node/composer.json does not exist. Skipping install
[npm-cache] [INFO] [npm] config file exists
[npm-cache] [INFO] [npm] cli exists
[npm-cache] [INFO] [npm] hash of /var/www/html/admin/modules/zulu/node/package.json: 9fd2861eafc72195dee2cd05d2a1050b
[npm-cache] [INFO] [npm] cache exists
[npm-cache] [INFO] [npm] clearing installed dependencies at /var/www/html/admin/modules/zulu/node/node_modules
[npm-cache] [INFO] [npm] …cleared
[npm-cache] [INFO] [npm] retrieving dependencies from /home/asterisk/.package_cache/npm/5.6.0/9fd2861eafc72195dee2cd05d2a1050b.tar.gz
[npm-cache] [INFO] [bower] Dependency config file /var/www/html/admin/modules/zulu/node/bower.json does not exist. Skipping install
[npm-cache] [INFO] [npm] done extracting
[npm-cache] [INFO] successfully installed all dependencies

Finished updating libraries!
Stopping old running processes…Stopping Zulu Server
Stopped Zulu Server
Done
Migration from XMPP was done previously
Starting new Zulu Process…Starting Zulu Server…
Started Zulu Server. PID is 25601
Started with PID 25601!
Generating CSS…Done
Module zulu version 15.0.57.12 successfully installed
Updating Hooks…Done
Chowning directories…Done


(Vasman) #4

Well still no further forward, it seem Zulu isn’t all its made out to be, Zooper & X-lite work without any issues, two mins setup and works, why have you made Zulu so complicated ?


(Btaney) #5

I am having pretty much exactly the same issue and can’t find anything… Does anyone have a resolution to this?
Thanks,
Bill


(Marios Tsakmakis) #6

When i first used Zulu i had the exact issue but when updated to latest version, deactivate and then activate again wws and ws and finally rebooted i was good to go!

I hope this helps!


#7

I have actually been having the same issue for a bit, but have not been using Zulu much recently. I went through the server setup, WS/WSS appear to be working:

asterisk -x “pjsip show transports”

Transport: <TransportId…> <BindAddress…>

Transport: 0.0.0.0-tcp tcp 3 96 0.0.0.0:5060
Transport: 0.0.0.0-tls tls 3 96 0.0.0.0:5061
Transport: 0.0.0.0-udp udp 3 96 0.0.0.0:5060
Transport: 0.0.0.0-ws ws 3 96 0.0.0.0:5060
Transport: 0.0.0.0-wss wss 3 96 0.0.0.0:5060

I have disabled/reinstalled zulu with no luck. I have tested with firewalls on/off, does anyone have any suggestions?


#8

Second Zulu stand-up today and I’m having this issue on the newer system.

Zulu 15.0.58.3
FreePBX 12.7.6-2002-2.sng7

The only option in the client is Desk (IP Phone).
The first system is setup as another account and shows both that and Zulu (Softphone)

Transport: 0.0.0.0-tcp tcp 3 96 0.0.0.0:5060
Transport: 0.0.0.0-tls tls 3 96 0.0.0.0:5061
Transport: 0.0.0.0-udp udp 3 96 0.0.0.0:5060
Transport: 0.0.0.0-ws ws 3 96 0.0.0.0:5060
Transport: 0.0.0.0-wss wss 3 96 0.0.0.0:5060

Have disabled and re-enabled the user.
Have disabled and re-enabled Zulu.
fwconsole restart
Full system reboot
Disable and re-enable WS and WSS and then fwconsole restart

No change. Any ideas? Logs to grab?


(Dave Burgess) #9

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug is always a good place to start.


#10

First I removed Zulu entirely, then reinstalled.

Running tail -f /var/log/asterisk/full

Nothing hapens in the log when I start Zulu (on Windows).

I have a STUN server set and the FreePBX internal IP set as an ICE Host Candidate to it’s NATed public IP (same as on the system that’s working).

Here’s the log when trying to make a call with it set to DeskPhone. If there is something else I should grab let me know; it seems like the issue is happening in config or startup of Zulu, not when making a call.

(log was too long to upload inline. Attached txt file with tgz extension)

Asterisk Logs Zulu.tgz (50.2 KB)


#11

The test extension was virtual. For an extension with an associated handset, Zulu says “Softphone reconnecting…” I’ve disabled and re-enabled Zulu for that user. The firewall shows my IP as registered endpoint.

I’ve opened a support case, ticket 954278. Ticket has Zulu client log file attached.


#12

Hugo in support sussed it out.

  1. Even though I’d checked the LE cert, the change hadn’t worked/taken (I’ve seen this happen before with Firefox, but missed it this time). So we set the LE cert as default.
  2. The ICE Host setting that had to be in place for the older system to work had to be removed for this current system to work.

Edit to add:
Quick follow-up. This client connects remote PCs to the office with a Windows SSTP VPN. Without the ICE Host entry, remote Zulu clients connected and worked. But SSTP-connected Zulu clients would not. I put the ICE host entry back and both seem to be working now. I will post back if that changes.
Hugo was great.

2nd follow-up (I can’t have three consecutive posts, so have to edit this one): When adding a new Zulu user i seem to have to toggle the ICE Host. If one is set for the FreePBX server I have to remove. If there isn’t one, I have to add. Went through this four times yesterday and until I toggled the ICE Host, the new instance would stick on “Softphone Connecting…” Once the the client had been added once, it worked. I have no explanation for this. One more to go today.


#13

I realized I never updated this post with a response, my fix was changing my STUN server. Once I applied that change, Zulu (Softphone) showed right up.


(system) closed #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.