Zombie active calls

zombie active calls

System status is showing:
Total Active Calls 10
Internal calls 5
External calls 5
Total Active channels 20
but I dont think there are any at the moment.
My ver is FreePBX 2.5.0rc3.0

PBXinaFlash


  • Running Asterisk Version : Asterisk 1.4.21.2
  • Asterisk Source Version : 1.4.21.2
  • Zaptel Source Version : 1.4.11
  • Libpri Source Version : 1.4.7
  • Addons Source Version : 1.4.7

CentOS release 5 (Final) - 32 Bit ** Kernel: 2.6.18-53.1.14.el5

Please help troubleshoot/diagnose wassup?
Thanks!

pbx*CLI> sip show channels
Peer User/ANR Call ID Seq (Tx/Rx) Format Hold Last Message
64.61.93.190 ZDt92ruS96 0d58e7e7755 04336/00000 0x0 (nothing) No
64.61.93.190 +180086511 48811b8677b 00103/00000 0x3f0004 (ulaw| No Tx: ACK
67.108.9.165 ZDt92ruS96 7cd97ef715d 00101/00102 0x4 (ulaw) No Rx: ACK
67.108.9.165 +180086511 78ffb2ff60f 00103/00000 0x3f0004 (ulaw| No Tx: ACK
67.108.9.165 ZDt92ruS96 3a12994c682 00101/00102 0x4 (ulaw) No Rx: ACK
67.108.9.165 +140849424 61d171f9361 00103/00000 0x3f0004 (ulaw| No Tx: ACK
67.108.9.165 ZDt92ruS96 72483b751aa 00101/00102 0x4 (ulaw) No Rx: ACK
67.108.9.165 +140849424 3b4cd3c67b0 00103/00000 0x3f0004 (ulaw| No Tx: ACK
67.108.9.165 ZDt92ruS96 7ae924205d7 00101/00102 0x4 (ulaw) No Rx: ACK
67.108.9.165 +180086511 4da898450d9 00103/00000 0x3f0004 (ulaw| No Tx: ACK
67.108.9.165 ZDt92ruS96 70ac9f3b388 00101/00102 0x4 (ulaw) No Rx: ACK

pbx*CLI> soft hangup
Local/[email protected],1 Local/[email protected],2 Local/[email protected],1
Local/[email protected],2 Local/[email protected],1 Local/[email protected],2
Local/[email protected],1 Local/[email protected],2 Local/[email protected],1
Local/[email protected],2 SIP/VP-SIPSJCA-0a1c8318 SIP/VP-SIPSJCA-0a2328b0
SIP/VP-SIPSJCA-0a245d80 SIP/VP-SIPSJCA-0a247a10 SIP/VP-SIPSJCB-0a274978
SIP/ZDt92ruS96-0a1b78e8 SIP/ZDt92ruS96-0a230470 SIP/ZDt92ruS96-0a251350
SIP/ZDt92ruS96-0a25c2c0 SIP/ZDt92ruS96-0a1cca28

where XXXX are valid -
I am not sure if this info is sensitive, so blotted it out.

I think you’re right, but I don’t think they’re “zombie” calls. For some reason, it doesn’t seem that the system status “tracks” the number of calls in real time. It looks to me that it may delay reporting anywhere from a few seconds to 30 or more seconds. As I’ve said, I’ve noticed this, but really haven’t paid a whole lot of attention to it except as a curiosity.

Maybe Phillippe or the other developers could shed some light on how it operates.

Bill/W5WAF