ZOHO Integration on "non-SIP" connections

OK, so one of my long-time customers is trying to integrate Zoho with FreePBX 13/Asterisk 13.

Zoho supports Asterisk 1.4, and the VOIP Connector they are using supposedly works with Asterisk 1.8. I’m pretty sure that the protocol they are using is coming in on either ARI or AMI.

From what I can tell, the setup is fairly straight forward. The one wrinkle that I’ve found is that the customer has implemented all of his Yealink phones on PJSIP and Zoho is trying to connect to SIP.

I’m trying to convince the Zoho people to change their interface to LOCAL/exten from SIP/exten. This might not solve all of the problems, but I think it will give us a good starting point. Failing the Zoho people’s cooperation, is there a way to change the Channel Type from PJSIP to SIP in the PBX? I’m pretty sure it isn’t as simple as changing the string, but it would be good first step.

I looked back through the forums, and it turns out that I was the only person that touched this last time it came up. Anyone want to help me take a run at this thing?

Little bump on this topic.

Figured I would throw this out there. So it hopefully helps someone else.

I found part of the solution for this between a couple different websites, but we still got some more bugs to work out.

Links
https://wiki.noojee.com.au/Noojee_Campaigner/Integration/01.Methods/Zoho_CRM-_phone_bridge
and then the connecting one was from this http://wiki.freepbx.org/display/FPG/Asterisk+Managers+Interface

Previously we were creating a normal user account. “Admin > User Management” this did not work. Instead you need to create the user for the “Zoho/ztiadapter/teleadapters/asterisk14/conf/asterisk14.properties” file in “Settings > Asterisk Manager Users”

> #$Id$

> #Outgoing call context of Asterisk Server - dont change unnecessarily
> outgoingcallcontext=from-internal

> #Asterisk server details
> asterisk.server=localhost
> asterisk.manager.username=zoho-phonebridge
> asterisk.manager.password=<manager-password-goes-here>

Then put the same manager user password in the “manager_custom.conf” file.

[zoho-phonebridge]
secret=<manager-password-goes-here>
deny=0.0.0.0/0.0.0.0
permit=127.0.0.1/255.255.255.0

Ok so this allows a call now to connect from ZOHO to the external extension. However ZOHO doesn’t show that the call has connected, and when I call from external to that extension ZOHO doesn’t register that call like it should.

As I find out more I will update.

Have you had any luck making this work?

No I haven’t. See this other thread here.

The Sangoma CRM Link module now supports both Zoho and SalesForce. https://wiki.freepbx.org/display/FPG/Customer+Relationship+Management

1 Like

Awesome, does this include the ZULU module as well for the Click to call?

No Zulu provides click to call from a browser and works with chrome and Firefox for any page not specific to CRM. This module provides CRM integration for call history, call recordings, voicemails and ability if you have licensed Zulu to have it screen pop your CRM records.