Yum upgrade nodejs error

Transaction Check Error:
  file /usr/lib/node_modules/npm/node_modules/semver/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-semver-2.1.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/semver/bin/semver from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-semver-2.1.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/semver/semver.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-semver-2.1.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/mkdirp/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-mkdirp-0.3.5-3.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/mkdirp/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-mkdirp-0.3.5-3.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/graceful-fs/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-graceful-fs-2.0.0-2.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-graceful-fs-2.0.0-2.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-graceful-fs-2.0.0-2.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/rimraf/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-rimraf-2.2.2-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/rimraf/rimraf.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-rimraf-2.2.2-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/reader.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/fstream.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/abstract.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/collect.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/dir-reader.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/dir-writer.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/file-reader.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/file-writer.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/get-type.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/link-reader.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/link-writer.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/proxy-reader.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/proxy-writer.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/socket-reader.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream/lib/writer.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-0.1.24-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/osenv/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-osenv-0.0.3-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/osenv/osenv.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-osenv-0.0.3-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/slide/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-slide-1.1.5-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/slide/lib/async-map.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-slide-1.1.5-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/lru-cache/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-lru-cache-2.3.0-3.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/lru-cache/lib/lru-cache.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-lru-cache-2.3.0-3.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/ini/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-ini-1.1.0-3.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/ini/ini.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-ini-1.1.0-3.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/hoek/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hoek-0.9.1-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/hoek/lib/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hoek-0.9.1-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/hoek/lib/escape.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hoek-0.9.1-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/boom/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-boom-0.4.2-2.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/boom/lib/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-boom-0.4.2-2.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/block-stream/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-block-stream-0.0.7-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/tar/lib/pack.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-tar-0.1.18-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/tar/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-tar-0.1.18-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/tar/lib/parse.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-tar-0.1.18-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/tar/lib/entry.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-tar-0.1.18-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/tar/lib/extract.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-tar-0.1.18-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/npm-registry-client/node_modules/retry/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-retry-0.6.0-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/retry/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-retry-0.6.0-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/npm-registry-client/node_modules/retry/lib/retry.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-retry-0.6.0-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/retry/lib/retry.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-retry-0.6.0-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/npm-registry-client/node_modules/retry/lib/retry_operation.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-retry-0.6.0-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/retry/lib/retry_operation.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-retry-0.6.0-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/chownr/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-chownr-0.0.1-9.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/chownr/chownr.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-chownr-0.0.1-9.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/ansi/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-ansi-0.2.1-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/ansi/lib/ansi.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-ansi-0.2.1-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/npmlog/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-npmlog-0.0.4-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/npmlog/log.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-npmlog-0.0.4-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/abbrev/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-abbrev-1.0.4-6.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/nopt/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-nopt-2.1.2-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/nopt/bin/nopt.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-nopt-2.1.2-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/nopt/lib/nopt.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-nopt-2.1.2-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/once/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-once-1.1.1-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/once/once.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-once-1.1.1-5.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/which/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-which-1.0.5-8.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/which/bin/which from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-which-1.0.5-8.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/which/which.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-which-1.0.5-8.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/cryptiles/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-cryptiles-0.2.2-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/cryptiles/lib/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-cryptiles-0.2.2-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/sntp/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-sntp-0.2.4-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/sntp/lib/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-sntp-0.2.4-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/lib/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/lib/utils.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/lib/browser.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/lib/client.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/lib/crypto.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/lib/server.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/boom from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/cryptiles from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/hoek from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/hawk/node_modules/sntp from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-hawk-1.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/sha/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-sha-1.2.1-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/sha/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-sha-1.2.1-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/cmd-shim/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-cmd-shim-1.1.0-3.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/cmd-shim/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-cmd-shim-1.1.0-3.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/editor/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-editor-0.0.4-2.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/editor/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-editor-0.0.4-2.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/npm-user-validate/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-npm-user-validate-0.0.3-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/npm-user-validate/npm-user-validate.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-npm-user-validate-0.0.3-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/uid-number/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-uid-number-0.0.3-7.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/uid-number/uid-number.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-uid-number-0.0.3-7.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/lockfile/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-lockfile-0.4.2-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/lockfile/lockfile.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-lockfile-0.4.2-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/chmodr/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-chmodr-0.1.0-4.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/chmodr/chmodr.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-chmodr-0.1.0-4.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/opener/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-opener-1.3.0-7.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/opener/opener.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-opener-1.3.0-7.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/archy/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-archy-0.0.2-8.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/minimatch/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-minimatch-0.2.12-2.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/minimatch/minimatch.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-minimatch-0.2.12-2.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/glob/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-glob-3.2.6-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/read-package-json/node_modules/glob/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-glob-3.2.6-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/glob/glob.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-glob-3.2.6-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/read-package-json/node_modules/glob/glob.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-glob-3.2.6-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream-npm/node_modules/fstream-ignore/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-ignore-0.0.7-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream-npm/node_modules/fstream-ignore/ignore.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-ignore-0.0.7-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream-npm/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-npm-0.1.5-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream-npm/fstream-npm.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-npm-0.1.5-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/fstream-npm/node_modules/fstream-ignore from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-fstream-npm-0.1.5-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/read/node_modules/mute-stream/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-mute-stream-0.0.4-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/read/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-read-1.0.5-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/read/node_modules/mute-stream from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-read-1.0.5-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/init-package-json/node_modules/promzard/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-promzard-0.2.0-6.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/init-package-json/node_modules/promzard/promzard.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-promzard-0.2.0-6.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/qs/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-qs-0.6.6-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/node-uuid/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-node-uuid-1.4.1-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/node-uuid/uuid.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-node-uuid-1.4.1-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/forever-agent/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-forever-agent-0.5.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/forever-agent/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-forever-agent-0.5.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/oauth-sign/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-oauth-sign-0.3.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/oauth-sign/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-oauth-sign-0.3.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/json-stringify-safe/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-json-stringify-safe-5.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/json-stringify-safe/stringify.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-json-stringify-safe-5.0.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/tunnel-agent/package.json from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-tunnel-agent-0.3.0-1.el6.noarch
  file /usr/lib/node_modules/npm/node_modules/request/node_modules/tunnel-agent/index.js from install of nodejs-0.12.18-1nodesource.el6.i686 conflicts with file from package nodejs-tunnel-agent-0.3.0-1.el6.noarch

yum remove nodejs*
yum install nodejs

Fixed thank u