Yum upgrade failed on distro


(Tony Guadagno) #1

hi, i am using distro 15. i patched not to long ago with no issues, but i went to patch again yesterday. and got these errors

Error: Package: sangoma-pbx-2008-1.sng7.noarch (sng-pkgs)
           Requires: kmod-via-rhine
           Removing: kmod-via-rhine-1.5.2-1.sng7.x86_64 (@anaconda/1703)
               kmod-via-rhine = 1.5.2-1.sng7
           Available: kmod-via-rhine-1.5.1-4.sng7.x86_64 (sng-pkgs)
               kmod-via-rhine = 1.5.1-4.sng7
           Available: kmod-via-rhine-1.5.1-5.sng7.x86_64 (sng-pkgs)
               kmod-via-rhine = 1.5.1-5.sng7
           Available: kmod-via-rhine-1.5.1-6.sng7.x86_64 (sng-pkgs)
               kmod-via-rhine = 1.5.1-6.sng7
Error: Package: sangoma-pbx-2008-1.sng7.noarch (sng-pkgs)
           Requires: kmod-via-velocity
           Removing: kmod-via-velocity-1.16-1.sng7.x86_64 (@anaconda/1703)
               kmod-via-velocity = 1.16-1.sng7
           Available: kmod-via-velocity-1.15-2.sng7.x86_64 (sng-pkgs)
               kmod-via-velocity = 1.15-2.sng7
           Available: kmod-via-velocity-1.15-3.sng7.x86_64 (sng-pkgs)
               kmod-via-velocity = 1.15-3.sng7
           Available: kmod-via-velocity-1.15-4.sng7.x86_64 (sng-pkgs)
               kmod-via-velocity = 1.15-4.sng7

anyone give me a clue as to what to do about this?

here is the full log if anyone needs it
thanks in advance

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2020.09.27 12:02:14 =~=~=~=~=~=~=~=~=~=~=~=
—> Package kmod-libs.x86_64 0:20-23.el7 will be updated
—> Package kmod-libs.x86_64 0:20-28.el7 will be an update
—> Package kmod-wanpipe.x86_64 0:7.0.25-2.sng7 will be updated
—> Package kmod-wanpipe.x86_64 0:7.0.25-3.sng7 will be an update
—> Package kpartx.x86_64 0:0.4.9-123.el7 will be updated
—> Package kpartx.x86_64 0:0.4.9-131.el7 will be an update
—> Package krb5-libs.x86_64 0:1.15.1-37.el7_6 will be updated
—> Package krb5-libs.x86_64 0:1.15.1-46.el7 will be an update
—> Package libX11.x86_64 0:1.6.5-2.el7 will be updated
—> Package libX11.x86_64 0:1.6.7-2.el7 will be an update
—> Package libX11-common.noarch 0:1.6.5-2.el7 will be updated
—> Package libX11-common.noarch 0:1.6.7-2.el7 will be an update
—> Package libacl.x86_64 0:2.2.51-14.el7 will be updated
—> Package libacl.x86_64 0:2.2.51-15.el7 will be an update
—> Package libavdevice.x86_64 0:3.1.1-2.sng7 will be updated
—> Package libavdevice.x86_64 0:3.1.1-4.sng7 will be an update
—> Package libblkid.x86_64 0:2.23.2-59.el7_6.1 will be updated
—> Package libblkid.x86_64 0:2.23.2-63.el7 will be an update
—> Package libcap.x86_64 0:2.22-9.el7 will be updated
—> Package libcap.x86_64 0:2.22-11.el7 will be an update
—> Package libcom_err.x86_64 0:1.42.9-13.el7 will be updated
—> Package libcom_err.x86_64 0:1.42.9-17.el7 will be an update
—> Package libcurl.x86_64 0:7.29.0-51.el7 will be updated
—> Package libcurl.x86_64 0:7.29.0-57.el7_8.1 will be an update
—> Package libdb.x86_64 0:5.3.21-24.el7 will be updated
—> Package libdb.x86_64 0:5.3.21-25.el7 will be an update
—> Package libdb-utils.x86_64 0:5.3.21-24.el7 will be updated
—> Package libdb-utils.x86_64 0:5.3.21-25.el7 will be an update
—> Package libdrm.x86_64 0:2.4.91-3.el7 will be updated
—> Package libdrm.x86_64 0:2.4.97-2.el7 will be an update
—> Package libffi.x86_64 0:3.0.13-18.el7 will be updated
—> Package libffi.x86_64 0:3.0.13-19.el7 will be an update
—> Package libgcc.x86_64 0:4.8.5-36.el7_6.2 will be updated
—> Package libgcc.x86_64 0:4.8.5-39.el7 will be an update
—> Package libgomp.x86_64 0:4.8.5-36.el7_6.2 will be updated
—> Package libgomp.x86_64 0:4.8.5-39.el7 will be an update
—> Package libicu.x86_64 0:50.1.2-17.el7 will be updated
—> Package libicu.x86_64 0:50.2-4.el7_7 will be an update
—> Package libicu-devel.x86_64 0:50.1.2-17.el7 will be updated
—> Package libicu-devel.x86_64 0:50.2-4.el7_7 will be an update
—> Package libjpeg-turbo.x86_64 0:1.2.90-6.el7 will be updated
—> Package libjpeg-turbo.x86_64 0:1.2.90-8.el7 will be an update
—> Package libmount.x86_64 0:2.23.2-59.el7_6.1 will be updated
—> Package libmount.x86_64 0:2.23.2-63.el7 will be an update
—> Package libmspack.x86_64 0:0.5-0.6.alpha.el7 will be updated
—> Package libmspack.x86_64 0:0.5-0.7.alpha.el7 will be an update
—> Package libpcap.x86_64 14:1.5.3-11.el7 will be updated
—> Package libpcap.x86_64 14:1.5.3-12.el7 will be an update
—> Package libreport-filesystem.x86_64 0:2.1.11-42.el7.centos will be updated
—> Package libreport-filesystem.x86_64 0:2.1.11-53.el7.centos will be an update
—> Package libseccomp.x86_64 0:2.3.1-3.el7 will be updated
—> Package libseccomp.x86_64 0:2.3.1-4.el7 will be an update
—> Package libselinux.x86_64 0:2.5-14.1.el7 will be updated
—> Package libselinux.x86_64 0:2.5-15.el7 will be an update
—> Package libselinux-python.x86_64 0:2.5-14.1.el7 will be updated
—> Package libselinux-python.x86_64 0:2.5-15.el7 will be an update
—> Package libselinux-utils.x86_64 0:2.5-14.1.el7 will be updated
—> Package libselinux-utils.x86_64 0:2.5-15.el7 will be an update
—> Package libsmartcols.x86_64 0:2.23.2-59.el7_6.1 will be updated
—> Package libsmartcols.x86_64 0:2.23.2-63.el7 will be an update
—> Package libsndfile.x86_64 0:1.0.25-10.el7 will be updated
—> Package libsndfile.x86_64 0:1.0.25-11.el7 will be an update
—> Package libss.x86_64 0:1.42.9-13.el7 will be updated
—> Package libss.x86_64 0:1.42.9-17.el7 will be an update
—> Package libssh2.x86_64 0:1.4.3-12.el7_6.2 will be updated
—> Package libssh2.x86_64 0:1.8.0-3.el7 will be an update
—> Package libstdc++.x86_64 0:4.8.5-36.el7_6.2 will be updated
—> Package libstdc++.x86_64 0:4.8.5-39.el7 will be an update
—> Package libstdc+±devel.x86_64 0:4.8.5-36.el7_6.2 will be updated
—> Package libstdc+±devel.x86_64 0:4.8.5-39.el7 will be an update
—> Package libtalloc.x86_64 0:2.1.13-1.el7 will be updated
—> Package libtalloc.x86_64 0:2.1.16-1.el7 will be an update
—> Package libtiff.x86_64 0:4.0.3-27.el7_3 will be updated
—> Package libtiff.x86_64 0:4.0.3-32.el7 will be an update
—> Package libtiff-tools.x86_64 0:4.0.3-27.el7_3 will be updated
—> Package libtiff-tools.x86_64 0:4.0.3-32.el7 will be an update
—> Package libtirpc.x86_64 0:0.2.4-0.15.el7 will be updated
—> Package libtirpc.x86_64 0:0.2.4-0.16.el7 will be an update
—> Package libuuid.x86_64 0:2.23.2-59.el7_6.1 will be updated
—> Package libuuid.x86_64 0:2.23.2-63.el7 will be an update
—> Package libxml2.x86_64 0:2.9.1-6.el7_2.3 will be updated
—> Package libxml2.x86_64 0:2.9.1-6.el7.4 will be an update
—> Package libxml2-python.x86_64 0:2.9.1-6.el7_2.3 will be updated
—> Package libxml2-python.x86_64 0:2.9.1-6.el7.4 will be an update
—> Package linux-firmware.noarch 0:20180911-69.git85c5d90.el7 will be updated
—> Package linux-firmware.noarch 0:20191203-76.gite8a0f4c.el7 will be an update
—> Package lldpad.x86_64 0:1.0.1-3.git036e314.el7 will be updated
—> Package lldpad.x86_64 0:1.0.1-5.git036e314.el7 will be an update
—> Package lm_sensors.x86_64 0:3.4.0-6.20160601gitf9185e5.el7 will be updated
—> Package lm_sensors.x86_64 0:3.4.0-8.20160601gitf9185e5.el7 will be an update
—> Package lm_sensors-libs.x86_64 0:3.4.0-6.20160601gitf9185e5.el7 will be updated
—> Package lm_sensors-libs.x86_64 0:3.4.0-8.20160601gitf9185e5.el7 will be an update
—> Package logrotate.x86_64 0:3.8.6-17.el7 will be updated
—> Package logrotate.x86_64 0:3.8.6-19.el7 will be an update
—> Package lvm2.x86_64 7:2.02.180-10.el7_6.8 will be updated
—> Package lvm2.x86_64 7:2.02.186-7.el7_8.2 will be an update
—> Package lvm2-libs.x86_64 7:2.02.180-10.el7_6.8 will be updated
—> Package lvm2-libs.x86_64 7:2.02.186-7.el7_8.2 will be an update
—> Package lz4.x86_64 0:1.7.5-2.el7 will be updated
—> Package lz4.x86_64 0:1.7.5-3.el7 will be an update
—> Package make.x86_64 1:3.82-23.el7 will be updated
—> Package make.x86_64 1:3.82-24.el7 will be an update
—> Package mariadb.x86_64 1:5.5.60-1.el7_5 will be updated
—> Package mariadb.x86_64 1:5.5.65-1.el7 will be an update
—> Package mariadb-libs.x86_64 1:5.5.60-1.el7_5 will be updated
—> Package mariadb-libs.x86_64 1:5.5.65-1.el7 will be an update
—> Package mariadb-server.x86_64 1:5.5.60-1.el7_5 will be updated
—> Package mariadb-server.x86_64 1:5.5.65-1.el7 will be an update
—> Package mdadm.x86_64 0:4.1-rc1_2.el7 will be updated
—> Package mdadm.x86_64 0:4.1-4.el7 will be an update
—> Package mesa-libEGL.x86_64 0:18.0.5-4.el7_6 will be updated
—> Package mesa-libEGL.x86_64 0:18.3.4-7.el7_8.1 will be an update
—> Package mesa-libGL.x86_64 0:18.0.5-4.el7_6 will be updated
—> Package mesa-libGL.x86_64 0:18.3.4-7.el7_8.1 will be an update
—> Package mesa-libgbm.x86_64 0:18.0.5-4.el7_6 will be updated
—> Package mesa-libgbm.x86_64 0:18.3.4-7.el7_8.1 will be an update
—> Package mesa-libglapi.x86_64 0:18.0.5-4.el7_6 will be updated
—> Package mesa-libglapi.x86_64 0:18.3.4-7.el7_8.1 will be an update
—> Package mod_ssl.x86_64 1:2.4.6-89.13.sng7.sangoma will be updated
—> Package mod_ssl.x86_64 1:2.4.6-93.el7.centos will be an update
—> Package mokutil.x86_64 0:15-2.el7.centos will be updated
—> Package mokutil.x86_64 0:15-8.el7 will be an update
—> Package neon.x86_64 0:0.30.0-3.el7 will be updated
—> Package neon.x86_64 0:0.30.0-4.el7 will be an update
—> Package net-snmp.x86_64 1:5.7.2-37.el7 will be updated
—> Package net-snmp.x86_64 1:5.7.2-48.el7_8.1 will be an update
—> Package net-snmp-agent-libs.x86_64 1:5.7.2-37.el7 will be updated
—> Package net-snmp-agent-libs.x86_64 1:5.7.2-48.el7_8.1 will be an update
—> Package net-snmp-libs.x86_64 1:5.7.2-37.el7 will be updated
—> Package net-snmp-libs.x86_64 1:5.7.2-48.el7_8.1 will be an update
—> Package net-tools.x86_64 0:2.0-0.24.20131004git.el7 will be updated
—> Package net-tools.x86_64 0:2.0-0.25.20131004git.el7 will be an update
—> Package nmap.x86_64 2:6.40-16.el7 will be updated
—> Package nmap.x86_64 2:6.40-19.el7 will be an update
—> Package nmap-ncat.x86_64 2:6.40-16.el7 will be updated
—> Package nmap-ncat.x86_64 2:6.40-19.el7 will be an update
—> Package nodejs.x86_64 2:8.11.3-1.7 will be updated
—> Package nodejs.x86_64 2:8.16.0-1.11 will be an update
—> Package nspr.x86_64 0:4.19.0-1.el7_5 will be updated
—> Package nspr.x86_64 0:4.21.0-1.el7 will be an update
—> Package nss.x86_64 0:3.36.0-7.1.el7_6 will be updated
—> Package nss.x86_64 0:3.44.0-7.el7_7 will be an update
—> Package nss-pem.x86_64 0:1.0.3-5.el7_6.1 will be updated
—> Package nss-pem.x86_64 0:1.0.3-7.el7 will be an update
—> Package nss-softokn.x86_64 0:3.36.0-5.el7_5 will be updated
—> Package nss-softokn.x86_64 0:3.44.0-8.el7_7 will be an update
—> Package nss-softokn-freebl.x86_64 0:3.36.0-5.el7_5 will be updated
—> Package nss-softokn-freebl.x86_64 0:3.44.0-8.el7_7 will be an update
—> Package nss-sysinit.x86_64 0:3.36.0-7.1.el7_6 will be updated
—> Package nss-sysinit.x86_64 0:3.44.0-7.el7_7 will be an update
—> Package nss-tools.x86_64 0:3.36.0-7.1.el7_6 will be updated
—> Package nss-tools.x86_64 0:3.44.0-7.el7_7 will be an update
—> Package nss-util.x86_64 0:3.36.0-1.1.el7_6 will be updated
—> Package nss-util.x86_64 0:3.44.0-4.el7_7 will be an update
—> Package ntp.x86_64 0:4.2.6p5-28.el7.centos will be updated
—> Package ntp.x86_64 0:4.2.6p5-29.el7.centos.2 will be an update
—> Package ntpdate.x86_64 0:4.2.6p5-28.el7.centos will be updated
—> Package ntpdate.x86_64 0:4.2.6p5-29.el7.centos.2 will be an update
—> Package numactl-libs.x86_64 0:2.0.9-7.el7 will be updated
—> Package numactl-libs.x86_64 0:2.0.12-5.el7 will be an update
—> Package open-vm-tools.x86_64 0:10.2.5-3.el7 will be updated
—> Package open-vm-tools.x86_64 0:10.3.10-2.el7_8.1 will be an update
—> Package openssh.x86_64 0:7.4p1-16.el7 will be updated
—> Package openssh.x86_64 0:7.4p1-21.el7 will be an update
—> Package openssh-clients.x86_64 0:7.4p1-16.el7 will be updated
—> Package openssh-clients.x86_64 0:7.4p1-21.el7 will be an update
—> Package openssh-server.x86_64 0:7.4p1-16.el7 will be updated
—> Package openssh-server.x86_64 0:7.4p1-21.el7 will be an update
—> Package openssl.x86_64 1:1.0.2k-16.el7_6.1 will be updated
—> Package openssl.x86_64 1:1.0.2k-19.el7 will be an update
—> Package openssl-libs.x86_64 1:1.0.2k-16.el7_6.1 will be updated
—> Package openssl-libs.x86_64 1:1.0.2k-19.el7 will be an update
—> Package openvpn.x86_64 0:2.4.7-1.el7 will be updated
—> Package openvpn.x86_64 0:2.4.9-1.el7 will be an update
—> Package pam.x86_64 0:1.1.8-22.el7 will be updated
—> Package pam.x86_64 0:1.1.8-23.el7 will be an update
—> Package pango.x86_64 0:1.42.4-2.el7_6 will be updated
—> Package pango.x86_64 0:1.42.4-4.el7_7 will be an update
—> Package parted.x86_64 0:3.1-29.el7 will be updated
—> Package parted.x86_64 0:3.1-32.el7 will be an update
—> Package passwd.x86_64 0:0.79-4.el7 will be updated
—> Package passwd.x86_64 0:0.79-6.el7 will be an update
—> Package patch.x86_64 0:2.7.1-10.el7_5 will be updated
—> Package patch.x86_64 0:2.7.1-12.el7_7 will be an update
—> Package perl.x86_64 4:5.16.3-294.el7_6 will be updated
—> Package perl.x86_64 4:5.16.3-295.el7 will be an update
—> Package perl-Git.noarch 0:1.8.3.1-20.el7 will be updated
—> Package perl-Git.noarch 0:1.8.3.1-23.el7_8 will be an update
—> Package perl-Pod-Escapes.noarch 1:1.04-294.el7_6 will be updated
—> Package perl-Pod-Escapes.noarch 1:1.04-295.el7 will be an update
—> Package perl-Socket.x86_64 0:2.010-4.el7 will be updated
—> Package perl-Socket.x86_64 0:2.010-5.el7 will be an update
—> Package perl-libs.x86_64 4:5.16.3-294.el7_6 will be updated
—> Package perl-libs.x86_64 4:5.16.3-295.el7 will be an update
—> Package perl-macros.x86_64 4:5.16.3-294.el7_6 will be updated
—> Package perl-macros.x86_64 4:5.16.3-295.el7 will be an update
—> Package plymouth.x86_64 0:0.8.9-0.31.20140113.el7.centos will be updated
—> Package plymouth.x86_64 0:0.8.9-0.33.20140113.el7.centos will be an update
—> Package plymouth-core-libs.x86_64 0:0.8.9-0.31.20140113.el7.centos will be updated
—> Package plymouth-core-libs.x86_64 0:0.8.9-0.33.20140113.el7.centos will be an update
—> Package plymouth-scripts.x86_64 0:0.8.9-0.31.20140113.el7.centos will be updated
—> Package plymouth-scripts.x86_64 0:0.8.9-0.33.20140113.el7.centos will be an update
—> Package policycoreutils.x86_64 0:2.5-29.el7_6.1 will be updated
—> Package policycoreutils.x86_64 0:2.5-34.el7 will be an update
—> Package polkit.x86_64 0:0.112-18.el7_6.1 will be updated
—> Package polkit.x86_64 0:0.112-26.el7 will be an update
—> Package postfix.x86_64 2:2.10.1-7.el7 will be updated
—> Package postfix.x86_64 2:2.10.1-9.el7 will be an update
—> Package procps-ng.x86_64 0:3.3.10-23.el7 will be updated
—> Package procps-ng.x86_64 0:3.3.10-27.el7 will be an update
—> Package psmisc.x86_64 0:22.20-15.el7 will be updated
—> Package psmisc.x86_64 0:22.20-16.el7 will be an update
—> Package python.x86_64 0:2.7.5-80.el7_6 will be updated
—> Package python.x86_64 0:2.7.5-88.el7 will be an update
—> Package python-chardet.noarch 0:2.2.1-1.el7_1 will be updated
—> Package python-chardet.noarch 0:2.2.1-3.el7 will be an update
—> Package python-firewall.noarch 0:0.5.3-5.el7 will be updated
—> Package python-firewall.noarch 0:0.6.3-8.el7_8.1 will be an update
—> Package python-jinja2.noarch 0:2.7.2-3.el7_6 will be updated
—> Package python-jinja2.noarch 0:2.7.2-4.el7 will be an update
—> Package python-libs.x86_64 0:2.7.5-80.el7_6 will be updated
—> Package python-libs.x86_64 0:2.7.5-88.el7 will be an update
—> Package python-linux-procfs.noarch 0:0.4.9-4.el7 will be updated
—> Package python-linux-procfs.noarch 0:0.4.11-4.el7 will be an update
—> Package python-perf.x86_64 0:3.10.0-957.21.3.el7 will be updated
—> Package python-perf.x86_64 0:3.10.0-1127.19.1.el7 will be an update
—> Package python-requests.noarch 0:2.6.0-1.el7_1 will be updated
—> Package python-requests.noarch 0:2.6.0-9.el7_8 will be an update
—> Package python-urlgrabber.noarch 0:3.10-9.el7 will be updated
—> Package python-urlgrabber.noarch 0:3.10-10.el7 will be an update
—> Package python-urllib3.noarch 0:1.10.2-5.el7 will be updated
—> Package python-urllib3.noarch 0:1.10.2-7.el7 will be an update
—> Package quota.x86_64 1:4.01-17.el7 will be updated
—> Package quota.x86_64 1:4.01-19.el7 will be an update
—> Package quota-nls.noarch 1:4.01-17.el7 will be updated
—> Package quota-nls.noarch 1:4.01-19.el7 will be an update
—> Package readline.x86_64 0:6.2-10.el7 will be updated
—> Package readline.x86_64 0:6.2-11.el7 will be an update
—> Package redhat-rpm-config.noarch 0:9.1.0-87.el7.centos will be updated
—> Package redhat-rpm-config.noarch 0:9.1.0-88.el7.centos will be an update
–> Processing Dependency: python-srpm-macros for package: redhat-rpm-config-9.1.0-88.el7.centos.noarch
—> Package rpcbind.x86_64 0:0.2.0-47.el7 will be updated
—> Package rpcbind.x86_64 0:0.2.0-49.el7 will be an update
—> Package rpm.x86_64 0:4.11.3-35.el7 will be updated
—> Package rpm.x86_64 0:4.11.3-43.el7 will be an update
—> Package rpm-build.x86_64 0:4.11.3-35.el7 will be updated
—> Package rpm-build.x86_64 0:4.11.3-43.el7 will be an update
—> Package rpm-build-libs.x86_64 0:4.11.3-35.el7 will be updated
—> Package rpm-build-libs.x86_64 0:4.11.3-43.el7 will be an update
—> Package rpm-libs.x86_64 0:4.11.3-35.el7 will be updated
—> Package rpm-libs.x86_64 0:4.11.3-43.el7 will be an update
—> Package rpm-python.x86_64 0:4.11.3-35.el7 will be updated
—> Package rpm-python.x86_64 0:4.11.3-43.el7 will be an update
—> Package rsync.x86_64 0:3.1.2-6.el7_6.1 will be updated
—> Package rsync.x86_64 0:3.1.2-10.el7 will be an update
—> Package rsyslog.x86_64 0:8.24.0-34.el7 will be updated
—> Package rsyslog.x86_64 0:8.24.0-52.el7_8.2 will be an update
—> Package sangoma-pbx.noarch 0:2002-2.sng7 will be updated
—> Package sangoma-pbx.noarch 0:2008-1.sng7 will be an update
—> Package sangoma-release.x86_64 0:7-5.1805.02.el7.sangoma will be updated
—> Package sangoma-release.x86_64 0:7-8.2003.3.el7.sangoma will be an update
—> Package sed.x86_64 0:4.2.2-5.el7 will be updated
—> Package sed.x86_64 0:4.2.2-6.el7 will be an update
—> Package selinux-policy.noarch 0:3.13.1-229.el7_6.12 will be updated
—> Package selinux-policy.noarch 0:3.13.1-266.el7_8.1 will be an update
—> Package selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.12 will be updated
—> Package selinux-policy-targeted.noarch 0:3.13.1-266.el7_8.1 will be an update
—> Package setup.noarch 0:2.8.71-10.el7 will be updated
—> Package setup.noarch 0:2.8.71-11.el7 will be an update
—> Package shadow-utils.x86_64 2:4.1.5.1-25.el7_6.1 will be updated
—> Package shadow-utils.x86_64 2:4.6-5.el7 will be an update
—> Package shared-mime-info.x86_64 0:1.8-4.el7 will be updated
—> Package shared-mime-info.x86_64 0:1.8-5.el7 will be an update
—> Package shim-x64.x86_64 0:15-2.el7.centos will be updated
—> Package shim-x64.x86_64 0:15-8.el7 will be an update
—> Package sox.x86_64 0:14.4.1-6.el7 will be updated
—> Package sox.x86_64 0:14.4.1-7.el7 will be an update
—> Package sqlite.x86_64 0:3.7.17-8.el7 will be updated
—> Package sqlite.x86_64 0:3.7.17-8.el7_7.1 will be an update
—> Package ssh_keys.noarch 0:3.1-73.sng7 will be updated
—> Package ssh_keys.noarch 0:3.1-76.sng7 will be an update
—> Package sudo.x86_64 0:1.8.23-3.el7 will be updated
—> Package sudo.x86_64 0:1.8.23-9.el7 will be an update
—> Package sysstat.x86_64 0:10.1.5-17.el7 will be updated
—> Package sysstat.x86_64 0:10.1.5-19.el7 will be an update
—> Package systemd.x86_64 0:219-62.el7_6.7 will be updated
—> Package systemd.x86_64 0:219-73.el7_8.9 will be an update
—> Package systemd-libs.x86_64 0:219-62.el7_6.7 will be updated
—> Package systemd-libs.x86_64 0:219-73.el7_8.9 will be an update
—> Package systemd-sysv.x86_64 0:219-62.el7_6.7 will be updated
—> Package systemd-sysv.x86_64 0:219-73.el7_8.9 will be an update
—> Package tcpdump.x86_64 14:4.9.2-3.el7 will be updated
—> Package tcpdump.x86_64 14:4.9.2-4.el7_7.1 will be an update
—> Package telnet.x86_64 1:0.17-64.el7 will be updated
—> Package telnet.x86_64 1:0.17-65.el7_8 will be an update
—> Package tftp-server.x86_64 0:5.2-23.6.sng7 will be updated
—> Package tftp-server.x86_64 0:5.2-23.8.sng7 will be an update
—> Package tmpwatch.x86_64 0:2.11-5.el7 will be updated
—> Package tmpwatch.x86_64 0:2.11-6.el7 will be an update
—> Package tuned.noarch 0:2.10.0-6.el7_6.3 will be updated
—> Package tuned.noarch 0:2.11.0-8.el7 will be an update
—> Package tzdata.noarch 0:2019b-1.el7 will be updated
—> Package tzdata.noarch 0:2020a-1.el7 will be an update
—> Package tzdata-java.noarch 0:2019b-1.el7 will be updated
—> Package tzdata-java.noarch 0:2020a-1.el7 will be an update
—> Package unbound-libs.x86_64 0:1.6.6-1.el7 will be updated
—> Package unbound-libs.x86_64 0:1.6.6-5.el7_8 will be an update
—> Package unixODBC.x86_64 0:2.3.1-11.el7 will be updated
—> Package unixODBC.x86_64 0:2.3.1-14.el7 will be an update
—> Package unzip.x86_64 0:6.0-19.el7 will be updated
—> Package unzip.x86_64 0:6.0-21.el7 will be an update
—> Package urw-base35-fonts.noarch 0:20170801-10.el7 will be obsoleting
–> Processing Dependency: urw-base35-fonts-common = 20170801-10.el7 for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-z003-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-standard-symbols-ps-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-p052-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-nimbus-sans-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-nimbus-roman-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-nimbus-mono-ps-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-gothic-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-d050000l-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-c059-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
–> Processing Dependency: urw-base35-bookman-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
—> Package urw-fonts.noarch 0:2.4-16.el7 will be obsoleted
—> Package usermode.x86_64 0:1.111-5.el7 will be updated
—> Package usermode.x86_64 0:1.111-6.el7 will be an update
—> Package util-linux.x86_64 0:2.23.2-59.el7_6.1 will be updated
—> Package util-linux.x86_64 0:2.23.2-63.el7 will be an update
—> Package vim-common.x86_64 2:7.4.160-6.el7_6 will be updated
—> Package vim-common.x86_64 2:7.4.629-6.el7 will be an update
—> Package vim-enhanced.x86_64 2:7.4.160-6.el7_6 will be updated
—> Package vim-enhanced.x86_64 2:7.4.629-6.el7 will be an update
—> Package vim-filesystem.x86_64 2:7.4.160-6.el7_6 will be updated
—> Package vim-filesystem.x86_64 2:7.4.629-6.el7 will be an update
—> Package vim-minimal.x86_64 2:7.4.160-6.el7_6 will be updated
—> Package vim-minimal.x86_64 2:7.4.629-6.el7 will be an update
—> Package vsftpd.x86_64 0:3.0.2-25.el7 will be updated
—> Package vsftpd.x86_64 0:3.0.2-27.el7 will be an update
—> Package wanpipe.x86_64 0:7.0.25-2.sng7 will be updated
—> Package wanpipe.x86_64 0:7.0.25-3.sng7 will be an update
—> Package wireshark.x86_64 0:1.10.14-16.el7 will be updated
—> Package wireshark.x86_64 0:1.10.14-24.el7 will be an update
—> Package xerces-c.x86_64 0:3.1.1-9.el7 will be updated
—> Package xerces-c.x86_64 0:3.1.1-10.el7_7 will be an update
—> Package xfsprogs.x86_64 0:4.5.0-19.el7_6 will be updated
—> Package xfsprogs.x86_64 0:4.5.0-20.el7 will be an update
—> Package xinetd.x86_64 2:2.3.15-13.el7 will be updated
—> Package xinetd.x86_64 2:2.3.15-14.el7 will be an update
—> Package yaml-cpp.x86_64 1:0.5.1-1.el7.2 will be updated
—> Package yaml-cpp.x86_64 1:0.5.1-2.el7 will be an update
—> Package yum.noarch 0:3.4.3-161.10.sng7 will be updated
—> Package yum.noarch 0:3.4.3-167.el7.centos will be an update
—> Package yum-plugin-fastestmirror.noarch 0:1.1.31-50.el7 will be updated
—> Package yum-plugin-fastestmirror.noarch 0:1.1.31-54.el7_8 will be an update
—> Package yum-plugin-versionlock.noarch 0:1.1.31-50.el7 will be updated
—> Package yum-plugin-versionlock.noarch 0:1.1.31-54.el7_8 will be an update
—> Package yum-utils.noarch 0:1.1.31-50.el7 will be updated
—> Package yum-utils.noarch 0:1.1.31-54.el7_8 will be an update
–> Running transaction check
—> Package bind-export-libs.x86_64 32:9.11.4-16.P2.el7_8.6 will be installed
—> Package geoipupdate.x86_64 0:2.5.0-1.el7 will be installed
—> Package libgs.x86_64 0:9.25-2.el7_7.3 will be installed
–> Processing Dependency: adobe-mappings-pdf for package: libgs-9.25-2.el7_7.3.x86_64
–> Processing Dependency: adobe-mappings-cmap-deprecated for package: libgs-9.25-2.el7_7.3.x86_64
–> Processing Dependency: adobe-mappings-cmap for package: libgs-9.25-2.el7_7.3.x86_64
–> Processing Dependency: libpaper.so.1()(64bit) for package: libgs-9.25-2.el7_7.3.x86_64
–> Processing Dependency: libopenjp2.so.7()(64bit) for package: libgs-9.25-2.el7_7.3.x86_64
—> Package python-srpm-macros.noarch 0:3-32.el7 will be installed
—> Package urw-base35-bookman-fonts.noarch 0:20170801-10.el7 will be installed
–> Processing Dependency: xorg-x11-server-utils for package: urw-base35-bookman-fonts-20170801-10.el7.noarch
–> Processing Dependency: xorg-x11-server-utils for package: urw-base35-bookman-fonts-20170801-10.el7.noarch
—> Package urw-base35-c059-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-d050000l-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-fonts-common.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-gothic-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-nimbus-mono-ps-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-nimbus-roman-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-nimbus-sans-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-p052-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-standard-symbols-ps-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-z003-fonts.noarch 0:20170801-10.el7 will be installed
–> Running transaction check
—> Package adobe-mappings-cmap.noarch 0:20171205-3.el7 will be installed
—> Package adobe-mappings-cmap-deprecated.noarch 0:20171205-3.el7 will be installed
—> Package adobe-mappings-pdf.noarch 0:20180407-1.el7 will be installed
—> Package libpaper.x86_64 0:1.1.24-8.el7 will be installed
—> Package openjpeg2.x86_64 0:2.3.1-3.el7_7 will be installed
—> Package xorg-x11-server-utils.x86_64 0:7.7-20.el7 will be installed
–> Processing Dependency: libXxf86misc.so.1()(64bit) for package: xorg-x11-server-utils-7.7-20.el7.x86_64
–> Processing Dependency: libXmuu.so.1()(64bit) for package: xorg-x11-server-utils-7.7-20.el7.x86_64
–> Processing Dependency: libXmu.so.6()(64bit) for package: xorg-x11-server-utils-7.7-20.el7.x86_64
–> Running transaction check
—> Package libXmu.x86_64 0:1.1.2-2.el7 will be installed
—> Package libXxf86misc.x86_64 0:1.0.3-7.1.el7 will be installed
–> Finished Dependency Resolution
–> Running transaction check
—> Package kernel.x86_64 0:3.10.0-693.21.1.el7 will be erased
no --> Processing Dependency: kernel(napi_complete_done) = 0x905307be for package: kmod-via-rhine-1.5.2-1.sng7.x86_64
–> Processing Dependency: kernel(napi_complete_done) = 0x905307be for package: kmod-via-velocity-1.16-1.sng7.x86_64
–> Running transaction check
—> Package kmod-via-rhine.x86_64 0:1.5.2-1.sng7 will be erased
–> Processing Dependency: kmod-via-rhine for package: sangoma-pbx-2008-1.sng7.noarch
—> Package kmod-via-velocity.x86_64 0:1.16-1.sng7 will be erased
–> Processing Dependency: kmod-via-velocity for package: sangoma-pbx-2008-1.sng7.noarch
–> Finished Dependency Resolution
Error: Package: sangoma-pbx-2008-1.sng7.noarch (sng-pkgs)
Requires: kmod-via-rhine
Removing: kmod-via-rhine-1.5.2-1.sng7.x86_64 (@anaconda/1703)
kmod-via-rhine = 1.5.2-1.sng7
Available: kmod-via-rhine-1.5.1-4.sng7.x86_64 (sng-pkgs)
kmod-via-rhine = 1.5.1-4.sng7
Available: kmod-via-rhine-1.5.1-5.sng7.x86_64 (sng-pkgs)
kmod-via-rhine = 1.5.1-5.sng7
Available: kmod-via-rhine-1.5.1-6.sng7.x86_64 (sng-pkgs)
kmod-via-rhine = 1.5.1-6.sng7
Error: Package: sangoma-pbx-2008-1.sng7.noarch (sng-pkgs)
Requires: kmod-via-velocity
Removing: kmod-via-velocity-1.16-1.sng7.x86_64 (@anaconda/1703)
kmod-via-velocity = 1.16-1.sng7
Available: kmod-via-velocity-1.15-2.sng7.x86_64 (sng-pkgs)
kmod-via-velocity = 1.15-2.sng7
Available: kmod-via-velocity-1.15-3.sng7.x86_64 (sng-pkgs)
kmod-via-velocity = 1.15-3.sng7
Available: kmod-via-velocity-1.15-4.sng7.x86_64 (sng-pkgs)
kmod-via-velocity = 1.15-4.sng7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@uepbx1 ~]#


(Tony Guadagno) #2

bump, i could use a hand with this, thanks!


(TheWebMachine Networks (Sangoma Software Development Partner)) #3

Hi there! Those versions of rhine and velocity are partly broken, dependency-wise, and will require a forced downgrade before they can be properly upgraded (long story). You will want to run these in order and as you see them…yes, you are running each twice, but this is required. Note that each command will take a while to run, so be patient:

yum -y downgrade kmod-via-rhine

yum -y downgrade kmod-via-rhine

yum -y downgrade kmod-via-velocity

yum -y downgrade kmod-via-velocity

Then you can run yum normally again and all should proceed as expected.


(Tony Guadagno) #4

h, thanks for the tip, i will try this…but this reminds me that i think we had this problem a while ago (a year or 2 ago)?? i thought this issue was fixed?


(TheWebMachine Networks (Sangoma Software Development Partner)) #5

You mention you are on v15 and did updates recently, but still appear to be on an older kernel (3.10.0-693) from a while back. I’m not sure how you ended up here, but the same commands I posted will resolve it (again, if that’s the case). You need to ensure you getting everything updated this time around. So, run those 4 commands above, then run these to ensure we are fixing everything and getting your kernel updated…then perhaps this won’t happen again. First run will skip any broken, allowing the rest of the proper updates to install, then the second run will attempt to circle around and catch the broken, which should not be broken anymore:

yum -y upgrade --skip-broken
yum -y upgrade

Dependency loops and broken upgrade paths are a pain, but hopefully that will get you sorted out. When finished, you should definitely reboot the server. Then run this to confirm that your kernel got upgraded:

uname -r

You should see a much newer version than the 3.10.0-693 you’re on now:

# uname -r
3.10.0-1127.19.1.el7.x86_64