Yum update now failing

When I tried to do a yum update, I am getting the same results mentioned in this thread: FreePBX Distro Fails to Yum Update - Distro Discussion & Help - FreePBX Community Forums

I do not believe it is a DNS issue; as mirrorlist.sangoma.net does resolve to when I run a ping. The ping fails (but I suspect that is due to sangoma.net not allowing pings.)

I suspect this may be a firewall issue. Either with my server, or DSL router firewall.

Here is the urlgrabber results

[[email protected] ~]#
[[email protected] ~]# sudo URLGRABBER_DEBUG=1,/tmp/debug.log yum update
* Closing connection 0
* Closing connection 1
* Closing connection 2
Loaded plugins: versionlock
* Closing connection 3
* Closing connection 4
* Closing connection 5
* Closing connection 6
* Closing connection 7
* Closing connection 8
* Closing connection 9
* Closing connection 10
* About to connect() to mirrorlist.sangoma.net port 80 (#11)
*   Trying
* After 14970ms connect time, move on!
*   Trying
* After 7484ms connect time, move on!
*   Trying
* After 3742ms connect time, move on!
*   Trying 2606:4700:10::ac43:ac0...
* Failed to connect to 2606:4700:10::ac43:ac0: Network is unreachable
*   Trying 2606:4700:10::6816:2196...
* Failed to connect to 2606:4700:10::6816:2196: Network is unreachable
*   Trying 2606:4700:10::6816:2096...
* Failed to connect to 2606:4700:10::6816:2096: Network is unreachable
* Failed connect to mirrorlist.sangoma.net:80; Network is unreachable
* Closing connection 11
Could not retrieve mirrorlist http://mirrorlist.sangoma.net/?release=7-8.2003.5.el7.sangoma&arch=x86_64&repo=os&dist=$dist&staging=$staging error was
14: curl#7 - "Failed to connect to 2606:4700:10::ac43:ac0: Network is unreachable"

 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=<repoid> ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>
            subscription-manager repos --disable=<repoid>

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: sng-base/7-8.2003.5.el7.sangoma/x86_64

If you wanted to test quickly you could bring the firewall down and try the command to rule it out. Then you could move on further down the stream.

Do you mean bring down the firewall in freepbx, or the one on my router?

If FreePBX firewall, my understanding is that if I restart the server twice within 5 minutes, then the firewall stays disabled for five minutes. I did that, and ran yum update and got the same results.

If the router, that is a little more complicated. My FreePBX server is behind a DSL router (i live in the sticks). Using DDNS. And the firewall I am using is the one in the router.

Well if you have ruled out the FreePBX firewall, then it sounds like your router is next.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.