Yum update fails


(Mvogel4949) #1

I’m trying to run a yum update -y on a new system and part way through the update I keep getting errored out. I’ve attempted to run yum clean all and also the yum --enable repo command in the cli error. any ideas?

(305/326): yaml-cpp-0.5.1-2.el7.x86_64.rpm                                                       | 178 kB  00:00:00
wanpipe-7.0.25-3.sng7.x86_64.r FAILED
http://sng7.com/sng7-7.8/sng7/RPMS/wanpipe-7.0.25-3.sng7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=sng-pkgs clean metadata
Trying other mirror.
(306/326): xerces-c-3.1.1-10.el7_7.x86_64.rpm                                                    | 879 kB  00:00:01


Error downloading packages:
  asterisk13-addons-mysql-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-doc-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-addons-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-addons-ooh323-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-addons-bluetooth-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  kmod-wanpipe-7.0.25-3.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-voicemail-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  wanpipe-7.0.25-3.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-odbc-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  sangoma-pbx-2008-1.sng7.noarch: [Errno 256] No more mirrors to try.
  sangoma-release-7-8.2003.3.el7.sangoma.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-resample-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-ogg-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-curl-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  kmod-dahdi-linux-2.11.1-53.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-dahdi-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-addons-core-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-core-13.36.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
  asterisk13-g729-2002-1.sng7.x86_64: [Errno 256] No more mirrors to try.

#2

Yep same here

Error downloading packages:
kmod-dahdi-linux-2.11.1-53.sng7.x86_64: [Errno 256] No more mirrors to try.
asterisk16-voicemail-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
asterisk16-ogg-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
asterisk16-addons-ooh323-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
asterisk16-odbc-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
asterisk16-dahdi-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
asterisk16-doc-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
asterisk16-addons-bluetooth-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.


(Matt Brooks) #3

@mvogel4949 Thanks for reporting this! We should have resolved the issue. Can you please execute a ‘yum clean all’ and ‘yum update’ again and let us know if everything is working now?

Thanks!


(Justin Zimmerman) #4

I am seeing the same issue.
asterisk16-odbc-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
asterisk16-dahdi-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.
asterisk16-doc-16.13.0-1.sng7.x86_64: [Errno 256] No more mirrors to try.


(Matt Brooks) #5

@justin_trueway I believe we just resolved the issue. Please execute the following and try again:

yum clean all
yum update

(Mvogel4949) #6

Seems to be working now. Thank you!


(Justin Zimmerman) #7

works great now, Thank you for the fast response.


(Daniel) #8

This is still broken. I’ve been having trouble with updates off and on for weeks. What is going on with the servers?


(Mvogel4949) #9

It was working but I’ve run into a yum update issue again. I did run the yum clean all and still see the following:

---> Package python36u.x86_64 0:3.6.7-1.ius.centos7 will be installed
--> Processing Dependency: python36u-libs(x86-64) = 3.6.7-1.ius.centos7 for package: python36u-3.6.7-1.ius.centos7.x86_64
---> Package python36u-vega.x86_64 0:1.2.3-1.sng7 will be installed
--> Processing Dependency: python36u-libs for package: python36u-vega-1.2.3-1.sng7.x86_64
--> Finished Dependency Resolution
Error: Package: python36u-vega-1.2.3-1.sng7.x86_64 (sng-pkgs)
           Requires: python36u-libs
Error: Package: python36u-3.6.7-1.ius.centos7.x86_64 (sng-pkgs)
           Requires: python36u-libs(x86-64) = 3.6.7-1.ius.centos7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

(Matt Brooks) #10

@mvogel4949 we believe there is some addition information missing, can you post the entire log?


(Mvogel4949) #11

—> Package boost-random.x86_64 0:1.53.0-28.el7 will be installed
—> Package dejavu-sans-fonts.noarch 0:2.33-6.el7 will be installed
–> Processing Dependency: dejavu-fonts-common = 2.33-6.el7 for package: dejavu-sans-fonts-2.33-6.el7.noarch
—> Package fdk-aac.x86_64 0:0.1.4-1.sng7 will be installed
—> Package geoipupdate.x86_64 0:2.5.0-1.el7 will be installed
—> Package gtk2.x86_64 0:2.24.31-1.el7 will be installed
–> Processing Dependency: libXrandr >= 1.2.99.4-2 for package: gtk2-2.24.31-1.el7.x86_64
–> Processing Dependency: atk >= 1.29.4-2 for package: gtk2-2.24.31-1.el7.x86_64
–> Processing Dependency: hicolor-icon-theme for package: gtk2-2.24.31-1.el7.x86_64
–> Processing Dependency: gtk-update-icon-cache for package: gtk2-2.24.31-1.el7.x86_64
–> Processing Dependency: libatk-1.0.so.0()(64bit) for package: gtk2-2.24.31-1.el7.x86_64
–> Processing Dependency: libXrandr.so.2()(64bit) for package: gtk2-2.24.31-1.el7.x86_64
–> Processing Dependency: libXinerama.so.1()(64bit) for package: gtk2-2.24.31-1.el7.x86_64
–> Processing Dependency: libXcursor.so.1()(64bit) for package: gtk2-2.24.31-1.el7.x86_64
—> Package json-c.x86_64 0:0.11-4.el7_0 will be installed
—> Package libglvnd-egl.x86_64 1:1.0.1-0.8.git5baa1e5.el7 will be installed
–> Processing Dependency: libglvnd(x86-64) = 1:1.0.1-0.8.git5baa1e5.el7 for package: 1:libglvnd-egl-1.0.1-0.8.git5baa1e5.el7.x86_64
–> Processing Dependency: libGLdispatch.so.0()(64bit) for package: 1:libglvnd-egl-1.0.1-0.8.git5baa1e5.el7.x86_64
—> Package libglvnd-glx.x86_64 1:1.0.1-0.8.git5baa1e5.el7 will be installed
—> Package libgs.x86_64 0:9.25-2.el7_7.3 will be installed
–> Processing Dependency: adobe-mappings-pdf for package: libgs-9.25-2.el7_7.3.x86_64
–> Processing Dependency: adobe-mappings-cmap-deprecated for package: libgs-9.25-2.el7_7.3.x86_64
–> Processing Dependency: adobe-mappings-cmap for package: libgs-9.25-2.el7_7.3.x86_64
–> Processing Dependency: libpaper.so.1()(64bit) for package: libgs-9.25-2.el7_7.3.x86_64
–> Processing Dependency: libopenjp2.so.7()(64bit) for package: libgs-9.25-2.el7_7.3.x86_64
—> Package libsmartcols.x86_64 0:2.23.2-63.el7 will be installed
—> Package libwayland-client.x86_64 0:1.15.0-1.el7 will be installed
—> Package libwayland-server.x86_64 0:1.15.0-1.el7 will be installed
—> Package pcsc-lite-libs.x86_64 0:1.8.8-8.el7 will be installed
—> Package php56w-pecl-redis.x86_64 0:2.2.7-1.w7 will be installed
–> Processing Dependency: php-pecl-igbinary(x86-64) for package: php56w-pecl-redis-2.2.7-1.w7.x86_64
—> Package python36u-aiohttp.x86_64 0:2.2.4-1.sng7 will be installed
–> Processing Dependency: python(abi) = 3.6 for package: python36u-aiohttp-2.2.4-1.sng7.x86_64
–> Processing Dependency: libpython3.6m.so.1.0()(64bit) for package: python36u-aiohttp-2.2.4-1.sng7.x86_64
—> Package python36u-aiohttp-swagger.x86_64 0:1.0.5-1.sng7 will be installed
—> Package python36u-asyncssh.x86_64 0:1.11.0-1.sng7 will be installed
—> Package python36u-cffi.x86_64 0:1.11.2-1.sng7 will be installed
—> Package python36u-chardet.noarch 0:3.0.4-1.sng7 will be installed
—> Package python36u-click.x86_64 0:6.7-1.sng7 will be installed
—> Package python36u-cryptography.x86_64 0:2.0.2-1.sng7 will be installed
—> Package python36u-dateutil.noarch 0:2.6.1-1.sng7 will be installed
—> Package python36u-pycparser.x86_64 0:2.18-1.sng7 will be installed
—> Package python36u-vega.x86_64 0:1.2.3-1.sng7 will be installed
–> Processing Dependency: python36u-yarl for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-six for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-setuptools for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-pytz for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-pyparsing for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-multidict for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-markupsafe for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-libs for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-jinja2 for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-idna for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-async_timeout for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-asn1crypto for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-argparse for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Processing Dependency: python36u-PyYAML for package: python36u-vega-1.2.3-1.sng7.x86_64
—> Package redis.x86_64 0:3.2.12-2.el7 will be installed
–> Processing Dependency: libjemalloc.so.1()(64bit) for package: redis-3.2.12-2.el7.x86_64
—> Package urw-base35-bookman-fonts.noarch 0:20170801-10.el7 will be installed
–> Processing Dependency: xorg-x11-server-utils for package: urw-base35-bookman-fonts-20170801-10.el7.noarch
–> Processing Dependency: xorg-x11-server-utils for package: urw-base35-bookman-fonts-20170801-10.el7.noarch
—> Package urw-base35-c059-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-d050000l-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-fonts-common.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-gothic-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-nimbus-mono-ps-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-nimbus-roman-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-nimbus-sans-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-p052-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-standard-symbols-ps-fonts.noarch 0:20170801-10.el7 will be installed
—> Package urw-base35-z003-fonts.noarch 0:20170801-10.el7 will be installed
–> Running transaction check
—> Package adobe-mappings-cmap.noarch 0:20171205-3.el7 will be installed
—> Package adobe-mappings-cmap-deprecated.noarch 0:20171205-3.el7 will be installed
—> Package adobe-mappings-pdf.noarch 0:20180407-1.el7 will be installed
—> Package atk.x86_64 0:2.28.1-2.el7 will be installed
—> Package dejavu-fonts-common.noarch 0:2.33-6.el7 will be installed
—> Package gtk-update-icon-cache.x86_64 0:3.22.30-5.el7 will be installed
—> Package hicolor-icon-theme.noarch 0:0.12-7.el7 will be installed
—> Package jemalloc.x86_64 0:3.6.0-1.el7 will be installed
—> Package libXcursor.x86_64 0:1.1.15-1.el7 will be installed
—> Package libXinerama.x86_64 0:1.1.3-2.1.el7 will be installed
—> Package libXrandr.x86_64 0:1.5.1-2.el7 will be installed
—> Package libglvnd.x86_64 1:1.0.1-0.8.git5baa1e5.el7 will be installed
—> Package libpaper.x86_64 0:1.1.24-8.el7 will be installed
—> Package openjpeg2.x86_64 0:2.3.1-3.el7_7 will be installed
—> Package php56w-pecl-igbinary.x86_64 0:1.2.1-2.w7 will be installed
—> Package python3-libs.x86_64 0:3.6.8-13.el7 will be installed
—> Package python36u.x86_64 0:3.6.7-1.ius.centos7 will be installed
–> Processing Dependency: python36u-libs(x86-64) = 3.6.7-1.ius.centos7 for package: python36u-3.6.7-1.ius.centos7.x86_64
—> Package python36u-PyYAML.x86_64 0:3.12-1.sng7 will be installed
–> Processing Dependency: libyaml-0.so.2()(64bit) for package: python36u-PyYAML-3.12-1.sng7.x86_64
—> Package python36u-argparse.x86_64 0:1.4.0-1.sng7 will be installed
—> Package python36u-asn1crypto.x86_64 0:0.23.0-1.sng7 will be installed
—> Package python36u-async_timeout.noarch 0:1.2.1-1.sng7 will be installed
—> Package python36u-idna.x86_64 0:2.6-1.sng7 will be installed
—> Package python36u-jinja2.noarch 0:2.9.6-1.sng7 will be installed
—> Package python36u-markupsafe.x86_64 0:1.0-1.sng7 will be installed
—> Package python36u-multidict.x86_64 0:3.1.4a3-1.sng7 will be installed
—> Package python36u-pyparsing.noarch 0:2.2.0-1.sng7 will be installed
—> Package python36u-pytz.noarch 0:2017.2-1.sng7 will be installed
—> Package python36u-setuptools.noarch 0:39.0.1-1.ius.centos7 will be installed
—> Package python36u-six.x86_64 0:1.11.0-1.sng7 will be installed
—> Package python36u-vega.x86_64 0:1.2.3-1.sng7 will be installed
–> Processing Dependency: python36u-libs for package: python36u-vega-1.2.3-1.sng7.x86_64
—> Package python36u-yarl.x86_64 0:0.12.0-1.sng7 will be installed
—> Package xorg-x11-server-utils.x86_64 0:7.7-20.el7 will be installed
–> Processing Dependency: libXxf86misc.so.1()(64bit) for package: xorg-x11-server-utils-7.7-20.el7.x86_64
–> Processing Dependency: libXmuu.so.1()(64bit) for package: xorg-x11-server-utils-7.7-20.el7.x86_64
–> Processing Dependency: libXmu.so.6()(64bit) for package: xorg-x11-server-utils-7.7-20.el7.x86_64
–> Running transaction check
—> Package libXmu.x86_64 0:1.1.2-2.el7 will be installed
—> Package libXxf86misc.x86_64 0:1.0.3-7.1.el7 will be installed
—> Package libyaml.x86_64 0:0.1.4-11.el7_0 will be installed
—> Package python36u.x86_64 0:3.6.7-1.ius.centos7 will be installed
–> Processing Dependency: python36u-libs(x86-64) = 3.6.7-1.ius.centos7 for package: python36u-3.6.7-1.ius.centos7.x86_64
—> Package python36u-vega.x86_64 0:1.2.3-1.sng7 will be installed
–> Processing Dependency: python36u-libs for package: python36u-vega-1.2.3-1.sng7.x86_64
–> Finished Dependency Resolution
Error: Package: python36u-vega-1.2.3-1.sng7.x86_64 (sng-pkgs)
Requires: python36u-libs
Error: Package: python36u-3.6.7-1.ius.centos7.x86_64 (sng-pkgs)
Requires: python36u-libs(x86-64) = 3.6.7-1.ius.centos7


(Mvogel4949) #12

I couldn’t include the full log as it went over the character limit.


#13

Paste it at pastebin.freepbx.org and post the link here.


(Mvogel4949) #14

https://pastebin.freepbx.org/view/a3bbbdd2


(Matt Brooks) #15

@mvogel4949 it looks like the rpm package was missing for some reason, so we added it back. Try again and see if the issue is resolved.


(Roberto Fichera) #16

Hi,

I’m trying to install mock sangoma-rpm-helper sangoma-devel but doesn’t seem to work

[root@tse0021 ~]# yum clean all
Loaded plugins: fastestmirror, versionlock
Cleaning repos: sng-base sng-epel sng-extras sng-pkgs sng-updates
Cleaning up list of fastest mirrors
Other repos take up 99 M of disk space (use --verbose for details)
[root@tse0021 ~]# yum install mock sangoma-rpm-helper sangoma-devel
Loaded plugins: fastestmirror, versionlock
Determining fastest mirrors
sng-base | 3.6 kB 00:00:00
sng-epel | 2.9 kB 00:00:00
sng-extras | 2.9 kB 00:00:00
sng-pkgs | 2.9 kB 00:00:00
sng-updates | 2.9 kB 00:00:00
(1/6): sng-base/7-8.2003.3.el7.sangoma/x86_64/group_gz | 153 kB 00:00:00
(2/6): sng-extras/7-8.2003.3.el7.sangoma/x86_64/primary_db | 206 kB 00:00:00
(3/6): sng-base/7-8.2003.3.el7.sangoma/x86_64/primary_db | 6.1 MB 00:00:00
(4/6): sng-pkgs/7-8.2003.3.el7.sangoma/x86_64/primary_db | 775 kB 00:00:00
(5/6): sng-updates/7-8.2003.3.el7.sangoma/x86_64/primary_db | 4.5 MB 00:00:00
(6/6): sng-epel/7-8.2003.3.el7.sangoma/x86_64/primary_db | 7.3 MB 00:00:02
Resolving Dependencies
–> Running transaction check
—> Package mock.noarch 0:1.2.17-1.4.sng7 will be installed
–> Processing Dependency: usermode for package: mock-1.2.17-1.4.sng7.noarch
–> Processing Dependency: python-six for package: mock-1.2.17-1.4.sng7.noarch
–> Processing Dependency: python-requests for package: mock-1.2.17-1.4.sng7.noarch
–> Processing Dependency: pigz for package: mock-1.2.17-1.4.sng7.noarch
–> Processing Dependency: createrepo_c for package: mock-1.2.17-1.4.sng7.noarch
—> Package sangoma-devel.noarch 0:1.12-1.sng7 will be installed
–> Processing Dependency: mock >= 1.4.2 for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: rpmdevtools for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: rpm-build for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: redhat-rpm-config for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: php56w-pecl-xdebug for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: patch for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: libtool for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: libtonezone-devel for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: libss7-devel for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: libsrtp-devel for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: libpri-devel for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: git for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: gdb for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: flite-devel for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: flex for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: dahdi-linux-devel for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: ccache for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: bison for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: automake for package: sangoma-devel-1.12-1.sng7.noarch
–> Processing Dependency: autoconf for package: sangoma-devel-1.12-1.sng7.noarch
—> Package sangoma-rpm-helper.noarch 0:1.4-2.sng7 will be installed
–> Running transaction check
—> Package autoconf.noarch 0:2.69-11.el7 will be installed
–> Processing Dependency: m4 >= 1.4.14 for package: autoconf-2.69-11.el7.noarch
—> Package automake.noarch 0:1.13.4-3.el7 will be installed
–> Processing Dependency: perl(Thread::Queue) for package: automake-1.13.4-3.el7.noarch
–> Processing Dependency: perl(TAP::Parser) for package: automake-1.13.4-3.el7.noarch
—> Package bison.x86_64 0:3.0.4-2.el7 will be installed
—> Package ccache.x86_64 0:3.7.7-1.el7 will be installed
—> Package createrepo_c.x86_64 0:0.10.0-20.el7 will be installed
–> Processing Dependency: createrepo_c-libs = 0.10.0-20.el7 for package: createrepo_c-0.10.0-20.el7.x86_64
–> Processing Dependency: libcreaterepo_c.so.0()(64bit) for package: createrepo_c-0.10.0-20.el7.x86_64
—> Package dahdi-linux-devel.x86_64 0:2.11.1-50.sng7 will be installed
—> Package flex.x86_64 0:2.5.37-6.el7 will be installed
—> Package flite-devel.x86_64 0:1.3-22.el7 will be installed
—> Package gdb.x86_64 0:7.6.1-119.el7 will be installed
—> Package git.x86_64 0:1.8.3.1-23.el7_8 will be installed
–> Processing Dependency: perl-Git = 1.8.3.1-23.el7_8 for package: git-1.8.3.1-23.el7_8.x86_64
–> Processing Dependency: perl(Term::ReadKey) for package: git-1.8.3.1-23.el7_8.x86_64
–> Processing Dependency: perl(Git) for package: git-1.8.3.1-23.el7_8.x86_64
–> Processing Dependency: perl(Error) for package: git-1.8.3.1-23.el7_8.x86_64
—> Package libpri-devel.x86_64 0:1.6.0-1.sng will be installed
—> Package libsrtp-devel.x86_64 0:1.6.0-1.sng7 will be installed
—> Package libss7-devel.x86_64 0:2.0.0-1.2.sng will be installed
—> Package libtonezone-devel.x86_64 0:2.11.1-2.sng7 will be installed
—> Package libtool.x86_64 0:2.4.2-22.el7_3 will be installed
—> Package patch.x86_64 0:2.7.1-12.el7_7 will be installed
—> Package php56w-pecl-xdebug.x86_64 0:2.5.0-1.w7 will be installed
—> Package pigz.x86_64 0:2.3.4-1.el7 will be installed
—> Package python-requests.noarch 0:2.6.0-9.el7_8 will be installed
–> Processing Dependency: python-urllib3 >= 1.10.2-1 for package: python-requests-2.6.0-9.el7_8.noarch
—> Package python-six.noarch 0:1.9.0-2.el7 will be installed
—> Package redhat-rpm-config.noarch 0:9.1.0-88.el7.centos will be installed
–> Processing Dependency: dwz >= 0.4 for package: redhat-rpm-config-9.1.0-88.el7.centos.noarch
–> Processing Dependency: python-srpm-macros for package: redhat-rpm-config-9.1.0-88.el7.centos.noarch
–> Processing Dependency: perl-srpm-macros for package: redhat-rpm-config-9.1.0-88.el7.centos.noarch
—> Package rpm-build.x86_64 0:4.11.3-43.el7 will be installed
–> Processing Dependency: elfutils >= 0.128 for package: rpm-build-4.11.3-43.el7.x86_64
—> Package rpmdevtools.noarch 0:8.3-5.el7 will be installed
–> Processing Dependency: emacs-filesystem for package: rpmdevtools-8.3-5.el7.noarch
—> Package sangoma-devel.noarch 0:1.12-1.sng7 will be installed
–> Processing Dependency: mock >= 1.4.2 for package: sangoma-devel-1.12-1.sng7.noarch
—> Package usermode.x86_64 0:1.111-6.el7 will be installed
–> Running transaction check
—> Package createrepo_c-libs.x86_64 0:0.10.0-20.el7 will be installed
—> Package dwz.x86_64 0:0.11-3.el7 will be installed
—> Package elfutils.x86_64 0:0.176-4.el7 will be installed
—> Package emacs-filesystem.noarch 1:24.3-23.el7 will be installed
—> Package m4.x86_64 0:1.4.16-10.el7 will be installed
—> Package perl-Error.noarch 1:0.17020-2.el7 will be installed
—> Package perl-Git.noarch 0:1.8.3.1-23.el7_8 will be installed
—> Package perl-TermReadKey.x86_64 0:2.30-20.el7 will be installed
—> Package perl-Test-Harness.noarch 0:3.28-3.el7 will be installed
—> Package perl-Thread-Queue.noarch 0:3.02-2.el7 will be installed
—> Package perl-srpm-macros.noarch 0:1-8.el7 will be installed
—> Package python-srpm-macros.noarch 0:3-32.el7 will be installed
—> Package python-urllib3.noarch 0:1.10.2-7.el7 will be installed
–> Processing Dependency: python-ipaddress for package: python-urllib3-1.10.2-7.el7.noarch
–> Processing Dependency: python-backports-ssl_match_hostname for package: python-urllib3-1.10.2-7.el7.noarch
—> Package sangoma-devel.noarch 0:1.12-1.sng7 will be installed
–> Processing Dependency: mock >= 1.4.2 for package: sangoma-devel-1.12-1.sng7.noarch
–> Running transaction check
—> Package python-backports-ssl_match_hostname.noarch 0:3.5.0.1-1.el7 will be installed
–> Processing Dependency: python-backports for package: python-backports-ssl_match_hostname-3.5.0.1-1.el7.noarch
—> Package python-ipaddress.noarch 0:1.0.16-2.el7 will be installed
—> Package sangoma-devel.noarch 0:1.12-1.sng7 will be installed
–> Processing Dependency: mock >= 1.4.2 for package: sangoma-devel-1.12-1.sng7.noarch
–> Running transaction check
—> Package python-backports.x86_64 0:1.0-8.el7 will be installed
—> Package sangoma-devel.noarch 0:1.12-1.sng7 will be installed
–> Processing Dependency: mock >= 1.4.2 for package: sangoma-devel-1.12-1.sng7.noarch
–> Finished Dependency Resolution
Error: Package: sangoma-devel-1.12-1.sng7.noarch (sng-pkgs)
Requires: mock >= 1.4.2
Available: mock-1.2.14-6.el7.sng.noarch (sng-pkgs)
mock = 1.2.14-6.el7.sng
Available: mock-1.2.14-6.2.sng7.noarch (sng-pkgs)
mock = 1.2.14-6.2.sng7
Available: mock-1.2.17-1.el7.centos.noarch (sng-extras)
mock = 1.2.17-1.el7.centos
Installing: mock-1.2.17-1.4.sng7.noarch (sng-pkgs)
mock = 1.2.17-1.4.sng7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


(Leonardo) #17

Hi, Roberto.

Seems like we had some additional packages to restore, including mock. Can you try it again?

Let us know if the issue is resolved.


(Roberto Fichera) #18

Hi Leonardo,

not yet! It still some missing see below

—> Package python-backports.x86_64 0:1.0-8.el7 will be installed
–> Finished Dependency Resolution
Error: Package: mock-1.4.14-2.el7.noarch (sng-pkgs)
Requires: mock-core-configs >= 27.4
You could try using --skip-broken to work around the problem


(Leonardo) #19

Ok, it should be there now. I checked the dependencies of this package and seems like there’s nothing else required. You’ll likely have to do a yum clean all again, by the way.


(Roberto Fichera) #20

Yep! Now works!

But let’s see if the asterisk rebuild works as well.

Thanks for now!