Yealink Version 82 Firmware in Commercial Endpoint Manager

When will the Yealink version 82 firmware be available in Commercial Endpoint Manager?

If you don’t want to wait, you can always use the custom firmware option in endpoint manager, get the firmware from yealink and put it into one of your firmware slots manually.

1 Like

Also feature requests go to


For some reason I’m unable to utilize the custom firmware feature in EPM.

I’m working with Yealink T29G and this has been an issue for me since the initial install of EPM in freePBX.

I’ve followed the wiki and placed either 0.00 or 0.01 in a slot, waited for the slot and version file to be created, and then uploaded T29- via WinSCP into the appropriate slot. Upon save/rebuild/update the phones do reboot but the firmware does not update.

I did open a support ticket (#773050) but was initially advised that uploading custom firmware was not recommended. Ticket was closed when I updated with my workaround explained below.

I did manage to come up with a workaround during my initial deployment in Dec. Using a copy of the ‘version’ file 1.17 installed in the second slot, I edited the T29 line to reflect the correct version rom I was uploading. Which at that time was SIP-T29G I then renamed the yealink firmware to t29.rom and uploaded. I copied permissions and owner/group to asterisk and the phones all updated correctly.

But fast forward to today with T29- and I can not even duplicate my workaround as above.

Any advice or suggestions would be greatly appreciated.

PBX Firmware:12.7.4-1804-1.sng7
PBX Service Pack:
Asterisk Version: 13.19.1
EndPoint Manager: Stable

Did you set the template to use the firmware slot of the custom firmware?

I’ve done it before and it worked fine, not recently. I just uploaded it to slot tftpboot/grandstream/2/*

I did, and also tried different templates in case it was template related somehow. Thanks for suggestion.

Apparently I have a larger/provisioning problem. I noticed there was no output in /logs/messages from the tftp service. Checked status and tftp was inactive although property enabled in sys admin within freepbx. Started tftp manually and tried to update phones again. Still no output to /logs/messages. I then made a small change to a template (removed a button) and tried updating. Phone did not take the change. I’ve had this system installed for about 4 months and its pretty basic with a few commercial modules only. Provisioning and updating had been working fine so not sure what has changed except possibly and update somewhere? I’ve both tftp and http enabled under provisioning in sys admin.

Thanks Lorne, I did find that in the wiki which is how I discovered tftp was not producing any output and consequently not an active service. However, I’m guessing that xinetd calls for tftp when necessary? When I changed a template from http to tftp provisioning I started seeing output and did verify that tftp service was now active.

I did solve template/provision updating. Server ip was incorrect in both EPM global settings and individual phones as the server had been given a new static ip during a restructure. Corrected and now phones are recognizing template changes when updated.

However, I’m back to square one in which custom firmware is not updated. I did try my workaround as listed in my previous post with no luck. We are provisioning via http, is there a log that I can examine to see what this issue is with custom firmware? Since template changes are recognized and updated it would seem like provisioning is working but this is something specific with custom firmware. Not sure which log to start with to narrow things down.


I routinely use custom firmware in EPM so I am pretty sure it works. Add the custom slot, upload the firmware, change ownership to asterisk:asterisk, update the template to use the the correct firmware slot, tail the log when the phone provisions.

Do you also have to rename the firmware file to something specific?
Such as t29g.rom instead of e.g. T29- (it would appear as t29g in a slot where you aren’t using custom firmware but firmware pulled from Sangoma via EPM).

1 Like

The file name must match whatever the phone requests, which you can see from /var/log/messages when the phone provisions via tftp** or /var/log/httpd/access_log if provisioning with http.

** if tftp verbose logging is enabled per wiki link above

1 Like

ah! /var/log/httpd/access_log is what I needed. Proper file name for our phones is t29.rom not T29.rom :man_facepalming:

Thanks @avayax and @lgaetz for the help.

Is there somewhere we can submit for wiki/manual suggestions?


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.