Yealink transfer call shows extension instead of external number


I am switching from Polycom phone to Yealink.

  1. With Polycom when somebody call my extension from outside and I transfered that call to another extension, after transfer was completed (I hang up the headset) the external number showed up on other extension.

  2. With Yealink phone instead external number I see just the other extension. This is problematic since they cannot just redial last called number.

Any thoughts?

So you are saying a on warm transfer, the CID that the person sees on their phone changes after that transfer completes?

Because with blind transfers this normally already shows the original CID.

Does Yealink support connected line update using either Remote-Party-ID or P-Asserted-Identity headers. If it does, make sure you have the right one selected. If not, you will be out of luck.

It looks like this has to be enabled on the phone, see page 3 of Calling and Connected Line Identification Presentation on Yealink IP Phones.pdf

It works with my ancient T26Ps, provided that Send RPID for the extension is set to Send P-Asserted-Identity header, and Caller ID Source for the phone is set to PAI-FROM.

Works perfectly on current Yealink models also.

If you use auto provisioning, this is the setting.

account.1.cid_source = 2

This seems to be set by default.
I just clicked quick create extension and it was already set.

Maybe this setting in Advanced settings controls that default?

I have used newest T41P firmware and I see now:

B Trans (blind) - and indeed my external numbers shows - this is great.
Send > PICK THE CALL> Transfer only shows extension number not external number


  • What’s the distro version
  • What’s the Asterisk version.
  • What’s the driver for your devices: chan_sip / pjsip_sip?

You might want to try this setting:

account.1.refresh_remote_id.enable = 1

I have FreePBX 14.0.11 Asterisk: Asterisk 15.5.0 with driver for chan_sip

Is there any way to do that from GUI if the phone?


You could export the settings from the config section, add that line, and then import the settings again.


Think to make your system up to date (O.S and Freepbx modules).
If you use EPM, think to select and set the latest firmware in the good slot, for your devices.

If you used pjsip driver, it might have some trouble with rpid/pai under some asterisk versions, but it’s ok with chan_sip.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.