Yealink T58W Freezing

I have an environment with the following:

20 Yealink T54W
5 Yealink T58W
FreePBX 16.0.15 on the same subnet
Commercial Endpoint Manager

The T54W’s all work great.

The T58W’s freeze occassionally. I can’t find anything specific that will make them freeze. Sometimes they keep ringing until the phone is rebooted. Sometimes they freeze on the dial screen after a user hangs up a call. None of the T54W’s do this. All of them are on the same network switch.

Unfortunately, there is no T58W template on endpoint manager. I tried a T57W, and a T58V with the same result. Then, I just moved it to the same template as the T54W’s. Same thing.

I tried taking the phones off POE and connecting them to a new network switch. Same result.

Firmware version
Hardware Version

I’m going nuts, what else should I look at?

I don’t know much about EPM, but you should upgrade the firmware to

I updated this firmware as suggested. If it’s a firmware issue it would resolve. Would still like to see if anyone has any template experience with the T58W, or if there’s any other troubleshooting steps I can take.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.