Yealink T46S and Endpoint manager BLFs

I have had the same issue on 2 new FreePBX installs with Commercial Endpoint Manager installed.
Phones provision happily EXCEPT the BLF side of things.
I create BLFs to monitor extensions and do call parking and set all to account 1
What happens though is the account numbers on the phone handset increment.
On DSS key page of yealink, Line one get account N/A, Line 2 gets account 1, Line 3 get account 3 and so on.

Anyone else come across this?
Both are new installs of FreePBX within the last month.
Using latest firmware on phones provided by EPM and latest distro.
All system and module updates are done.

Can you post screenshots of your config?

I’ve had issues with the phones coming with newer firmware and it essentially downgrading when grabbing the config from Endpoint Manager. This caused some of the Yealinks (T41S and T46S) to have a similar issue. The fix was to factory reset the phone and when it pulled the config, it was fine.

In my instance, they came with v82 and downgraded to v81. And FYI, anything higher than 81 has some BLF issues, due to a forced standard adherence

The work around is to reboot the phones when asterisk restarts. I have not noticed this to be a problem with only normal reloads.

Phone firmware is which it gets from Endpoint Manager.
This is what phone inteface looks like after provisioning in the DSS Keys Page


This is what my BLF page in Endpoint manager looks like.

I guess if there is a buggy firmware version then i would have thought that EPM would not allow you to upgrade to it or would give you the lower version that works as most recent …

Does the config file for that phone in /tftpboot have the correct config?

yes it does … It seems to be the firmware issue … I have manually set buttons and turned off provisioning in both the phone and the basefile edit.

This was previous stated but you did not say if you did so.

Once downgraded to the firmware pushed out by EPM, did you factory reset the phone?

Sorry i misread your comment earlier, I’ll try that today and let you know :slight_smile:

That looks to have done the trick … thanks for that … I’ve marked it as solved … :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.