Yealink t46g with intermittent "unreachable" messages

Hello experts and gurus,
I’ve got a user who works from home and has a Yealink T46G phone that connects to our phone server via cable internet (Time Warner Cable). Last week, he was having trouble with this circuit and so the ISP replaced his modem. Internet connectivity appears solid but now, his phone intermittently disconnects (I think that’s the right word) from FreePBX for about 16 or 17 minutes throughout the day. It would show something like this in the log:

[2018-09-26 10:20:58] NOTICE[1851] chan_sip.c: Peer ‘340’ is now UNREACHABLE! Last qualify: 70

[2018-09-26 10:36:51] NOTICE[16303] chan_sip.c: Peer ‘340’ is now Reachable. (68ms / 2000ms)

[2018-09-26 12:40:56] NOTICE[1851] chan_sip.c: Peer ‘340’ is now UNREACHABLE! Last qualify: 70

[2018-09-26 12:56:51] NOTICE[25031] chan_sip.c: Peer ‘340’ is now Reachable. (75ms / 2000ms)

Doing ping tests to his gateway from my office showed times pretty consistent around 80 – 83 ms… but then showed intermittent packet drops. He called his ISP and told them what was happening and they blamed the phone. They did their own ping test and said everything looked fine.

So, over the past few days, I’ve tried changing some setting in the phone server and on his phone to, perhaps, tolerate some packet loss.

On the user’s phone, we tried changing the Server Expires time from the default of 3600 seconds down to 300 seconds.

After this, the user still had the unreachable outages but they only lasted from 1 to 4 minutes as opposed to upwards of 16 minutes. BUT… he started getting phantom “calls” on his phone that did not show up in the FreePBX CDR report at all. The phone would ring and show a “c” on the screen. When he answered a call, it would be nothing and nobody there. This was happening a lot.

So yesterday afternoon, I got he and I on the phone with his ISP. I explained what was happening and they did a packet test and found up to 10% packet loss, by their test. They agreed to send out another tech to test and replace the modem.

A new tech came out to his house this AM and could find nothing wrong with his circuit. I believe they are coming back later to replace the modem anyway.

Does this sound like an ISP issue? Or am I missing something in the phone server setup?

Currently running FreePBX

Thanks for hearing me out.
RK Faulhaber

This is 100% a NAT/Firewall issue with the router that, I’m going to take a wild stab it saying, the Time Warner gave the user.

  1. The phone is registering to your PBX and making a “NAT hole” in the routers firewall/NAT rules. It becomes the router’s job to keep that hole open.

  2. When the peer is showing UNREACHABLE in the PBX that means the Qualify attempts are not getting replies and then suddenly they are when it goes REACHABLE. So this would mean the router is not doing a very good job with the NAT hole and it gets closed. My guess is when it goes REACHABLE again it is because the phone itself re-registered and caused a new outbound request through the firewall.

  3. Those ghost calls are due to the fact that when the NAT hole is open it’s open completely on 5060 UDP and letting ALL incoming requests on 5060 UDP into the network. So your user is being SIP scanned and since it’s an INVITE being sent and the router is sending it to the phone, the phone is going to respond normally to the INVITE and ring.

All of this is due to their POS modem/routers. I would suggest getting your own router like a Mikrotik hEX or hAP AC (if you want wireless as well) for the user.

Either route you go with the router since this is Resi level service (I’m guessing) that TW isn’t going to offer up a Bridge mode option for their modem. If that is the case, you would need to use their router’s DMZ setting to point to the static IP of the new router or its MAC. That will bypass all their firewall’s rules/NAT filters and let your router deal with it.

Basically, either the main office or your remote user does not have a stable internet connection.

Once you have that resolved, then you can start messing with the settings.

Of course, the main office should not have 5060 open publicly, restrict it to trusted IP addresses and/or FQDN’s (you can also do that using the FreePBX firewall)

These phones (Yealink and Sangoma) should typically work well behind any router, you might need to disable SIP ALG tho.

To summarize: I’d wait until the network connectivity issues are 100% resolved, and first then start messing with the settings or purchasing another router.

If possible, avoid the use of a Spectrum (TWC) supplied ‘gateway’. You want a dumb modem (one with a single Ethernet jack and no Wi-Fi), which is used with a router provided by the customer. If Spectrum is leasing the modem (separate line item on the monthly bill), it will be less expensive to purchase your own and return theirs. If the modem is included in the plan price and it’s a gateway (four Ethernet jacks), see if they can replace it with a straight modem or can put the gateway in ‘bridge’ mode. I agree with @BlazeStudios that Mikrotik is a good router choice. If you are stuck with the Spectrum router, disable SIP ALG if possible.

In the phone, under Account -> Account 1 -> Advanced, change Local SIP Port from 5060 to some other value, e.g. 5072. This should stop your ghost calls.

Also, I’d set Server Expires down to 120. This is not a significant server load (if done for only a few phones), might fix the unreachable problem by keeping the NAT association open, and will in any case reduce the time that it stays unreachable.

Hello and thank you to all those who replied.
TWC replaced the modem/router with two separate units this time. As soon as it was hooked up, it connected and it looks like everything is fine. I’ll find out tomorrow the makes/models of the devices.

Haven’t had the regular drops, nor the mystery “c” calls since.

I will forward on all suggestions to my colleague who knows more about these things than I do.

Again, thank you to Stewart1, PitzKey, and BlazeStudios for your replies and suggestions.

RK Faulhaber

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.