Yealink T46G to T54W upgrade oddness

Update from before I even hit “Create Topic” - I’ve figured this out. It’s Yealink’s “Smart Noise Filtering”. Here’s the basefile edit to disable it: features.noise_filtering_rev.enable = 0 . If it’s OK I’d like to leave this here for future generations. This feature didn’t exist on my old T46G’s so I overlooked it in my initial troubleshooting. I might turn off all of the audio “improvement” buttons and add them back one at a time to see what I get as far as audio quality.

Original post:

I’m not sure this is a FreePBX issue or a Yealink issue, but here goes!

Upgraded our office phones from Yealink T46G’s that were starting to fail in a very unusual way (after several years service). New phones are Yealink T54W. I’m using Endpoint manager.

My only major issue (besides reduced audio quality but I think that’s a setting somewhere) is the ringback fades away and if the ringing goes on long enough (4 rings usually) it is totally gone. I’ve also lost the “bleep” that happens when you pick a parked call back up. I’m guessing these are related somehow.

The T46G that I still have in service is fine.

Troubleshooting I’ve gone through so far:

  1. I’ve tried different trunks with other providers to make sure it’s not a problem. BulkVS shows the same issue.
  2. I’ve gone through my old T46G web UI line by line to make sure it’s the same a the new T54W and all settings are the same from what I can see.
  3. I’ve tried all of the options in Trunk → pjsip Settings → DTMF Mode - no change.
  4. Updated the T54W to the latest firmware from Yealink’s website.
  5. I toggled “Inband Progress” but no change.
1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.