Yealink T46G Phone provisioning fails in EPM

Working in a new FreePBX 14 / Asterisk 13 installed from the July distro. I believe I’ve followed all the steps / instructions properly but I cannot get any of the phones (all Yealink T46G) to provision. I’ve created extensions, assigned the extensions to the phones (they all appeared in the ‘scan network’ EPM UI), and they all subsequently appear in the Exention mapping EPM UI. I used a web browser to connect to the Yealink phone(s), entered the IP of the FreePBX as the Auto Provision Server URL and “Confirmed” i.e. saved the setting. When I then click ‘Auto provision now’ the Yealink Web UI shows the Configuration updating…” message for around 30-45 seconds, then returns to the auto-provision page. The phone itself shows no indication that anything is happening during (or after) this process. The Yealink web UI shows no changes to settings, e.g. Dsskeys etc.

Some troubleshooting I’ve done. all resulting in the same (non) result.:
Tried both TFTP and HTTP as the provision server protocol (and rebuilt the config files after making these changes)
Tried specifying the port with the IP in the Yealink GUI (e.g. 192.168.x.120:83 for HTTP)
My original extension were configured as PJSIP, so I deleted one mapping and tried mapping to a new Chan_SIP extension.

It seems that (likely many)other people have been able to provision T48G’s via EPM, so not sure what the problem is or how to further troubleshoot. I’ve checked and re-checked my settings many times over against the wiki etc.

These phones are running the latest firmware ( and I noticed that EPMs latest available firmware is version (as such, I’ve left the template’s “Firmware Version” set to the default (i.e. None). Maybe I need to downgrade the firmware?

Very frustrating experience because we puchased the EPM as it was supposed to be a huge time saver. Instead I’ve spent hours working on this with no results and I could have manually provisioned these 11 phones and been up and running already. But would like to get this working anyway as I anticipate it will make configuration changes and so forth easier / better in the long run.

Any suggestions, ideas appreciated.

Solved, really simple error - needed to add “http://” to the IP address:port in the Yealink GUI. Issue resolved.

Nice - just an FYI in case anyone comes across this thread later, another cause for provisioning to fail is if the firmware is WAY out of date - happens a lot when I get phones from EBay - if everything is “Right” and the phone still won’t take provisioning, flash it to current and try again!


First off, Super newbie to this.

I was running PBX13 for the past year and was able to run just fine. I bought a new server and upgraded to PBX14 and everything was going smoothly until I try and sync T48G phone to new server? I can’t get my phone pointed to the PBX. It says it’s “autoprovisoing” then it just spins out and goes right back to nothing. I have installed latest firmware upgrade. I have been able to establish that my inbound and outbound routes are working as calls are making it thru my IVR.

Not sure what to do?

FYI my whole problem and reason for switching was I was experiencing heavy chatter and static when calls were coming through my server.

Anybody know anything?

Provisioning has nothing to do with your IVR, Inbound or outbound Routes…

Couple of things to check:

  1. Make sure you have the right MAC in EPM.
  2. Template is properly set.
  3. Your subnet is white listed, so you are hopefully not banned already.
  4. If you are at a remote location, you gotta have NAT enabled.

Lastly, make sure you look at the wiki guides everything is pretty clear there.

BTW just wanted to say thanks for helping.

Okay, I was never able to get the new server holding PBX 14 and my T-48G pointed at one another. I tried everything.I double checked your steps 1-4 and yes I’m super familiar with the Wiki. It’s my GO-2. Still no luck :frowning:

Nevertheless, I re-installed my deployment back on the old PBX 13 server tried to somewhat mirror the settings of the newly installed PBX 14 and was successful. I immediately pointed the phone at the old PBX 13 and it started configuring just like it always had. I’m left completely clueless as to why I can’t get the phone to auto-provision on the New server?

Sorry forgot, I also wanted to mention that after connecting back to the old server my call quality now seems to be better. I have Zero idea what changed? Lol, I did some research regarding poor quality in VOIP phones and found that there are a few things, but one being “Jitter Buffer”? Are you familiar with this? Nevertheless, I switched that on and things seem to be working better.