Yealink t46g Not Taking Provisioning from EPM Paid license

Hello guys, i need some help provisioning T46G Yealink phones, i got a lot of them to work with, i setup the template to use http provision, set my options and i see all the files are correctly built from /tftpboot folder.

i do provision from the scanner, phone reboot but nothing get in, i also set provision url form phone gui, phone start process and said configuration updated but nothing happens.

if anyone got some light on this please help.

I think you may have discovered your problem already.

problem ?

did you read it all ?

You are telling the phone to get its config files from the webserver, but the files are in the TFTP server.

Are you even paying attention to what you write, or do you just want someone to think for you?

ahh sorry, i forgot to mention i also tried tftp method and nothing happens, but see the files built

You need to make sure the files are available from the webserver and through the correct port in the server. This topic has been covered several times in the past couple of weeks. Look back through the forum posts for “T46G provisioning” and you should find one of those discussions pretty quickly.

Note that there are several places where this can fail, including at the firewall and the webserver. You need to make sure the files you want to download are available at the URL the phone is trying to use.

http provisioning reads the files from /tftpboot

Listen 83
<VirtualHost *:83>
  Alias /.well-known /var/www/html/.well-known
  Alias /.freepbx-known /var/www/html/.freepbx-known
  RewriteEngine on
  RewriteRule ^/\.(well-known|freepbx-known)/ - [H=text/plain,L]
  RewriteRule (^\.|/\.) - [F]
  DocumentRoot /tftpboot/
</VirtualHost>

You can provision with http, and the provisioning URL will take the form:

http://username:[email protected]_domain:port

The username and password are as specified in System Admin, Provisioning Protocols. The port is as specified in System Admin, Port Management for provisioning. It’s really easy to forget the port, and it’s critical. You can dump that URL in a web page and get a test page to ensure you got it right. You need to ensure the phone has access to the PBX obviously, which involves your Router if coming from the Net, and your FreePBX firewall.

i can certify this too

here mine

Listen 84
<VirtualHost *:84>
Alias /.well-known /var/www/html/.well-known
Alias /.freepbx-known /var/www/html/.freepbx-known
RewriteEngine on
RewriteRule ^/.(well-known|freepbx-known)/ - [H=text/plain,L]
RewriteRule (^.|/.) - [F]
DocumentRoot /tftpboot/

@lgaetz i set the url and port, i tried to find sysadmin pw, but i haven’t set no pw there, and on first place i get only one phone to work with the url provisioning like this http://ip-addrr:84 but now trying 2 more and dint work, all phones are local network.

i think also about firmware but older or even last one dint work for me

hello, i have do it that way and still not getting the phones provisioned, going to start looking for logs to see if any error comes up

Are you paying attention to what you write? The /tftpboot folder is where both versions of the EPM write out the actual config files for the devices. It is a directory structure on the server. It is not the TFTP Server. Apache is configured to take :84 requests and use /tftpboot as the default web root folder. The TFTP server points to /tftpboot as its root directory for connections.

Please do not bash people for something like this while you do not understand how things really work and are providing wrong information as well.

1 Like

find the problem working to solve the fail2ban issue over centos 7, iptables rules dont have the correct ports set by default

@cynjut That is totally not how it has ever worked.

The Apache confit has always pointed this to the tftpboot folder.

@garias are you sure you are using HTTP and not HTTPS? The G model Yealink’s will not talk to FreePBX 14 with a LetsEncrypt cert.

it was HTTP, the problem was that the iptables config dont have the default ports set on the apache only 80, and not 84, i flushed iptables and it works so i put my configs to allow port 84