FreePBX | Register | Issues | Wiki | Portal | Support

Yealink Syncs time with freepbx


(Dejv) #1

I have freepbx installed with yealink phones and wish to be able to sync date/time with the freepbx server on all my phones (around 40,T22P, T20P, T28P, W52H)

Installed Packages
freepbx.noarch 14.1-1.sng7 @anaconda/1707

Can anyone let me know what settings I need to configure on the yealink phone in order for it to sync date/time? as for some reason neither date nor time is syncing and I have been trying to changes settings

dhcp time : enabled
time zone +1
ntp by dhcp priority: high
primary server : 192.168.40.200 (ip of freepbx)
secondary server: pbx.***.com
synchronism 300
daylight saving time : disable
manual time: disable
time format: hour 12
date format DD-MMM-YY


(Greg) #2

If the NTP service isn’t running on your box, it won’t sync the time and date.

The NTP Daemon needs to be running, and UDP Port 123 has to be enabled through the firewall.

Hope this helps.


(Lorne Gaetz) #3

In SNG7 ntp is handled by chrony. You can confirm the service is active and running with:

systemctl status chronyd.service

Local time on the PBX can be confirmed with:

date

If the time is off, you can check to see if the PBX can reach the preconfigued time servers to sync with

chronyc sources -v

In rare circumstances, you may need to tweak the chrony config, which you will find in:

/etc/sangoma_chrony.conf

When all that is in place you only need to point the ntp server for your devices to the PBX IP and time will sync.


(Dejv) #4

ntp was not running :stuck_out_tongue: configured it to run on start up now and it seems to be syncing the time.

with regards to daylight saving time, should I keep it disabled or set on automatic?


#5

That should have been the fallback when your NTP wasn’t running, but it also didn’t work. Unless you have a good reason for the choice,
pool.ntp.org
should be much more reliable.