Yealink showing calling number instead of called number in History when Send RPID

Looking at the call history of my Yealink phones I see the number of the calling party (CID:4000 e.g.) instead of the called party when using Send RPID or Send P-Asserted-Itentity-Header in extension settings.
I see this for calls sent out on intra-company trunk.

Send RPID has to be set to no for the called number ID to show up in call history.

What exactly breaks or doesn’t work when Send RPID is set to no?

When you make a call, do you see the calling party id on the screen of the yealink?


Go to the advances settings module and change the Display CallerID on Calling Phone to false.

Thank you,

Daniel Friedman
Trixton LTD.

Briefly yes.
I have the exact same issue as described in this thread:

Looks like this setting has moved to another location on newer V80 and V81 firmware.
I have to look for it.

Advanced settings of FreePBX

Ah, got it.
Was looking for that in the phones themselves.