Yealink S Series Phones in EPM

Are there plans to add the Yealink S model (T46S, T41S, etc) phones to the commercial endpoint manager?

I have the exact same question. Can anyone that supports EPM comment? Thanks

That is something Yealink has to initiate with us as a Certified Partner and at this point they have not.

I have been apart of the Yealink testing of the T4xS series phones and providing them feedback. We are also a large FreePBX dealer and have used the Yealink/FreePBX combo for a few years. I have spoken to Yealink and they inform me that you have not responded to there requests to get this done. What is the ETA to get this completed

That is a complete load of crap. We have had communications with them even as late as this week with them and waiting on them to initiate the requirements to add additional phones as per their contract with us.

I will reach out to Yealink and see what the deal is.

This really upsets me as the same thing happened 2 years ago when they refused to get certified and tried to blame it on us. No other manufacture we work with acts this way.


Its sad honestly. I really wish they had US based support yealink. We too use them and love them but we tend to have issues getting support through them or talking to them at all.

What are the real differences in the phones? Couldn’t you just use the T46G templates for the T46S? I substituted the W52 template for the W56 phone for quite some time. Same with Algo equipment.

The only difference i saw is the new Opus protocol which SIP trunking most likely wont support for years.

That’s what I am doing in the meantime. The config files are hardly different, so it works.

If ever on SIP trunks.

But on FreePBX/Asterisk Opus will be supported in the new FPBX Distro, which will come out soon, so you can at least use Opus on Yealink phones on internal calls, or to remote phones if you have them. Yealink phones support Opus 8kHz narrowband and 16 kHz wideband, so you will get G722 audio quality at lower bandwidth.

You can just add Opus in basefile edit.

The best sounding codec in my opinion though is Siren 14 (or G.722-1c), which is ultra-wideband and sounds noticeably better than G.722. Unfortunately Yealink phones do not support it, only Polycom phones and higher end Digium phones do.

Yes, The T46G templete in EPM works on the T46S the rest apps work as well the only issue we have had is firmware we have had to made our on repository and add the new firmware for the T46S phones to work the firmware that comes on them has alot of bugs, But if there are issues say with restapps on the phone then there is zero support from any one.

Provisioning a 46S as a 46G will work. I use firmware slot 2, and upload the T46S firmware into that folder over the t46.rom file. So, for T46G’s I use firmware slot 1, and for T46S’s I use firmware slot 2. The firmware features/bugs in the 46S should be on par with the T46G’s. The biggest difference is the support for the new CPU in the 46S which makes it a little faster and the OPUS codec. Other than that (extensive testing and standard disclaimers not withstanding) they should be almost identical from a rest apps standpoint, and so far they seem to work just fine, barring the few minor workarounds described in this thread.

I have some T46S’s and thought that I tried to auto-provision one using the T46G template and that it didn’t work, at least not for me. Did I do something wrong? Or is there a trick to making this work?

I could have swore that one of the the T46G’s firmware supported opus in the past. Maybe they removed it bc the processor couldn’t handle it?

No trick, it just works, at least for me.

Yeah… I went back and tried again and it magically worked. Which means I must have had a typo in the MAC address the first time and instead of digging blamed it on the new version of the phone. Thanks all for letting me know it does work.

Is there a ETA on this?

Rest Apps -

Contacts does not work

Queue Agent does not work

Park - Works

Work on EPM is underway.

The T4xS models were added in Endpoint Manager 13.0.105. You’ll also need Phone Apps 13.0.87.

They are currently only available in EDGE (

Testing this but rest apps says it needs the PM2 mod???

The pm2 module is a new module we wrote to handle managing various services (such as restapps, zulu, etc). This should be available in EDGE.