FreePBX | Register | Issues | Wiki | Portal | Support

Yealink Phones are driving me crazy!


(Greg Snover) #1

I am starting to see this with specific extensions at specific installs - Yealink phones (so far just T42G and T48G) are coming un-registered from Asterisk even though the phone thinks it’s still connected - under it’s status it shows registered, but Asterisk says no:

Phone:

Register Status - Registered

Asterisk:

6065/6065 (Unspecified) D Yes Yes A 0 UNKNOWN

I have tried the latest firmware and even some earlier firmwares on the phones, and it doesn’t seem to make any difference.

And here is the thing - with the same cable hooked to a Aastra phone, using the same extension, I don’t have the problem.

Further, each site I am having the problem with is having it on two phones, and not having it on the other 42 phones at one location and 37 phones at the other - this is driving me crazy - is anyone else seeing this?

Again, everything else being equal, Aastra phone on the same Wire/Extension/everything works fine, but no matter what Yealink I put there, it has the problem - but the rest of the Yealinks at each site are NOT having the problem.

Fully up to date FreePBX Distro 6.12.65-31 with Endpoint Manager and the latest Yealink firmware (and many earlier ones too)

Surely I can’t be the only one having this problem.

Greg


Some extentions are unable to receive calls from other extensions
Extensions unregistering and registering
Upgrade to asterisk 13.6
Weirdest problem ever (Aastra 6867i)
(Tony Lewis) #2

Asterisk 11.20? If so downgrade they have a bug and waiting for .21 to be released soon to fix it


(Greg Snover) #3

An Asterisk bug specific to Yealink Phones?

As far as downgrading, What is the most “Approved” method of doing that with a FreePBX Distro? In the past when I had to do this, I just compiled from source, but that is always looked upon with great disdain around these parts.

Any suggestions appreciated.


(Lorne Gaetz) #4

I have done this exactly zero times but…

yum downgrade asterisk*

should take you from 11.20 to 11.19


(Greg Snover) #5

Sounds good - but is this a good excuse to upgrade to 13? I have been wanting to try, and this is as good a reason as any.


(Lorne Gaetz) #6

Yes. For now I would use chan_sip for trunks and PJSIP for extensions, or if you want to ease into the experience you could use chan_sip for everything.

asterisk-version-switch

(Greg Snover) #7

Yes, I have already had “Adventures” with chan-pjsip - nothing too terrible, but still.

Tony, or anyone else, do you have a Digium Issue that describes what I am seeing?

I am searching now and not finding.


(Lorne Gaetz) #8

https://issues.asterisk.org/jira/browse/ASTERISK-25476


Grandstream phone de-registers every 10 minutes
(Greg Snover) #9

Booger - Thanks for the link - That is a VERY specific bug - and only with Yealinks - I will downgrade the two sites tomorrow.

This community is awesome!


#10

Hi,

Just in case you still have problems…
We had a similar problem with T28G’s recently, out of 23 identical phones two would keep losing registration.
We eventually found the source of the problem to be the “802.3 Energy Efficient Ethernet (EEE)” on our Cisco switch causing dropped packets. Turning that “feature” off solved our problem.

Regards,
Josh


(Daniel Friedman) #11

Hi,

Here is another tip if you do not use 802.3 EEE switches:
Change your local source port in the Yealink phones to a higher port of 5060 (5061, 5062, 5063 for example).

You can find it in the account settings of the Yealink phones.

Thank you,

Daniel Friedman
Trixton LTD.


(Greg Snover) #12

Thanks Daniel and Josh - Do have Cisco switches at one of the affected sites, but not the other. Reverted back to 11.19 this morning and so far so good - it worries me that the Yealink’s do not seem as “robust” as far as the network goes - none of my old Polycom’s or Aastra’s experienced the problem.

The problem started after updating the boxes to the current release (11.20) - but not right away, and not all the phones - not even a majority of the phones - just a couple at two sites (and come to think of it, one phone at our Office - but we assumed it was a connection problem there).

These are hard to track down when it doesn’t affect every phone.

Oh well - moving on!


(User9000) #13

Care to share the bug? We’re about to launch 70+ T46g’s and I’d hate to see this bug. We’re using 10.13.66 and Asterisk 13. Does this bug affect 13?


(Lorne Gaetz) #14

Bug report is linked above. Affects Asterisk versions 11.20.0 & 13.6.0


(User9000) #15

Thanks, I must have missed it. Looks like we’re on 13.5, so no worries. :smile:


(Giorgi Gujabidze) #16

Hello everyone,

I also have exactly the same problem, its very strange that from 59 Yealink phones the problem has only 9 of them. Thanks to Igaetz for helping me to find out the real reason.

Now I have one more question regarding to it. I checked and found that the bug is fixed 2 days ago on Asterisk site. So, can someone tell when it’ll be provided to FreePBX users? As if it’ll be soon, then instead of downgrading, it’ll better to just wait and upgrade to the newer version. As only couple of phones are affected and after restarting them, they start to work for some time. how do you think?


(Lorne Gaetz) #17

It may be a while, 11.20 is still the stable branch and the Distro updates usually lag Asterisk releases for a bit.


(User9000) #18

We’re seeing something like this too. Our T46g Yealinks claim registered but Freepbx disagrees. If I look under peers I see the extension listed but the IP address is always (Unspecified). Current Asterisk Version: 11.25.1

Rebooting the phone fixes this or logging in and disabling the account and enabling it. It only seems to be a matter of time before it happens again. Not sure if this is something Asterisk is doing or if its a Yealink bug.

No idea what’s going on here, but I’m assuming that 11.20 bug has been long fixed in 11.25.1, correct?


(User9000) #19

In case anyone else is reading this I lowered my ‘server expires’ (as Yealink calls it) from 3600 to 600 on each Yealink phone and now they are re-registering correctly. The one hour yealink default seems to be the problem here for whatever reason.


(Jeff Brubaker) #20

Wow, thanks. I was having the same issue and I THINK this solved the problem!