Yealink "Hold" function not working

Freepbx 13.0.129 Asterisk 13.18

Yealink T41S phones. They are using Endpoint Manager to provision the phones. Using the Hold button on the phone an outside call gets put on Hold and they hear music on hold. When they press the resume button on the phone they have waited up to 70 seconds for the audio to return. If they use the hold butoon again the call is resumed immediately. We found thread that told of changing Rpid in the extension settings, it was set to Yes and using the Hold button dropped the call Changing the Rpid to No allowed the call to be put on Hold, and that is where we are now. I was always under the impression that the “Hold” function on a phone was internal and really didn’t interact with Asterisk for that function. Commenta as to what is happening so I can put this to bed?


@edlentz are you saying that disabling RPID for the extension fixes your audio issue?

Yes, It would go on hold and when they tried to Resume the call it took up to 70 seconds to get audio back. This is strange

I’ve seen this recently. It was a Yealink T4x phone running an older firmware, whenever the PBX sent the INVITE with the RPID info, the phone audio would break, same thing happens when you park / retrieve a call from the parking lot. A non-Yealink device using the same extension does not have this issue.

As far as I am concerned, this is a firmware bug, which may or may not be solved by upgrading/downgrading the phone. Sending a reINVITE to a phone shouldn’t break audio, even if the INVITE is not formatted to the specific phone requirements.

There is interaction, otherwise Asterisk would not know when to play hold music to the waiting caller.

Thanks Lorne.

He initially had some problems with parking, but his network was all screwed up. We got that sorted out and he was able to park. He said and I take it with a grain of salt that it “ALL” worked 3 days ago when they were training the users. Then, “All of a sudden” it wouldn’t work. We updated the phones to the latest phone firmware available in Endpoint Manager.

I guess I hadn’t spent enough time (13 seconds maybe :slight_smile: ) on how th ephone Hold would work, but that makes sense.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.