Yealink DECT - Register Failed

I am really struggling to find and answer to this issue

I have a Yealink W52P/W56P DECT base (running firmware 25.81.0.60) that is currently happily connected to a very old elastix installation (Elastix 2.5.0/FreePBX 2.11.0 /Asterisk v11.25.0)

I am trying to to replace it with a FreePBX 16.0.40.7/Asterisk 18.20.2 installation

I can get our SNOM handsets to register, I can get our 3CX softphones to register

every time I try to connect the Yealink base I get “Register Failed”

I am not using the extension manager or auto proisioning, I am manually setting the DECT base as I always have

I have tried chan_sip and chan_pjsip neither seem to allow the base to register an extension

DECT base and FreePBX on same subnet (no routing or NAT)

looking in the Asterisk Log Files I cannot even see that the device has tried to register

using TCPDUMP I can see there is an attempt

16:20:15.032727 IP 192.168.aaa.23.sip > server.site.sip: SIP: REGISTER sip:192.168.aaa.250:5060 SIP/2.0
16:20:15.549545 IP 192.168.aaa.23.sip > server.site.sip: SIP: REGISTER sip:192.168.aaa.250:5060 SIP/2.0
16:20:16.563668 IP 192.168.aaa.23.sip > server.site.sip: SIP: REGISTER sip:192.168.aaa.250:5060 SIP/2.0

I am obviously missing something daft, if someone can throw some light on it that would be great

Thanks

We need the logs from Asterisk, typically the full log with “pjsip set logger on” enabled (I assume you have upgraded to chan_pjsip).

hi @david55,

Thanks for replying, I have just logged back in after abandoning site and coming home and the yealink extensions have now logged in, really frustrating as they have not been doing all day.

I have tried some reboots of both FreePBX and yealink and each time they are now registering.

the install was fresh so chan_pjsip is default (I assume) had to enable the chan_sip driver, I have now disabled that as I guess its not supported any longer