FreePBX | Register | Issues | Wiki | Portal | Support

XMPP upgrade failure


(Juppers) #1

NOTE: Another forum is pointing to this thread as a cause for Google Voice/Motif not working. This thread, specifically XMPP has nothing to do with Google Voice. “XMPP” is a jabber protocol and this module (Open Source) allows one to setup a Jabber server. It has nothing to do with Google Voice or Motif

Whoops \ Exception \ ErrorException (E_WARNING)
HELP
mkdir(): Permission denied
/var/www/html/admin/modules/xmpp/Xmpp.class.php
			}
		}
		fclose($log);
		out("");
		out(_("Finished updating libraries!"));
 
		if(!file_exists($varlibdir.'/xmpp')) {
			mkdir($varlibdir.'/xmpp');
		}

(Lorne Gaetz) #2

Permission issues can usually be fixed with:

fwconsole chown

(Avayax) #3

Same here, even after a fwconsole chown, I can’t upgrade xmpp, at least from GUI/module admin.


(Ben Mott) #4

I am having the same exact issue. I tried uninstalling, which resulted in an error, but let me have the ability to install the module again. It continued to have the same error as above. I also tried the fwconsole chown which didn’t resolve the issue.


(David Leger) #5

Same here… Just adding myself to see any updates.


(Matthew B) #6

I get this issue too.


(Jon Sands) #7

Same exact issue as well, first bug I’ve encountered in freepbx.

If it helps any with debugging, I was originally getting an error updating some modules, saying module “pm2” was needed but not found. It wasn’t in the list of modules to install, and I realized it was because my license didn’t have it listed as it’s a new module.

I went to Admin > System Admin > Activation, and clicked “Update Activation”. After doing this, the “process Manager” module was finally showing up in the module list to install. I installed it and then all my other modules finally updated, except for xmpp which has the problem mentioned in this thread. fwconsole chown did not help


(Pavel Zichovsky) #8

Same for me, update of XMPP module (from 13.0.14 with prosody to new 13.0.16.6 with lets chat) failed.
Rolled back to Prosody for now, waiting for fixed new xmpp version.
(For rollback to prosody after failed xmpp update I had to install prosody manualy first via yum install prosody)


(Artem Karpenko) #9

The problem is that in file Xmpp.class.php there is a public function install (). In this function variable $varlibdir is not defined. So when function tries to create directory ‘xmpp’ in the root folder it gets a ‘permission denied’.
You can get a declaration for the variable in the same file in another function:
$varlibdir = $this->freepbx->Config->get(“ASTVARLIBDIR”);
Then module will be successfully updated, but editing php file will invalidate it’s signature - and You will get a constant security warning. Developers need to correct the error php file and sign it again.


(Chasemixon) #10

You guys rock! I have been fighting with the permissions for 10 minutes trying to figure out what in the world I had done… :slight_smile: Just for poops and grins, I noticed that when the upgrade is running it removes the write permission on the file Xmpp.class.php but Artem comment makes the most sense…


(Tom L.) #11

Thanks for the answer! I will wait for an updated module.


(Joel Buhr) #12

Getting the same issue here. What do we do to fix this?


(Joel Buhr) #13

So is it recommended to just wait?


#14

My systems that were just updated are also affected.


#15

I attempted to roll back to the previous version, 13.0.14, but got this error:

XMPP cannot be upgraded:
The File “/usr/bin/prosody” must exist.
Please try again after the dependencies have been installed.

I’m just leaving xmpp disabled until they work it out…


(Tony Lewis) #16

Someone finally opened a bug report here today and we are working on this. Bug reports is how developers get things resolved.


#17

Opened yesterday and closed even though people continued reporting the issue was not resolved:

https://issues.freepbx.org/browse/FREEPBX-14620

And now reopened… Yay!


(Andrew Nagy) #18

Fixed in xmpp version 13.0.16.7


(Joel Buhr) #19

PERFECTO! Thank you


#20

I just had the same issue two days past. XMPP upgrade failed with same permissions error. Removed module completely- ran chown - reinstalled and all fine.