Xinetd not responding to GET requests


(Roomwillow) #1

I have xinetd as standard on a fresh installation of the latest freepbx, attempting to setup TFTP for management of a Cisco 8851, I was originally blaming the 8851 for not liking a file, but this appears to be an issue with xinetd, the phone receives TFTP timeouts, running the tftp client on windows with tftp -i 10.8.90.30 GET SEPxxx.cnf.xml c:\Users\Myself\Desktop results in “connect request failed” on the client, and “RRQ from 10.8.90.52 filename SEPxxx.cnf.xml” on the server.

/etc/xinetd.d/tftp is:

#default: off
#description xxxtolazytocopythisover

service tftp
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -vv -c -s /tftpboot
disable = no
per_source = 11
cps = 100 2
flags = IPv4
}

obviously systemd says service status is active, ls -l reports all the files in /tftpboot are owned by astrisk:astrisk -rw-r–r--, I’m stumped on this, for reference, heres the thread I posted on the cisco forum beforehand when I suspected an issue with a specific file, you can see the detailed Cisco error logs here:

Thanks in advance!


(Dave Burgess) #2

Have you checked the /var/log/messages log file to see what error (if any) is being generated? While TFTP is “trivial” it can still be a pain to set up. If your xinetd is spawning the tftp process correctly, you should see the GET request in the log file.

Check the permissions in the /tftpboot directory and make sure they are 777 on the directory itself and 666 on all of the files in the directory.


(system) closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.