"Wrong password" error with pjsip / webrtc

i have installed FreePBX ( Asterisk 13.12.1 ). Also i registered SSL certififate ( lets encrypt ) to my server for webrtc.

i choose “both” sip drivers at advanced settings.

i’m fighting with this issue like 2 weeks. i read and tried a lot of things and now I’m so confused.

My problems are;

when i add a new pjsip extension with default values everything works fine. i can register to my server with a softphone and no problem with sound but when i try to connect over webrtc ( sipml5 ) i always get this error.

[2017-08-21 20:01:28] NOTICE[2446]: chan_sip.c:28486 handle_request_register: Registration from '“1000” ‘sip:[email protected]’ failed for ‘xxx.xxx.xxx.xxx:19668’ - Wrong password

i search google, asterisk , freepbx forums, etc. i tried all solutions which i found nothing change. i always get that error with pjsip.

So after that i tried to add a chansip extension. i can call and speak with softphone also i can register and call over webrtc but problem is i have no sound with webrtc on both sides

i’m using default FreePBX defined ports ( This device uses PJSIP technology listening on Port 5060 (UDP), Port 5060 (TCP), Port 5061 (TLS) )

Why did i always get this error ? How can i register psjip extension with webrtc or how can i fix sound issue over chansip.

Thanks for help.

websocket only works over one channel driver, either pjsip or chansip. You can change which one in Advanced Settings.

I also tried selecting one by one then restart and test again but i had same problems. on chansip i had no sound issue, on pjsip always get “wrong pass” error.

why did i get wrong pass error. i checked conf files too. Nothing different.
Someone says that cause because of ports but i’m using 5060 default port for pjsip too.

Ps: its not an active server, i’m just working on it. i can give pws if you want to check something

thanks for answer.

i registered with pjsip extension over webrtc and now i have same problem with chansip too. No Sound both side. i watched asterisk console with verbose 10. Didnt get any error about codecs or any other things. Everything seems normal.

So i have no sound on both side problem now


For those, who still have this. This solved my problem:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.