Why is https service not running?

I recently switched to the FreePBX distro, after many, many happy years of Trixbox. When attempting to harden FreePBX for external internet access, I discovered that https-server is not running. I would normally change “Listen 443” to some other port, and then disable unencrypted traffix (Port 80).

Any particular reason why ssl is not enabled?

Bob Bevill

You should not expose the web interface to the Internet under any circumstances. I can’t think of any reason.

Options - Setup an SSL VPN

Option 2 - Use the SSH tunnel option in Putty, (very easy). You open the SSH session and you browser connects to Putty as a proxy. The HTTP requests go across the tunnel. This even works for other devices on any reachable network from the machine you are ssh’ing to.

Option 3 - Only open http to trusted remote hosts using an access list on firewall

Hi, SSL is enabled by default so its a tad odd - however when you redirect 443 you can get some “notice errors”. i usually use a firewall to redirect in order to avoid any internal issues (redirect some oddball port to 443, but ignore inbound 443 requests).

didn’t see another request and its been a week or so, did you get this solved.


FreePBX ask for loging and password everytime i try to make any changes and i am unable to make any changes.I have installed AsteriskNOW. I am very new to this please help…

Harish … Do not hijack threads.