Why does module 'update all' install diverse 'not installed' modules, commercial and not commercial

Why does module ‘upgrade all’ install diverse ‘not installed’ modules, commercial and not commercial.

I have uninstalled and removed all unwanted modules for me.
Now if I choose ‘check online’ I have 1 update.

If I choose ‘Upgrade all’, suddenly several ‘uninstalled modules’ are set as ‘update and enable’

That would be unwanted behavior of the upgrade modules.

Why is this, and can it be fixed, or for sure, set more info on this, that ‘uninstalled modules’ suddenly be installed and enabled.

See screenshot

It’s been like this forever, you can file a feature request to change it.

Or update from command line, which doesn’t have this behavior and also resolves all dependencies automatically.

You can change this behavior at Admin -> Module Admin -> Scheduler and Alerts

I don’t see such a setting. Unless in a very recent update?

There is no ‘update all’ button. There is an ‘Upgrade all’ button.

The unwanted installation of ALL modules is due to enabling ‘Automatic Module Updates’ at:

Admin -> Module Admin -> Scheduler and Alerts

If this option is changed to ‘Email Only’, you will not experience the installation of unwanted modules.

It’s obviously ludicrous that enabling ‘Automatic Module Updates’ implies installing ALL available modules, but the response from developers is ‘It’s been this way from the beginning, so we don’t want to change it.’

Disable unwanted modules.

When this particular interface was written, it was deemed that the system would install all of the modules, disabled or not. This way, if you decided you wanted to enable a module, you didn’t have to install it. Basically, the process we’ve always used is to disable modules that we don’t need (rather than deleting them).

If you want to tilt at this particular windmill - knock yourself out. It’s been a head-shaker for years. Disabling the modules works and keeps the system happy.

Disabling tons of unwanted modules and wasting the space they occupy isn’t a sensible solution to me. Plus I don’t want updates happening automatically in the middle of the night, breaking things, as is happening more and more frequently lately. I’ll continue to disable ‘Automatic Module Updates’ as one of the first installation steps and sleep a whole lot better at night.

1 Like

I think it is not a logical answer to put it like:
It is like this, since the beginning, so we do not want to change it.
If I ask my kids why they do something, they say, because we have always done it this way :slight_smile:

So the ‘upgrade all’ button is not upgrade all, but do something strange that we cannot describe why, but it has ben like forever so live with it and disable it or go to the cli???

I think this is humor :slight_smile:
What do you think?

Why don’t you just disable automatic updates and enable security updates only? The dashboard shows you the available updates anyway.
And as you said…lately updates broke things…so I would suggest that you reload the module admin and choose the modules you want to update manually…

Thank you for the answers.
I do know hor Freepbx works, and I Disabled all unwanted modules.
But I just wanted to kn ow why some function , functions completely different as it says.

update vs upgrade

„Upgrade all“…really upgrades ALL modules of the freePBX distro :wink:

I understand upgrade vs update vs not-installed and download-install some not installed modules.
I think upgrade or update should not imply download-install some (not-installed modules.

That’s not true.

Clicking upgrade all will install modules that wasn’t installed.

At least it worked so last time I checked.

It happened to me twice. So I disabled that setting. Granted it was right after 14 came out, and I did zero troubleshooting.

Not here. I ALWAYS click ‘Upgrade all’ when there are one or more modules available to upgrade and I NEVER get anything new installed. “Download all” will queue up and install all modules that weren’t installed (if you follow through with “Process” and “Confirm”), but not ‘Upgrade all’.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.