Why did I get charged for a SIP call?

I called [email protected] thinking that the call would be free, but my VOIP service provider actually charged me for it. I was told that they saw the SIP URI as a regular call to 559-726-1200. Is there some good documentation that explains how to place a SIP call without incurring charges?


Why would you send that call to your SIP provider? That’s a URI dial and it simply uses your Internet connection.

Try putting SIP/[email protected] in the dial field of a custom extension. When you dial the extension it should connect you with that service.

in the dial field of a custom e

When I go into Custom Extensions in freePBX, the only fields I see are:

Custom Extension

There doesn’t seem to be a “dial field” as you mentioned. Did I do something wrong?

Thank you Sir.

Applications > Extension > add Extension > select in the device dropdown “[other (custom) device]”

Then input your Your Extension and Display Name, and then in the “This device uses custom technology.” dial field put in your sip uri in this format “sip/[email protected]” You will then be able to dial that URI using the extension you defined.

Ok, I followed your directions precisely Preston. I didn’t touch any other options on the page for setting up a new extension. I ended up using extension # 2001. Once I saved the settings and clicked the red button, then dialed 2001, all I got was a busy signal. I used sip/[email protected] By the way, when I went back into the settings for this new extension, the field where I pasted my SIP URI was gone. Is that normal?


No that’s not normal, it should remain, however I just tested it on my system and it works fine I can connect to that URI just fine.

Maybe I have a version of freePBX that needs updating because it has some bugs?

Your Linux Distribution: (Debian wheezy/sid)
Your FreePBX version: (2.10.1)

nestman, How did you install FreePBX? Did you follow these instructions? http://wiki.freepbx.org/display/HTGS/Installing+FreePBX+on+Debian+Wheezy#InstallingFreePBXonDebianWheezy-Finally,onelastmodandstartFreePBX.

It just came on an IP PBX Mini device that I bought on ebay. So it was already configured on the SD memory card.

Hello? Is there anyone there?

From what you have told us it sounds like you are running FreePBX on a Raspberry Pi… I just tested SIP URI dialing on mine and it works fine, even to the number you are trying to dial, so something is configured wrong, hopefully you didn’t pay too much for it, with a power supply, SD card and Raspberry Pi model B, and a case it should only set you back about 60-70 with shipping. I’m not sure which distro came installed on that, but that’s easy enough to fix by following these instructions http://nerdvittles.com/?p=5527 and getting the latest version installed, with hopefully a fix for your problem.

Not sure what you are looking for. Your questions are asked and answered.

You dismissed the question on how the system was installed. We can’t support a non-standard install on proprietary hardware.

It would seem that the vendor should help you out.

You also could consider installing genuine FreePBX if possible.