Whoops \ Exception \ ErrorException (E_WARNING) Illegal string offset 'fail2ban_ban_time'


(Bifur) #22

fwconsole ma disable extensionroutes
fwconsole ma remove firewall sysadmin
fwconsole reload
fwconsole ma downloadinstall sysadmin firewall
fwconsole ma enable extensionroutes
fwconsole reload
/var/www/html/admin/modules/sysadmin/hooks/fail2ban-apache-config
service fail2ban start

This worked for me. I had to do the fwconsole ma remove parts with a force flag (-f) because it complained of dependencies.

Let’s see if it continues to work.

Thank you!


(Sentinel) #23

Not working for me. I get into the firewall wizard, then get the exact same message. Ugh


(Sentinel) #24

what I notice on restore are the following issues.

No Endpoint manager installed or System Admin. After I install them, I get the Illegal string offset ‘fail2ban_ban_time’


(Sentinel) #25

yes it’s running


(Bob Reiber) #26

I ran all those commands and rebooted the pbx for good measure and no change for me.


(Sentinel) #27

Same for me.


(Franck Danard) #28

https://issues.freepbx.org/browse/FREEPBX-22651
As I’m working on this module, I assigned the ticket to me.
I will test it and fixe it asap.


(Franck Danard) #29

Can you tell me if your system is FreePBX distro or FreePBX install under another type of OS?
If sysadmin is installed or not?
Also, On the Whoops error, can you past the entier logs to get the line numbers where the issue come from.


(Franck Danard) #30

Oups I missed this part.
Yes maybe.
Sysadmin has a part of intrusion detection code.
If this one is missing at a moment, Maybe there’s something which breaks F2B.
Tell me what’s the kind of system was before (with sysadmin or without) and what’s the kind of system after (with sysadmin or without)
FreePBX distro or non-distro?


(Sentinel) #31

Distro. It was a free pbx 15 with endpoint and system admin. Even renewed them to make them current, did a fresh backup. Restore had same results


(Franck Danard) #32

Weird, I’m not able to reproduce.
Can you read your message on PM please and follow the step please.
I would like to check something.


(Franck Danard) #33

Also, what you can do.

  • Back to your system A.
  • Make module updates : fwconsole ma updateall
  • Make a backup
  • Go to system B
  • Make module updates : fwconsole ma updateall
  • Make a Restore.

(Sentinel) #34

That is the exact steps I make with same issue


(Franck Danard) #35

Hmmm ok.
Well. Need to know where the issue come from


(Franck Danard) #36

There’s something weird.
The fact to remove sysadmin on the first system and reinstall it, then you’ve got all data in the backup file.
I will continue to test it tomorrow morning


(Sentinel) #37

It only removes it after the restore. Both systems completely update to date. If you reinstall them, you lose all Endpoint settings and sysadmin settings as well as firewall. I want to also say I did 4 system restores about two weeks ago with no issues. My guess is a module update has changed causing these issues.


(Franck Danard) #38

Yep, I will continue to test and check with QA team tomorrow morning.
Don’t worry, I will update you
Have a good day :wink:


(Franck Danard) #39

There is a Pull Request on going.
Please take a look on the new version from EDGE repos.
Change log should be: FREEI-3684 Whoops exception on fail2ban_ban_time after restoring

Steps:

  • Update sysadmin module on all systems.
  • Make a backup data from system 1
  • Restore data to system 2

(Sentinel) #40

testing now


(Bob Reiber) #41

So we need to scrap the VM and move to a new one?