Where is the template in EPM for the new Sangoma P370?

I cannot find the template for the new Sangoma P370 in EPM. This is a (updated) freePBX 16 machine. Where is it? Where do I get it? The default-digium template doesnt have it.
P370

Shows up in mine on Freepbx 15. Under EPM, Sangoma, D&P Series Phones, digium_default template, Models, and click on P370 to enable it.
Did you run fwconsole ma upgradeall ?

Mine looks like this

Yes I did fwconsole ma upgradeall. Any other source where I get the newest template?

What ver of EPM? It should be there.

Is this not the newest version? Maybe I once bought EPM on this machine…cannot remember…is there a lock somewhere? Thanks!

EDIT: FreePBX 16.0.21.8

This is an issue with EPM, I’ve escalated to Engineering.

1 Like

Same issue in EPM 15.0.50.1 (P370 not showing up)

Is DPMA enabled in the EPM ? Please refer to EPM-DPMA for Digium Phones - PBX GUI - Documentation

Regards
Kapil

D’oh! Confirmed, I see it now. When I enabled DPMA in EPM Global Settings you must click ‘Save Global’ after waiting for DPMA to install. Once DPMA module is installed and enabled in global settings, the D80 and P370 show up as models in the template.

Thanks @kgupta

I tried to enable DPMA in EPM, but it crashed with a message regarding the Digium phones config module, which isn’t available in freePBX 16.

EDIT:

Checking FreePBX digium phone module status...
Done.

{"error":{"type":"Whoops\\Exception\\ErrorException","message":"file_put_contents(\/etc\/asterisk\/res_digium_phone_general.conf): failed to open stream: Permission denied","file":"\/var\/www\/html\/admin\/modules\/endpoint\/DpmaModel.class.php","line":264}}

Ok…that’s now a different error…I fooled around with digium config files :wink:
I will look at it tomorrow…thanks!

EDIT: I had to do a fwconsole chown…all is good now, thanks @lgaetz and @kgupta

Worked for me after turning on DPMA. Thanks @kgupta

1 Like

Permission errors are usually fixed with

fwconsole chown
1 Like

I was able to test the P370, thanks. Audio is good, touch screen sensitive and reliable…pretty much a Digium D80 2.0. Didn’t have enough time to set everything up.
I was not able to use the contact manager, but this might be my fault of not understanding the concept. Is the P370 still using the DPMA apps? Why do I have to activate the phone apps? Is it a mixture of both? I didn’t find a short manual of how to set up this new phone with freePBX.

All P phones only use DPMA apps, but they still use PBX resources provided by the Phone Apps module and the same Apache ports.

1 Like

Just realized I had the same problem with the D80 half a year ago and @kgupta told me the same thing “enable DPMA”! I am getting old & grey…just like my avatar :wink:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.