Where are my Voicemails?

I’m using FreePBX 15.0.23 (Asterisk 16.24.1) and ever since I upgraded to it we have not been able to login to the web interface and see our voice mails. When we go to the IP of the server we can log in with our extension number / password, but there is no option for voicemails, only the ability to add different modules (none of which have anything to do with voice mails). That was an inconvenience but we manage to live without the Web interface because we could still access the VM’s directly through the phone.

Last night I ran an update on FreePBX and now the phones can’t even dial to their own Voicemails.

Really need help with this, I have no idea where to start. I can see in the Admin Panel that the extensions HAVE the voice mails but I just don’t know how to listen / access them

Thank you

What phones? What do the logs say when you test pressing the voicemail button? Providing Great Debug - Support Services - Documentation

1 Like

Sounds like the voicemail module isn’t installed. What’s the output of

fwconsole ma list
1 Like

voicemail module is listed:
voicemail 15.0.18.49 - Enabled - GPLv3+
voicemail_report 15.0.7 | enabled | commercial

How can I just look at the voice mails and listen to them? in the old version of FreePBX when you logged in as a user / an extension the first thing you saw was the voice mails, now I can’t find any place to actually listen to them.

So assuming that vm is enabled in the GUI for the extensions, and assuming that you have not restricted access to the voicemail widget in UCP, then check asterisk for vm. Are you able to get a list of extensions with configured voicemails from:

asterisk -x "voicemail show users for default"
1 Like

Yup it shows all the users and their voice mails. Most have 0, some have 2, one of them has 19. these voice mails are VERY important

Okay, so need to translate this:

the phones can’t even dial to their own Voicemails.

Into a call trace. Please share a call trace of a failed call to VM using pastebin: Providing Great Debug - Support Services - Documentation

1 Like

I think this might have done the trick!

I also went into ADMIN → USER MANAGEMENT → GROUPS
Edit the PBX Internal Group → UCP
And enabled all the voice mail access, then I went to each user and did it as well.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.