What the...!?!

OK so I was going to do some work today on our FreePBX server. Type in the address and the screen with the three selections, Voicemail & Recordings (ARI), Flash Operator Panel (FOP), and FreePBX Administration comes up just like normal.

I clicked on Admin and nothing, blank white browser, (firefox, chrome, safari). Tried the ARI, same thing. The FOP works just fine however. I tried two different computers to access and same results, even tried reseting the server.

I’m using the AsteriskNow 1.6 distro with CentOS upgraded to 5.6

Any thoughts?

Check your /var/log/httpd/error_log for any clues

I have a similar issue and thought this may help. This is in the http error log.

I am Asterisk 1.8 - PIAF

From various pages I get a blank screen when I try to get to the Voicemail records screen. No errors on page just blank screen.

[Wed Aug 24 07:48:18 2011] [error] [client] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/index.php on line 264

Any ideas?


From where do you try to access this? Is it in FreePBX, the tab called Recordings?

Or if I click on the Voicemail & Recordings button on PIAF splash screen (Users and Admin.

I have tried all browsers - IE8, SAfari, Chrome. All blank screens


From the FreePBX Recordings Tab also.


Check that you have updated all modules in Module Admin. Especially FreePBX ARI Framework. Check your /var/log/httpd/error_log
Enable Debug in Advanced Settings, set Disable FreePBX Log to False, click on green check icon to save the setting.
Then try to access Recordings, check /tmp/freepbx_debug.log

Did yours steps

The ARI module is All others are 2.9.x and nothing wanted upgrading. I did force a re-download of the FREEPBX modules earlier.

2011-Aug-24 11:15:04 /var/www/html/admin/modules/googlevoice/functions.inc.php:29
[WARNING]: require_once(libraries/extensions.class.php) [function.require-once]: failed to open stream: No such file or directory

Nothing in error.log with same timestamps.


Delete module googlevoice.
Download version 0.1.1 from http://www.freepbx.org/trac/browser/contributed_modules/release/googlevoice-0.1.1.tgz

Hi Mikael,

I am not sure I understand how to implement this.

On Module Admin I can uninstall GoogleVoice.

But how do I install the new version?

Sorry - A little new at this.


Download it from the link above to your desktop, go to Module Admin, click on Upload module, browse for the new one, and upload. Then find it in the list and do an upgrade on it.

Looks like I should just replace the modules .




Fixed it.